aboutsummaryrefslogtreecommitdiff
path: root/games/nethack34
diff options
context:
space:
mode:
Diffstat (limited to 'games/nethack34')
-rw-r--r--games/nethack34/Makefile33
-rw-r--r--games/nethack34/distinfo1
-rw-r--r--games/nethack34/files/patch-ab49
-rw-r--r--games/nethack34/files/patch-ac47
-rw-r--r--games/nethack34/files/patch-ad20
-rw-r--r--games/nethack34/files/patch-ae37
-rw-r--r--games/nethack34/files/patch-af12
-rw-r--r--games/nethack34/pkg-comment1
-rw-r--r--games/nethack34/pkg-descr13
-rw-r--r--games/nethack34/pkg-plist124
10 files changed, 0 insertions, 337 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
deleted file mode 100644
index 4d4edb7ee19e..000000000000
--- a/games/nethack34/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-# New ports collection makefile for: nethack
-# Version required: 3.2.2
-# Date created: 27 March 1995
-# Whom: asami
-#
-# $FreeBSD$
-#
-
-DISTNAME= nethack-3.2.2
-CATEGORIES= games
-MASTER_SITES= ftp://ftp.wtower.com/nethack/sources/ \
- ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= nethack
-
-MAINTAINER= ports@FreeBSD.org
-
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
-
-USE_GMAKE= yes
-MAN6= dgn_comp.6 dlb.6 lev_comp.6 nethack.6 recover.6
-
-pre-configure:
- @cd ${WRKSRC}/sys/unix; ${SH} setup.sh
-
-post-install:
- @cd ${WRKSRC}/doc; ${CHMOD} 644 *.6
- @cd ${WRKSRC}/doc; PREFIX=${PREFIX} ${MAKE} manpages
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/nethack
- ${CP} ${WRKSRC}/doc/Guidebook.txt ${PREFIX}/share/doc/nethack
-.endif
-
-.include <bsd.port.mk>
diff --git a/games/nethack34/distinfo b/games/nethack34/distinfo
deleted file mode 100644
index e5173626ad09..000000000000
--- a/games/nethack34/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (nethack-3.2.2.tar.gz) = c85de4d14453b3a2d182d1dfc2ca04df
diff --git a/games/nethack34/files/patch-ab b/games/nethack34/files/patch-ab
deleted file mode 100644
index a22424c84079..000000000000
--- a/games/nethack34/files/patch-ab
+++ /dev/null
@@ -1,49 +0,0 @@
---- sys/unix/Makefile.src.orig Wed Dec 11 05:20:09 1996
-+++ sys/unix/Makefile.src Sun Mar 21 17:50:08 1999
-@@ -124,8 +124,8 @@
- # flags for debugging:
- # CFLAGS = -g -I../include
-
--CFLAGS = -O -I../include
--LFLAGS =
-+CFLAGS += -O -I../include -I${X11BASE}/include
-+LFLAGS = -L${X11BASE}/lib
-
-
- # Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
-@@ -146,8 +146,8 @@
- winmisc.o winstat.o wintext.o winval.o tile.o
- #
- #
--WINSRC = $(WINTTYSRC)
--WINOBJ = $(WINTTYOBJ)
-+WINSRC = $(WINTTYSRC) $(WINX11SRC)
-+WINOBJ = $(WINTTYOBJ) $(WINX11OBJ)
-
- # on some systems the termcap library is in -ltermcap or -lcurses
- # on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
-@@ -167,13 +167,13 @@
- #
- # libraries for X11
- # If USE_XPM is defined in config.h, you will also need -lXpm here.
--WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11
-+WINX11LIB = -lXaw -lXmu -lXext -lXt -lX11 -lXpm
- # WINX11LIB = -lXaw -lXmu -lXt -lX11
- # WINX11LIB = -lXaw -lXmu -lXext -lXt -lXpm -lX11 -lm
- # WINX11LIB = -lXaw -lXmu -lXpm -lXext -lXt -lX11 -lSM -lICE -lm # BSD/OS 2.0
- #
- #
--WINLIB = $(WINTTYLIB)
-+WINLIB = $(WINTTYLIB) $(WINX11LIB)
-
- # any other strange libraries your system needs (for Sysunix only -- the more
- # specialized targets should already be right)
-@@ -197,7 +197,7 @@
- # IRIX 4.0.x needs -lsun if NIS (YP) is being used for passwd file lookup
- # LIBS = -lsun
- #
--LIBS =
-+LIBS = -lSM -lICE
-
- # make NetHack
- GAME = nethack
diff --git a/games/nethack34/files/patch-ac b/games/nethack34/files/patch-ac
deleted file mode 100644
index ee05125afe6c..000000000000
--- a/games/nethack34/files/patch-ac
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -ruN ./include/config.h ../nethack-3.2.2/include/config.h
---- ./include/config.h Wed Dec 11 05:20:07 1996
-+++ ../nethack-3.2.2/include/config.h Sun Mar 21 17:25:02 1999
-@@ -211,7 +211,7 @@
- * Some combinations make no sense. See the installation document.
- */
- #define TTY_GRAPHICS /* good old tty based graphics */
--/* #define X11_GRAPHICS /* X11 interface */
-+#define X11_GRAPHICS /* X11 interface */
-
- /*
- * Define the default window system. This should be one that is compiled
-@@ -256,7 +256,7 @@
- * would allow:
- * xpmtoppm <x11tiles.xpm | pnmscale 1.25 | ppmquant 90 >x11tiles_big.xpm
- */
--/* # define USE_XPM /* Disable if you do not have the XPM library */
-+# define USE_XPM /* Disable if you do not have the XPM library */
- # ifdef USE_XPM
- # define GRAPHIC_TOMBSTONE /* Use graphical tombstone (rip.xpm) */
- # endif
-@@ -296,12 +296,12 @@
-
- #ifdef UNIX
- /* path and file name extension for compression program */
--# define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
--# define COMPRESS_EXTENSION ".Z" /* compress's extension */
-+/* # define COMPRESS "/usr/ucb/compress" /* Lempel-Ziv compression */
-+/* # define COMPRESS_EXTENSION ".Z" /* compress's extension */
-
- /* An example of one alternative you might want to use: */
--/* # define COMPRESS "/usr/local/bin/gzip" /* FSF gzip compression */
--/* # define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
-+# define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
-+# define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
- #endif
- #ifndef COMPRESS
- # define INTERNAL_COMP /* control use of NetHack's compression routines */
-@@ -331,7 +331,7 @@
- * otherwise it will be the current directory.
- */
- # ifndef HACKDIR
--# define HACKDIR "/usr/games/lib/nethackdir" /* nethack directory */
-+# define HACKDIR "/usr/local/share/nethack" /* nethack directory */
- # endif
-
- /*
diff --git a/games/nethack34/files/patch-ad b/games/nethack34/files/patch-ad
deleted file mode 100644
index 4ff9c983d5ca..000000000000
--- a/games/nethack34/files/patch-ad
+++ /dev/null
@@ -1,20 +0,0 @@
---- include/system.h.orig Mon Nov 4 08:01:25 1996
-+++ include/system.h Sat Jun 19 16:18:02 1999
-@@ -80,7 +80,7 @@
- # if !defined(SUNOS4) || defined(RANDOM)
- E void FDECL(srandom, (unsigned int));
- # else
--# ifndef bsdi
-+# if !defined(bsdi) && !defined(__FreeBSD__)
- E int FDECL(srandom, (unsigned int));
- # endif
- # endif
-@@ -510,7 +510,7 @@
- # if defined(ULTRIX) || defined(SYSV) || defined(MICRO) || defined(VMS) || defined(MAC)
- E time_t FDECL(time, (time_t *));
- # else
--E long FDECL(time, (time_t *));
-+E time_t FDECL(time, (time_t *));
- # endif /* ULTRIX */
-
- #ifdef VMS
diff --git a/games/nethack34/files/patch-ae b/games/nethack34/files/patch-ae
deleted file mode 100644
index b5c24ee2719d..000000000000
--- a/games/nethack34/files/patch-ae
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -ruN ./include/unixconf.h ../nethack-3.2.2/include/unixconf.h
---- ./include/unixconf.h Wed Dec 11 05:20:08 1996
-+++ ../nethack-3.2.2/include/unixconf.h Sun Mar 21 17:25:02 1999
-@@ -31,7 +31,7 @@
-
- /* define any of the following that are appropriate */
- /* #define SVR4 /* use in addition to SYSV for System V Release 4 */
--#define NETWORK /* if running on a networked system */
-+/* #define NETWORK /* if running on a networked system */
- /* e.g. Suns sharing a playground through NFS */
- #define SUNOS4 /* SunOS 4.x */
- /* #define LINUX /* Another Unix clone */
-@@ -42,12 +42,12 @@
- /* #define AIX_31 /* In AIX 3.1 (IBM RS/6000) use BSD ioctl's to gain
- * job control (note that AIX is SYSV otherwise)
- * Also define this for AIX 3.2 */
--/* #define TEXTCOLOR /* Use System V r3.2 terminfo color support */
-+#define TEXTCOLOR /* Use System V r3.2 terminfo color support */
- /* and/or ANSI color support on termcap systems */
- /* and/or X11 color */
--/* #define POSIX_JOB_CONTROL /* use System V / POSIX job control
-+#define POSIX_JOB_CONTROL /* use System V / POSIX job control
- * (e.g., VSUSP) */
--/* #define POSIX_TYPES /* use POSIX types for system calls and termios */
-+#define POSIX_TYPES /* use POSIX types for system calls and termios */
- /* define for many recent OS releases, including
- * those with specific defines (since types are
- * changing toward the standard from earlier chaos).
-@@ -125,7 +125,7 @@
- * A stat system call is done on the mailbox every MAILCKFREQ moves.
- */
-
--#define MAIL /* Deliver mail during the game */
-+/* #define MAIL /* Deliver mail during the game */
-
- /* The Andrew Message System does mail a little differently from normal
- * UNIX. Mail is deposited in the user's own directory in ~/Mailbox
diff --git a/games/nethack34/files/patch-af b/games/nethack34/files/patch-af
deleted file mode 100644
index 75c84c235c88..000000000000
--- a/games/nethack34/files/patch-af
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN ./sys/unix/Makefile.doc ../nethack-3.2.2/sys/unix/Makefile.doc
---- ./sys/unix/Makefile.doc Wed Dec 11 05:20:08 1996
-+++ ../nethack-3.2.2/sys/unix/Makefile.doc Sun Mar 21 17:25:02 1999
-@@ -31,7 +31,7 @@
-
-
- GAME = nethack
--MANDIR = /usr/man/man6
-+MANDIR = ${PREFIX}/man/man6
- MANEXT = 6
-
- # manual installation for most BSD-style systems
diff --git a/games/nethack34/pkg-comment b/games/nethack34/pkg-comment
deleted file mode 100644
index 70ca7a893988..000000000000
--- a/games/nethack34/pkg-comment
+++ /dev/null
@@ -1 +0,0 @@
-A dungeon explorin', slashin', hackin' game
diff --git a/games/nethack34/pkg-descr b/games/nethack34/pkg-descr
deleted file mode 100644
index 52e265b8886f..000000000000
--- a/games/nethack34/pkg-descr
+++ /dev/null
@@ -1,13 +0,0 @@
-This is nethack. You and your puppy (or kitten) will explore the deep
-dungeons to retrieve the long-lost magical item that causes so much
-trouble to anyone.
-
-Take care, and try not to miss meals.
-
-WWW: http://www.win.tue.nl/games/roguelike/nethack/
-
-- Satoshi
-asami@cs.berkeley.edu
-
-P.S. There is a newsgroup "rec.games.roguelike.nethack" if you are
- truly interested.
diff --git a/games/nethack34/pkg-plist b/games/nethack34/pkg-plist
deleted file mode 100644
index adcec9cf84f8..000000000000
--- a/games/nethack34/pkg-plist
+++ /dev/null
@@ -1,124 +0,0 @@
-bin/nethack
-share/nethack/nethack
-@exec mkdir %D/share/nethack/save
-@exec chmod -R 775 %D/share/nethack
-@exec chmod 2755 %D/share/nethack/nethack
-@exec chown games.games %D/share/nethack/save
-@unexec rm -rf %D/share/nethack/save
-share/doc/nethack/Guidebook.txt
-share/nethack/pet_mark.xbm
-share/nethack/rip.xpm
-share/nethack/x11tiles
-share/nethack/A-filla.lev
-share/nethack/A-fillb.lev
-share/nethack/A-goal.lev
-share/nethack/A-locate.lev
-share/nethack/A-start.lev
-share/nethack/B-filla.lev
-share/nethack/B-fillb.lev
-share/nethack/B-goal.lev
-share/nethack/B-locate.lev
-share/nethack/B-start.lev
-share/nethack/C-filla.lev
-share/nethack/C-fillb.lev
-share/nethack/C-goal.lev
-share/nethack/C-locate.lev
-share/nethack/C-start.lev
-share/nethack/E-filla.lev
-share/nethack/E-fillb.lev
-share/nethack/E-goal.lev
-share/nethack/E-locate.lev
-share/nethack/E-start.lev
-share/nethack/H-filla.lev
-share/nethack/H-fillb.lev
-share/nethack/H-goal.lev
-share/nethack/H-locate.lev
-share/nethack/H-start.lev
-share/nethack/K-filla.lev
-share/nethack/K-fillb.lev
-share/nethack/K-goal.lev
-share/nethack/K-locate.lev
-share/nethack/K-start.lev
-share/nethack/P-filla.lev
-share/nethack/P-fillb.lev
-share/nethack/P-goal.lev
-share/nethack/P-locate.lev
-share/nethack/P-start.lev
-share/nethack/R-filla.lev
-share/nethack/R-fillb.lev
-share/nethack/R-goal.lev
-share/nethack/R-locate.lev
-share/nethack/R-start.lev
-share/nethack/S-filla.lev
-share/nethack/S-fillb.lev
-share/nethack/S-goal.lev
-share/nethack/S-locate.lev
-share/nethack/S-start.lev
-share/nethack/T-filla.lev
-share/nethack/T-fillb.lev
-share/nethack/T-goal.lev
-share/nethack/T-locate.lev
-share/nethack/T-start.lev
-share/nethack/V-filla.lev
-share/nethack/V-fillb.lev
-share/nethack/V-goal.lev
-share/nethack/V-locate.lev
-share/nethack/V-start.lev
-share/nethack/W-filla.lev
-share/nethack/W-fillb.lev
-share/nethack/W-goal.lev
-share/nethack/W-locate.lev
-share/nethack/W-start.lev
-share/nethack/air.lev
-share/nethack/asmodeus.lev
-share/nethack/astral.lev
-share/nethack/baalz.lev
-share/nethack/bigrm-1.lev
-share/nethack/bigrm-2.lev
-share/nethack/bigrm-3.lev
-share/nethack/bigrm-4.lev
-share/nethack/bigrm-5.lev
-share/nethack/castle.lev
-share/nethack/cmdhelp
-share/nethack/data
-share/nethack/dungeon
-share/nethack/earth.lev
-share/nethack/fakewiz1.lev
-share/nethack/fakewiz2.lev
-share/nethack/fire.lev
-share/nethack/help
-share/nethack/hh
-share/nethack/history
-share/nethack/juiblex.lev
-share/nethack/knox.lev
-share/nethack/license
-share/nethack/medusa-1.lev
-share/nethack/medusa-2.lev
-share/nethack/minefill.lev
-share/nethack/minend-1.lev
-share/nethack/minend-2.lev
-share/nethack/minetn-1.lev
-share/nethack/minetn-2.lev
-share/nethack/opthelp
-share/nethack/options
-share/nethack/oracle.lev
-share/nethack/oracles
-share/nethack/orcus.lev
-share/nethack/quest.dat
-share/nethack/rumors
-share/nethack/sanctum.lev
-share/nethack/tower1.lev
-share/nethack/tower2.lev
-share/nethack/tower3.lev
-share/nethack/valley.lev
-share/nethack/water.lev
-share/nethack/wizard1.lev
-share/nethack/wizard2.lev
-share/nethack/wizard3.lev
-share/nethack/wizhelp
-@mode 664
-share/nethack/logfile
-share/nethack/record
-share/nethack/perm
-@dirrm share/nethack
-@dirrm share/doc/nethack