aboutsummaryrefslogtreecommitdiff
path: root/games/prismlauncher/files
diff options
context:
space:
mode:
Diffstat (limited to 'games/prismlauncher/files')
-rw-r--r--games/prismlauncher/files/extra-patch-libraries_javacheck_CMakeLists.txt11
-rw-r--r--games/prismlauncher/files/extra-patch-libraries_launcher_CMakeLists.txt11
-rw-r--r--games/prismlauncher/files/patch-launcher_minecraft_LaunchProfile.cpp18
-rw-r--r--games/prismlauncher/files/patch-launcher_minecraft_MinecraftInstance.cpp20
-rw-r--r--games/prismlauncher/files/patch-launcher_ui_pages_global_AccountListPage.cpp19
5 files changed, 79 insertions, 0 deletions
diff --git a/games/prismlauncher/files/extra-patch-libraries_javacheck_CMakeLists.txt b/games/prismlauncher/files/extra-patch-libraries_javacheck_CMakeLists.txt
new file mode 100644
index 000000000000..58dca6f362f4
--- /dev/null
+++ b/games/prismlauncher/files/extra-patch-libraries_javacheck_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libraries/javacheck/CMakeLists.txt.orig 2024-06-18 18:07:06 UTC
++++ libraries/javacheck/CMakeLists.txt
+@@ -4,7 +4,7 @@ set(CMAKE_JAVA_JAR_ENTRY_POINT JavaCheck)
+
+ include(UseJava)
+ set(CMAKE_JAVA_JAR_ENTRY_POINT JavaCheck)
+-set(CMAKE_JAVA_COMPILE_FLAGS -target 7 -source 7 -Xlint:deprecation -Xlint:unchecked)
++set(CMAKE_JAVA_COMPILE_FLAGS -target 8 -source 8 -Xlint:deprecation -Xlint:unchecked)
+
+ set(SRC
+ JavaCheck.java
diff --git a/games/prismlauncher/files/extra-patch-libraries_launcher_CMakeLists.txt b/games/prismlauncher/files/extra-patch-libraries_launcher_CMakeLists.txt
new file mode 100644
index 000000000000..35c7badf6a7d
--- /dev/null
+++ b/games/prismlauncher/files/extra-patch-libraries_launcher_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libraries/launcher/CMakeLists.txt.orig 2024-06-18 18:07:06 UTC
++++ libraries/launcher/CMakeLists.txt
+@@ -4,7 +4,7 @@ set(CMAKE_JAVA_JAR_ENTRY_POINT org.prismlauncher.Entry
+
+ include(UseJava)
+ set(CMAKE_JAVA_JAR_ENTRY_POINT org.prismlauncher.EntryPoint)
+-set(CMAKE_JAVA_COMPILE_FLAGS -target 7 -source 7)
++set(CMAKE_JAVA_COMPILE_FLAGS -target 8 -source 8)
+
+ set(SRC
+ org/prismlauncher/EntryPoint.java
diff --git a/games/prismlauncher/files/patch-launcher_minecraft_LaunchProfile.cpp b/games/prismlauncher/files/patch-launcher_minecraft_LaunchProfile.cpp
new file mode 100644
index 000000000000..3d00cebbefd3
--- /dev/null
+++ b/games/prismlauncher/files/patch-launcher_minecraft_LaunchProfile.cpp
@@ -0,0 +1,18 @@
+# Patch taken from er2off: https://github.com/er2off/freebsd-ports
+--- launcher/minecraft/LaunchProfile.cpp.orig 2023-11-27 12:45:04 UTC
++++ launcher/minecraft/LaunchProfile.cpp
+@@ -344,6 +344,14 @@ void LaunchProfile::getLibraryFiles(const RuntimeConte
+ jars.clear();
+ nativeJars.clear();
+ for (auto lib : getLibraries()) {
++#ifdef Q_OS_FREEBSD
++ // HACKHACK: use system lwjgl3 until mojang will fix it
++ QString artifact = lib->artifactId();
++ if (artifact.startsWith("lwjgl") && lib->version().startsWith("3.")) {
++ jars += "%%LOCALBASE%%/share/java/classes/lwjgl3/" + artifact + ".jar";
++ continue;
++ }
++#endif
+ lib->getApplicableFiles(runtimeContext, jars, nativeJars, native32, native64, overridePath);
+ }
+ // NOTE: order is important here, add main jar last to the lists
diff --git a/games/prismlauncher/files/patch-launcher_minecraft_MinecraftInstance.cpp b/games/prismlauncher/files/patch-launcher_minecraft_MinecraftInstance.cpp
new file mode 100644
index 000000000000..1f8887bc7703
--- /dev/null
+++ b/games/prismlauncher/files/patch-launcher_minecraft_MinecraftInstance.cpp
@@ -0,0 +1,20 @@
+# Patch taken from er2off: https://github.com/er2off/freebsd-ports
+--- launcher/minecraft/MinecraftInstance.cpp.orig 2023-11-27 12:44:40 UTC
++++ launcher/minecraft/MinecraftInstance.cpp
+@@ -305,7 +305,16 @@ QString MinecraftInstance::getNativePath() const
+
+ QString MinecraftInstance::getNativePath() const
+ {
++#ifdef Q_OS_FREEBSD
++ Version instance_ver{ getPackProfile()->getComponentVersion("net.minecraft") };
++ QDir natives_dir;
++ if (instance_ver < Version("1.13.0"))
++ natives_dir = QDir("%%LOCALBASE%%/lib/lwjgl/");
++ else
++ natives_dir = QDir("%%LOCALBASE%%/lib/lwjgl3/");
++#else
+ QDir natives_dir(FS::PathCombine(instanceRoot(), "natives/"));
++#endif
+ return natives_dir.absolutePath();
+ }
+
diff --git a/games/prismlauncher/files/patch-launcher_ui_pages_global_AccountListPage.cpp b/games/prismlauncher/files/patch-launcher_ui_pages_global_AccountListPage.cpp
new file mode 100644
index 000000000000..0c15ed8b6577
--- /dev/null
+++ b/games/prismlauncher/files/patch-launcher_ui_pages_global_AccountListPage.cpp
@@ -0,0 +1,19 @@
+# Patch taken from er2off: https://github.com/er2off/freebsd-ports
+--- launcher/ui/pages/global/AccountListPage.cpp.orig 2024-03-03 19:37:21 UTC
++++ launcher/ui/pages/global/AccountListPage.cpp
+@@ -147,6 +147,7 @@ void AccountListPage::on_actionAddOffline_triggered()
+
+ void AccountListPage::on_actionAddOffline_triggered()
+ {
++#ifdef NO_OFFLINE
+ if (!m_accounts->anyAccountIsValid()) {
+ QMessageBox::warning(this, tr("Error"),
+ tr("You must add a Microsoft account that owns Minecraft before you can add an offline account."
+@@ -154,6 +155,7 @@ void AccountListPage::on_actionAddOffline_triggered()
+ "If you have lost your account you can contact Microsoft for support."));
+ return;
+ }
++#endif
+
+ MinecraftAccountPtr account =
+ OfflineLoginDialog::newAccount(this, tr("Please enter your desired username to add your offline account."));