aboutsummaryrefslogtreecommitdiff
path: root/games/slune/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/slune/Makefile')
-rw-r--r--games/slune/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/games/slune/Makefile b/games/slune/Makefile
new file mode 100644
index 000000000000..9158a26ac217
--- /dev/null
+++ b/games/slune/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: slune
+# Date created: 2005-10-06
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= slune
+PORTVERSION= 1.0.10
+CATEGORIES= games python
+MASTER_SITES= http://download.gna.org/slune/
+DISTNAME= Slune-${PORTVERSION}
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= 3D game. includes racing, car-crashing, and lots of action
+
+RUN_DEPENDS= soya_editor:${PORTSDIR}/graphics/py-soya3d \
+ ${PYTHON_SITELIBDIR}/_openal.so:${PORTSDIR}/audio/py-openal \
+ ${PYTHON_SITELIBDIR}/pysdl_mixer/sdl_mixer.so:${PORTSDIR}/audio/py-sdl_mixer \
+ ${PYTHON_SITELIBDIR}/ogg/vorbis.so:${PORTSDIR}/audio/py-vorbis \
+ ${PYTHON_SITELIBDIR}/py2play/level.py:${PORTSDIR}/net/py-py2play
+LIB_DEPENDS= cal3d.11:${PORTSDIR}/graphics/cal3d \
+ GLEW.1:${PORTSDIR}/graphics/glew
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_GL= yes
+USE_SDL= sdl mixer
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>