aboutsummaryrefslogtreecommitdiff
path: root/games/tuxpaint/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/tuxpaint/Makefile')
-rw-r--r--games/tuxpaint/Makefile38
1 files changed, 26 insertions, 12 deletions
diff --git a/games/tuxpaint/Makefile b/games/tuxpaint/Makefile
index c94325fc1d4c..5b307cf00b4f 100644
--- a/games/tuxpaint/Makefile
+++ b/games/tuxpaint/Makefile
@@ -2,41 +2,51 @@
# $FreeBSD$
PORTNAME= tuxpaint
-PORTVERSION= 0.9.21
-PORTREVISION= 6
+PORTVERSION= 0.9.22
CATEGORIES= games
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Drawing program designed for young children
+LICENSE= GPLv2 # (or later)
+
LIB_DEPENDS= libfribidi.so:${PORTSDIR}/converters/fribidi \
libpaper.so:${PORTSDIR}/print/libpaper
+RUN_DEPENDS= anytopnm:${PORTSDIR}/graphics/netpbm \
+ bash:${PORTSDIR}/shells/bash
-OPTIONS_DEFINE= DOCS
-
+USES= gettext gmake pkgconfig shebangfix
+SHEBANG_FILES= src/tuxpaint-import.sh
USE_GNOME= librsvg2
USE_SDL= image mixer sdl ttf pango
-USES= gettext gmake pkgconfig
MAKE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PREFIX="${PREFIX}" \
- DOC_PREFIX="${STAGEDIR}${DOCSDIR}" \
- DEVDOC_PREFIX="${STAGEDIR}${DOCSDIR}/dev" \
MAN_PREFIX="${STAGEDIR}${MANPREFIX}/man" \
DEVMAN_PREFIX="${STAGEDIR}${MANPREFIX}/man" \
X11_ICON_PREFIX="${STAGEDIR}${PREFIX}/share/pixmaps" \
+ GNOME_PREFIX="${PREFIX}" \
ARCH_INSTALL="" \
OPTFLAGS="${CFLAGS} -DHAVE_STRCASESTR" \
- MAGIC_CFLAGS="${CFLAGS} -fno-common -Isrc `$(SDL_CONFIG) --cflags `" \
SHARED_FLAGS="-shared -fPIC"
-INSTALL_TARGET= install-bin install-data install-man install-magic-plugins \
- install-magic-plugin-dev install-icon install-gettext \
- install-im install-importscript install-default-config \
- install-example-stamps install-example-starters install-doc
+INSTALL_TARGET= install-gettext install-im install-magic-plugins \
+ install-magic-plugin-dev install-default-config \
+ install-example-stamps install-example-starters \
+ install-gnome install-icon install-bin install-importscript \
+ install-data install-doc install-man
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} <= 901000
+CFLAGS+= -Dfmemopen_alternative
+.endif
post-extract:
+ @${CHMOD} -R a+rX ${WRKSRC}
@${RM} -rf ${WRKSRC}/fonts/locale/vi_docs
post-patch:
@@ -45,4 +55,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/${file}
.endfor
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/tuxpaint
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/tuxpaint/plugins/*.so
+
.include <bsd.port.mk>