aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/q3server-excessive/Makefile16
-rw-r--r--games/q3server-excessive/distinfo1
-rw-r--r--games/q3server-excessive/pkg-comment1
-rw-r--r--games/q3server-excessive/pkg-descr7
-rw-r--r--games/q3server-excessive/pkg-plist7
-rw-r--r--games/quake3-excessive/Makefile16
-rw-r--r--games/quake3-excessive/distinfo1
-rw-r--r--games/quake3-excessive/pkg-comment1
-rw-r--r--games/quake3-excessive/pkg-descr7
-rw-r--r--games/quake3-excessive/pkg-plist7
11 files changed, 65 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index a5670e72f19b..7b9468388a5b 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -189,6 +189,7 @@
SUBDIR += pysol-music
SUBDIR += pythoong
SUBDIR += q3server
+ SUBDIR += q3server-excessive
SUBDIR += q3server-ra3
SUBDIR += qcc
SUBDIR += qix
diff --git a/games/q3server-excessive/Makefile b/games/q3server-excessive/Makefile
new file mode 100644
index 000000000000..9fc8f51d4311
--- /dev/null
+++ b/games/q3server-excessive/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: Q3 Mod: Excessive
+# Date created: Sat Jun 23 23:40:21 EDT 2001
+# Whom: pat@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= excessive
+PORTVERSION= 003
+MASTER_SITES= ftp://ftp.gigabell.net/pub/exp/q3/mod/excessive/ \
+ ftp://ftp.task.gda.pl/vol/d33/ftp.extreme-players.de/exp/q3/mod/excessive/
+DISTNAME= ${PORTNAME}_q3_server_${PORTVERSION}
+
+Q3_MOD_MASTER= ${.CURDIR}/../q3server-ra3
+
+.include "${Q3_MOD_MASTER}/Makefile"
diff --git a/games/q3server-excessive/distinfo b/games/q3server-excessive/distinfo
new file mode 100644
index 000000000000..e758fbde2ae5
--- /dev/null
+++ b/games/q3server-excessive/distinfo
@@ -0,0 +1 @@
+MD5 (excessive_q3_server_003.zip) = fe9994605fd32cc6980ee6d3d4c34672
diff --git a/games/q3server-excessive/pkg-comment b/games/q3server-excessive/pkg-comment
new file mode 100644
index 000000000000..9a652eee5305
--- /dev/null
+++ b/games/q3server-excessive/pkg-comment
@@ -0,0 +1 @@
+Quake III Arena Excessive Mod for Linux
diff --git a/games/q3server-excessive/pkg-descr b/games/q3server-excessive/pkg-descr
new file mode 100644
index 000000000000..a90135d78aa8
--- /dev/null
+++ b/games/q3server-excessive/pkg-descr
@@ -0,0 +1,7 @@
+This package contains all of the items you'll need to run a
+Quake III Arena dedicated server with Excessive mod under
+FreeBSD with Linux emulation.
+
+WWW: http://www.planetquake.com/excessive/
+
+- Patrick Li <pat@databits.net>
diff --git a/games/q3server-excessive/pkg-plist b/games/q3server-excessive/pkg-plist
new file mode 100644
index 000000000000..88f642fc5b29
--- /dev/null
+++ b/games/q3server-excessive/pkg-plist
@@ -0,0 +1,7 @@
+%%Q3DIR%%description.pk3
+%%Q3DIR%%maplist.cfg
+%%Q3DIR%%motd.cfg
+%%Q3DIR%%readme.txt
+%%Q3DIR%%vm/qagame.qvm
+@dirrm %%Q3DIR%%vm
+@dirrm %%Q3DIR%%
diff --git a/games/quake3-excessive/Makefile b/games/quake3-excessive/Makefile
new file mode 100644
index 000000000000..9fc8f51d4311
--- /dev/null
+++ b/games/quake3-excessive/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: Q3 Mod: Excessive
+# Date created: Sat Jun 23 23:40:21 EDT 2001
+# Whom: pat@databits.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= excessive
+PORTVERSION= 003
+MASTER_SITES= ftp://ftp.gigabell.net/pub/exp/q3/mod/excessive/ \
+ ftp://ftp.task.gda.pl/vol/d33/ftp.extreme-players.de/exp/q3/mod/excessive/
+DISTNAME= ${PORTNAME}_q3_server_${PORTVERSION}
+
+Q3_MOD_MASTER= ${.CURDIR}/../q3server-ra3
+
+.include "${Q3_MOD_MASTER}/Makefile"
diff --git a/games/quake3-excessive/distinfo b/games/quake3-excessive/distinfo
new file mode 100644
index 000000000000..e758fbde2ae5
--- /dev/null
+++ b/games/quake3-excessive/distinfo
@@ -0,0 +1 @@
+MD5 (excessive_q3_server_003.zip) = fe9994605fd32cc6980ee6d3d4c34672
diff --git a/games/quake3-excessive/pkg-comment b/games/quake3-excessive/pkg-comment
new file mode 100644
index 000000000000..9a652eee5305
--- /dev/null
+++ b/games/quake3-excessive/pkg-comment
@@ -0,0 +1 @@
+Quake III Arena Excessive Mod for Linux
diff --git a/games/quake3-excessive/pkg-descr b/games/quake3-excessive/pkg-descr
new file mode 100644
index 000000000000..a90135d78aa8
--- /dev/null
+++ b/games/quake3-excessive/pkg-descr
@@ -0,0 +1,7 @@
+This package contains all of the items you'll need to run a
+Quake III Arena dedicated server with Excessive mod under
+FreeBSD with Linux emulation.
+
+WWW: http://www.planetquake.com/excessive/
+
+- Patrick Li <pat@databits.net>
diff --git a/games/quake3-excessive/pkg-plist b/games/quake3-excessive/pkg-plist
new file mode 100644
index 000000000000..88f642fc5b29
--- /dev/null
+++ b/games/quake3-excessive/pkg-plist
@@ -0,0 +1,7 @@
+%%Q3DIR%%description.pk3
+%%Q3DIR%%maplist.cfg
+%%Q3DIR%%motd.cfg
+%%Q3DIR%%readme.txt
+%%Q3DIR%%vm/qagame.qvm
+@dirrm %%Q3DIR%%vm
+@dirrm %%Q3DIR%%