aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
Diffstat (limited to 'games')
-rw-r--r--games/antrix/Makefile3
-rw-r--r--games/atr3d/Makefile4
-rw-r--r--games/critterding/Makefile4
-rw-r--r--games/d2x-xl/Makefile4
-rw-r--r--games/flightgear-atlas/Makefile4
-rw-r--r--games/glest/Makefile4
-rw-r--r--games/gno3dtet/Makefile4
-rw-r--r--games/kmastermind/Makefile4
-rw-r--r--games/mangos/Makefile3
-rw-r--r--games/moon-buggy/Makefile4
-rw-r--r--games/naev/Makefile3
-rw-r--r--games/openalchemist/Makefile4
-rw-r--r--games/quake2forge/Makefile4
-rw-r--r--games/scorched3d/Makefile3
-rw-r--r--games/scourge/Makefile4
-rw-r--r--games/scourge/files/patch-configure.in10
-rw-r--r--games/spacejunk/Makefile1
-rw-r--r--games/tuxracer/Makefile4
-rw-r--r--games/tuxracer/files/patch-configure.in63
-rw-r--r--games/ufoai/Makefile3
-rw-r--r--games/wesnoth-devel/Makefile3
-rw-r--r--games/wesnoth/Makefile3
-rw-r--r--games/zangband/Makefile4
23 files changed, 75 insertions, 72 deletions
diff --git a/games/antrix/Makefile b/games/antrix/Makefile
index 99e1ce7c5677..2028c5c60331 100644
--- a/games/antrix/Makefile
+++ b/games/antrix/Makefile
@@ -7,6 +7,7 @@
PORTNAME= antrix
PORTVERSION= 1477
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://skillcoder.narod.ru/wow/antrix/ \
http://wtq.ru/wow/antrix/
@@ -17,7 +18,7 @@ COMMENT= Free stable dedicated-server for World of Warcraft
BUILD_DEPENDS= svn:${PORTSDIR}/devel/subversion
-USE_AUTOTOOLS= aclocal:19 libtoolize autoconf:262 autoheader:262 automake:19 libtool:22
+USE_AUTOTOOLS= aclocal:19 libtoolize autoconf:267 autoheader:267 automake:19 libtool:22
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= -a
USE_MYSQL= yes
diff --git a/games/atr3d/Makefile b/games/atr3d/Makefile
index b0d8f94ed1f5..9434bdf249ee 100644
--- a/games/atr3d/Makefile
+++ b/games/atr3d/Makefile
@@ -7,7 +7,7 @@
PORTNAME= atr3d
PORTVERSION= 0.6
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= games
MASTER_SITES= ftp://ftp.avoidtheroid.com/pub/${PORTNAME}/
DISTNAME= ${PORTNAME}_source_${PORTVERSION}
@@ -30,7 +30,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sound
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
SDL_CONFIG="${SDL_CONFIG}"
-USE_AUTOTOOLS= automake:19 autoconf:262
+USE_AUTOTOOLS= automake:19 autoconf:267
CPPFLAGS= -I${LOCALBASE}/include -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}
diff --git a/games/critterding/Makefile b/games/critterding/Makefile
index d9572583f499..1fb553822b59 100644
--- a/games/critterding/Makefile
+++ b/games/critterding/Makefile
@@ -7,7 +7,7 @@
PORTNAME= critterding
DISTVERSION= beta12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/sources
@@ -18,7 +18,7 @@ LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:262:env aclocal:110:env automake:110:env libtool:22
+USE_AUTOTOOLS= autoconf:267:env aclocal:110:env automake:110:env libtool:22
USE_SDL= sdl
USE_GL= gl
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
diff --git a/games/d2x-xl/Makefile b/games/d2x-xl/Makefile
index f3b0b9e2f81d..bf374de8168c 100644
--- a/games/d2x-xl/Makefile
+++ b/games/d2x-xl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= d2x-xl
PORTVERSION= 1.14.121
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/d2x-xl/Linux/Archive:source \
SF/d2x-xl/Linux:source \
@@ -29,7 +29,7 @@ CONFIGURE_ARGS= --disable-debug --enable-release=yes \
--with-sharepath=${PREFIX}/share/d2x-xl
USE_SDL= sdl mixer image
USE_GMAKE= yes
-USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262
+USE_AUTOTOOLS= aclocal:110 autoheader:267 automake:110 autoconf:267
USE_MOTIF= yes
MAKE_JOBS_SAFE= yes
AUTOMAKE_ARGS= --add-missing --copy
diff --git a/games/flightgear-atlas/Makefile b/games/flightgear-atlas/Makefile
index e23ba881a11c..e46dc01743c2 100644
--- a/games/flightgear-atlas/Makefile
+++ b/games/flightgear-atlas/Makefile
@@ -7,7 +7,7 @@
PORTNAME= flightgear-atlas
PORTVERSION= 0.3.1.20090529
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
http://freebsd.unixfreunde.de/sources/
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/include/simgear/version.h:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/FlightGear/version:${PORTSDIR}/games/flightgear-data
-USE_AUTOTOOLS= aclocal:19 autoheader:262 automake:15 autoconf:262
+USE_AUTOTOOLS= aclocal:19 autoheader:267 automake:15 autoconf:267
AUTOMAKE_ARGS= --add-missing
GNU_CONFIGURE= yes
diff --git a/games/glest/Makefile b/games/glest/Makefile
index 69135af0fad3..d971ef8edcbb 100644
--- a/games/glest/Makefile
+++ b/games/glest/Makefile
@@ -7,7 +7,7 @@
PORTNAME= glest
PORTVERSION= 3.2.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20source/${PORTVERSION}
DISTNAME= ${PORTNAME}_source_${PORTVERSION}
@@ -21,7 +21,7 @@ LIB_DEPENDS= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
BUILD_DEPENDS= jam:${PORTSDIR}/devel/jam
RUN_DEPENDS= ${DATADIR}/servers.ini:${PORTSDIR}/games/glest-data
-USE_AUTOTOOLS= automake:15:env autoconf:262:env
+USE_AUTOTOOLS= automake:15:env autoconf:267:env
USE_ZIP= yes
USE_OPENAL= al alut
USE_DOS2UNIX= yes
diff --git a/games/gno3dtet/Makefile b/games/gno3dtet/Makefile
index 1c9dbfafeb62..60454af15028 100644
--- a/games/gno3dtet/Makefile
+++ b/games/gno3dtet/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gno3dtet
PORTVERSION= 1.96.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= games gnome
MASTER_SITES= http://eseb.net/ftp/gno3dtet/
EXTRACT_SUFX= .tgz
@@ -19,7 +19,7 @@ EXTRACT_DEPENDS=intltoolize:${PORTSDIR}/textproc/intltool
USE_GNOME= gnomehack gnomeprefix gnometarget intlhack libgnomeui librsvg2
USE_GMAKE= yes
-USE_AUTOTOOLS= autoheader:262 automake:19 aclocal:19 autoconf:262
+USE_AUTOTOOLS= autoheader:267 automake:19 aclocal:19 autoconf:267
ACLOCAL_ARGS= -I m4 -I ${ACLOCAL_DIR} -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= -a -c -f
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/games/kmastermind/Makefile b/games/kmastermind/Makefile
index 583c570feac4..8ec86b207850 100644
--- a/games/kmastermind/Makefile
+++ b/games/kmastermind/Makefile
@@ -6,7 +6,7 @@
PORTNAME= kmastermind
PORTVERSION= 2.2
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games kde
MASTER_SITES= http://www.kde-apps.org/CONTENT/content-files/
DISTNAME= 20292-${PORTNAME}-${PORTVERSION}
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/x11/kdelibs3:extract
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_AUTOTOOLS= automake:19:env autoconf:262:env libtool:22
+USE_AUTOTOOLS= automake:19:env autoconf:267:env libtool:22
USE_PERL5_BUILD= yes
USE_KDELIBS_VER= 3
USE_BZIP2= yes
diff --git a/games/mangos/Makefile b/games/mangos/Makefile
index 46c134b45a96..6b997bdd389c 100644
--- a/games/mangos/Makefile
+++ b/games/mangos/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mangos
PORTVERSION= 5101
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= CENKES http://mangos-port.by.ru/ \
http://wow.omsktele.com/src/ \
@@ -22,7 +23,7 @@ OPTIONS= SCRIPTDEV2 "ScriptDev2" on \
RA "Remote Administration support" off \
DBC "Install DBC files" on
-USE_AUTOTOOLS= aclocal:19 libtoolize autoconf:262 autoheader:262 automake:19 libtool:22
+USE_AUTOTOOLS= aclocal:19 libtoolize autoconf:267 autoheader:267 automake:19 libtool:22
ACLOCAL_ARGS= -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= -a
USE_MYSQL= yes
diff --git a/games/moon-buggy/Makefile b/games/moon-buggy/Makefile
index fd910d4ef730..465cb1a427c8 100644
--- a/games/moon-buggy/Makefile
+++ b/games/moon-buggy/Makefile
@@ -7,7 +7,7 @@
PORTNAME= moon-buggy
PORTVERSION= 1.0.51
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= http://seehuhn.de/media/programs/
.if defined (WITH_ESOUND)
@@ -27,7 +27,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= esd:${PORTSDIR}/audio/esound:install
.endif
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
CONFIGURE_ARGS= --prefix=${PREFIX} \
--sharedstatedir=/var/games\
--with-setgid=games
diff --git a/games/naev/Makefile b/games/naev/Makefile
index d22c14ef55d0..1c00929af603 100644
--- a/games/naev/Makefile
+++ b/games/naev/Makefile
@@ -7,6 +7,7 @@
PORTNAME= naev
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DIST_SUBDIR= ${PORTNAME}
@@ -18,7 +19,7 @@ LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
freetype:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/ndata-${PORTVERSION}:${PORTSDIR}/games/naev-data
-USE_AUTOTOOLS= automake:19:env aclocal:19:env autoconf:262:env
+USE_AUTOTOOLS= automake:19:env aclocal:19:env autoconf:267:env
USE_BZIP2= yes
USE_DOS2UNIX= conf.example
GNU_CONFIGURE= yes
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index 66ab2b7a4f49..daacb6884d3f 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openalchemist
PORTVERSION= 0.3
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -20,7 +20,7 @@ LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png
-USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:262
+USE_AUTOTOOLS= aclocal:110 automake:110 autoconf:267
# Necessary to find pkg.m4 (PKG_CHECK_MODULES)
ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/quake2forge/Makefile b/games/quake2forge/Makefile
index ab3b304b922e..3bb55d8be5b1 100644
--- a/games/quake2forge/Makefile
+++ b/games/quake2forge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quake2forge
PORTVERSION= 0.3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games
MASTER_SITES= https://www.spoerlein.net/pub/
DISTNAME= quake2-${PORTVERSION}
@@ -15,7 +15,7 @@ DISTNAME= quake2-${PORTVERSION}
MAINTAINER= alepulver@FreeBSD.org
COMMENT= First Person Shooter with many addons available
-USE_AUTOTOOLS= autoconf:262 libtool:22
+USE_AUTOTOOLS= autoconf:267 libtool:22
USE_BZIP2= yes
CONFIGURE_ARGS= --program-transform-name='s/^quake2$$/${PORTNAME}/' \
diff --git a/games/scorched3d/Makefile b/games/scorched3d/Makefile
index 704f4a60af58..5ba407dcacc1 100644
--- a/games/scorched3d/Makefile
+++ b/games/scorched3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scorched3d
PORTVERSION= 0.${SCORCH_VERSION}${SCORCH_REVISION}
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Version%20${SCORCH_VERSION}/
DISTNAME= Scorched3D-${SCORCH_VERSION}-src
@@ -31,7 +32,7 @@ USE_SDL= mixer net sdl
GNU_CONFIGURE= yes
USE_GL= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:15 autoconf:262
+USE_AUTOTOOLS= automake:15 autoconf:267
USE_PERL5= yes
USE_WX= 2.4+
WX_CONF_ARGS= absolute
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index f3c493e39703..6497681fdf1e 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -7,7 +7,7 @@
PORTNAME= scourge
PORTVERSION= 0.21.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:S/$/.src/}
@@ -19,7 +19,7 @@ COMMENT= S.C.O.U.R.G.E. is a rogue-like game
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= ${DATADIR}/config/scourge.cfg:${PORTSDIR}/games/scourge-data
-USE_AUTOTOOLS= autoconf:262:env automake:19:env
+USE_AUTOTOOLS= autoconf:267:env automake:19:env
USE_GL= gl
USE_SDL= sdl image mixer net ttf
USE_GMAKE= yes
diff --git a/games/scourge/files/patch-configure.in b/games/scourge/files/patch-configure.in
new file mode 100644
index 000000000000..eca1eef134cc
--- /dev/null
+++ b/games/scourge/files/patch-configure.in
@@ -0,0 +1,10 @@
+--- configure.in.orig 2008-12-22 23:38:10.000000000 +0000
++++ configure.in 2010-06-14 11:57:29.000000000 +0000
+@@ -493,3 +493,6 @@
+ dnl Check for glext.h
+-AC_CHECK_HEADERS( "GL/glext.h", have_glext_h=yes, have_glext_h=no )
++dnl XXX: which requires GL/gl.h, and autoconf > 2.64 is barfing on this
++dnk XXX: use following check to cover the bases
++dnl AC_CHECK_HEADERS( "GL/glext.h", have_glext_h=yes, have_glext_h=no )
++have_glext_h=yes
+
diff --git a/games/spacejunk/Makefile b/games/spacejunk/Makefile
index c221dab5c0e1..dfc52287f0d4 100644
--- a/games/spacejunk/Makefile
+++ b/games/spacejunk/Makefile
@@ -45,6 +45,7 @@ post-patch:
${WRKSRC}/libinfo/gem-uta.c
@${REINPLACE_CMD} -e 's|data/|${DATADIR}/&|' ${WRKSRC}/src/*.c*
@${RM} -f ${WRKSRC}/config.guess
+ @${REINPLACE_CMD} -e 's|1.10.1|1.10.3|' ${WRKSRC}/aclocal.m4
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/spacejunk ${PREFIX}/libexec/
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index b280c8345883..f19dd3ea0954 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tuxracer
PORTVERSION= 0.61
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= SF
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz \
@@ -22,7 +22,7 @@ USE_SDL= mixer sdl
USE_GL= gl
USE_XORG= x11 xt xmu xi
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:14 autoconf:262
+USE_AUTOTOOLS= automake:14 autoconf:267
AUTOMAKE_ARGS= -a
CONFIGURE_ENV= THREAD_LIB="${PTHREAD_LIBS}"
MAKE_ENV= ${CONFIGURE_ENV}
diff --git a/games/tuxracer/files/patch-configure.in b/games/tuxracer/files/patch-configure.in
index caf2953a8959..57138f28db91 100644
--- a/games/tuxracer/files/patch-configure.in
+++ b/games/tuxracer/files/patch-configure.in
@@ -1,8 +1,6 @@
---- configure.in.orig 2001-01-16 16:26:29.000000000 +0100
-+++ configure.in 2009-04-27 03:06:12.000000000 +0200
-@@ -43,16 +43,10 @@
- dnl General options
- dnl --------------------------------------------------------------------------
+--- configure.in.orig 2001-01-16 15:26:29.000000000 +0000
++++ configure.in 2010-06-14 11:51:45.000000000 +0000
+@@ -45,12 +45,6 @@
TR_CPPFLAGS=""
-TR_CFLAGS="-O2 -Wall -fomit-frame-pointer -ffast-math -fexpensive-optimizations"
-TR_CXXFLAGS="-O2 -Wall -fomit-frame-pointer -ffast-math -fexpensive-optimizations"
@@ -17,54 +15,34 @@
-esac
-
AC_ARG_ENABLE(debug, [ --enable-debug Produce an executable with debugging symbols],
- [TR_CFLAGS="-g -Wall"; TR_CXXFLAGS="-g -Wall"],
- [TR_CPPFLAGS="$TR_CPPFLAGS -DTUXRACER_NO_ASSERT=1"])
-@@ -137,6 +131,10 @@
- if test "x$have_tcl_lib" = "xno" -a "x$with_tcl_lib_name" = "x" ; then
-
+@@ -139,2 +133,6 @@
TCL_LIB_LIST=`grep -v -E "^$TCL_LIB_NAME\$" <<EOF
+tcl8.5
+tcl85
+tcl8.4
+tcl84
tcl8.3
- tcl83
- tcl8.2
-@@ -191,6 +189,10 @@
-
- TCL_HEADER_LIST=`grep -v -E "^$TCL_HEADER\$" <<EOF
+@@ -193,2 +191,6 @@
tcl.h
+tcl8.5.h
+tcl85.h
+tcl8.4.h
+tcl84.h
tcl8.3.h
- tcl83.h
- tcl8.2.h
-@@ -219,7 +221,8 @@
- FIND_TCL_H
-
+@@ -221,3 +223,4 @@
if test "x$have_tcl_h" = "xno" -a "x$with_tcl_inc" = "x"; then
- TCL_INC_LIST="/usr/include/tcl8.3 /usr/include/tcl8.2 \
+ TCL_INC_LIST="/usr/include/tcl8.5 /usr/include/tcl8.4 \
+ /usr/include/tcl8.3 /usr/include/tcl8.2 \
/usr/include/tcl8.0 /usr/include/tcl"
-
- for TCL_INC in $TCL_INC_LIST ; do
-@@ -303,6 +306,10 @@
-
- saved_LIBS="$LIBS"
+@@ -305,2 +308,6 @@
+if test "x$THREAD_LIB" = "x" ; then
+ THREAD_LIB="-lpthread"
+fi
+
AC_DEFUN( CHECK_FOR_GL_LIB, [
- AC_MSG_CHECKING([for $GL_LIB_NAME library])
- LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME"
-@@ -313,15 +320,15 @@
- TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME"
-
+@@ -315,6 +322,6 @@
else
- dnl Try with -lpthread
+ dnl Try with pthreads
@@ -73,20 +51,27 @@
- LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME -lpthread"
+ LIBS="$saved_LIBS $TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME $THREAD_LIB"
AC_TRY_LINK( , , have_GL=yes, have_GL=no)
- AC_MSG_RESULT([$have_GL])
-
+@@ -323,3 +330,3 @@
if test "x$have_GL" = "xyes" ; then
- TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME -lpthread"
+ TR_LIBS="$TR_LIBS $GL_LDOPTS -l$GL_LIB_NAME $THREAD_LIB"
fi
- fi
- ])
-@@ -466,7 +473,7 @@
- if test "x$have_glx_h" = "xno" ; then
- AC_MSG_ERROR([Cannot find GL/glx.h])
+@@ -468,3 +475,3 @@
fi
-
+ CFLAGS="$CFLAGS -DGLX_GLXEXT_LEGACY"
dnl Check that glXGetProcAddressARB is defined in glx.h
- AC_MSG_CHECKING([whether glx.h defines glXGetProcAddressARB]);
- AC_TRY_COMPILE( [#include <GL/glx.h>], [ char *foo = (char*) glXGetProcAddressARB; ],
+@@ -480,4 +487,7 @@
+
+-dnl Check for glext.h
+-AC_CHECK_HEADERS( "GL/glext.h", have_glext_h=yes, have_glext_h=no )
++dnl Check for glext.h
++dnl XXX: which requires GL/gl.h, and autoconf > 2.64 is barfing on this
++dnl XXX: use following check to cover the bases
++dnl AC_CHECK_HEADERS( "GL/glext.h", have_glext_h=yes, have_glext_h=no )
++have_glext_h=yes
+
+@@ -497,2 +507,3 @@
+ [
++#include <GL/gl.h>
+ #include <GL/glext.h>
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 0d435717b192..00b7e9d717b9 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ufoai
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/UFO_AI%202.x/${PORTVERSION}
DISTNAME= ${PORTNAME:S/$/-/}${PORTVERSION}-source
@@ -24,7 +25,7 @@ LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
xvidcore.4:${PORTSDIR}/multimedia/xvid
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/base/default.cfg:${PORTSDIR}/games/ufoai-data
-USE_AUTOTOOLS= aclocal:110 autoconf:262
+USE_AUTOTOOLS= aclocal:110 autoconf:267
USE_BZIP2= yes
USE_GL= yes
USE_SDL= sdl image mixer ttf
diff --git a/games/wesnoth-devel/Makefile b/games/wesnoth-devel/Makefile
index 1d90c838ac69..8b4900ffb8be 100644
--- a/games/wesnoth-devel/Makefile
+++ b/games/wesnoth-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wesnoth
PORTVERSION= 1.9.0
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
http://files.wesnoth.org/
@@ -29,7 +30,7 @@ USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
USE_BZIP2= yes
-USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262
+USE_AUTOTOOLS= aclocal:110 autoheader:267 automake:110 autoconf:267
ACLOCAL_ARGS= -Im4
AUTOMAKE_ARGS= --add-missing --copy
CONFIGURE_ENV= PKG_CONFIG="${PKG_CONFIG}" \
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 80fdefc87b4a..cbf429e1348a 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wesnoth
PORTVERSION= 1.8.4
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}/${PORTNAME}-${PORTVERSION} \
http://files.wesnoth.org/
@@ -29,7 +30,7 @@ MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
USE_BZIP2= yes
USE_LUA= 5.1
-USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262
+USE_AUTOTOOLS= aclocal:110 autoheader:267 automake:110 autoconf:267
ACLOCAL_ARGS= -Im4
AUTOMAKE_ARGS= --add-missing --copy
CONFIGURE_ENV= PKG_CONFIG="${PKG_CONFIG}" \
diff --git a/games/zangband/Makefile b/games/zangband/Makefile
index 8df068c00a55..d8237f296281 100644
--- a/games/zangband/Makefile
+++ b/games/zangband/Makefile
@@ -7,7 +7,7 @@
PORTNAME= zangband
PORTVERSION= 2.6.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES+= games
MASTER_SITES= ftp://clockwork.dementia.org/angband/Variant/ZAngband/ \
ftp://ftp.sunet.se/pub/games/Angband/Variant/ZAngband/
@@ -17,7 +17,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Zangband (Zelazny Angband) with color, X11 support
USE_GMAKE= yes
-USE_AUTOTOOLS= automake:14 autoconf:262
+USE_AUTOTOOLS= automake:14 autoconf:267
USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --datadir=${PREFIX}/lib --mandir=${PREFIX}/man \
--with-setgid=${SHAREGRP}