aboutsummaryrefslogtreecommitdiff
path: root/graphics/atril-lite/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/atril-lite/Makefile')
-rw-r--r--graphics/atril-lite/Makefile130
1 files changed, 9 insertions, 121 deletions
diff --git a/graphics/atril-lite/Makefile b/graphics/atril-lite/Makefile
index 4018cccd5623..06e8da1258c6 100644
--- a/graphics/atril-lite/Makefile
+++ b/graphics/atril-lite/Makefile
@@ -1,128 +1,16 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-PORTNAME= atril
-PORTVERSION= 1.8.1
-PORTREVISION?= 4
-CATEGORIES= graphics print mate
-MASTER_SITES= MATE
-DIST_SUBDIR= mate
+PORTREVISION= 0
+PKGNAMESUFFIX= -lite
-MAINTAINER= gnome@FreeBSD.org
-COMMENT?= MATE multi-format document viewer
+COMMENT= MATE multi-format document viewer
-BUILD_DEPENDS= itstool:${PORTSDIR}/textproc/itstool
+OPTIONS_EXCLUDE= CAJA
-LIB_DEPENDS= libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib \
- libspectre.so:${PORTSDIR}/print/libspectre
+MASTERDIR= ${.CURDIR}/../../graphics/atril
+SLAVEPORT= lite
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
-RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
-
-PORTSCOUT= limitw:1,even
-SLAVEPORT?= no
-
-USES= desktop-file-utils gettext gmake libtool pathfix \
- pkgconfig tar:xz
-USE_MATE= icontheme
-USE_XORG= sm
-USE_GNOME= cairo gtk20 intlhack libxml2
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gtk=2.0 \
- --disable-xps \
- --disable-static
-INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-INSTALL_TARGET= install-strip
-
-.if ${SLAVEPORT} == lite
-CONFIGURE_ARGS+=--disable-introspection \
- --disable-thumbnailer \
- --disable-previewer
-.else
-USE_GNOME+= introspection:build
-CONFIGURE_ARGS+= --enable-introspection
-.endif
-
-GLIB_SCHEMAS= org.mate.Atril.gschema.xml
-
-OPTIONS_DEFINE= CAJA COMICS DJVU DVI KEYRING T1LIB XPS
-OPTIONS_DEFAULT=CAJA COMICS KEYRING XPS
-DVI_DESC= DVI viewer support
-T1LIB_DESC= T1LIB for TYPE1 fonts to DVI (Enables DVI)
-CAJA_DESC= Caja plugin
-KEYRING_DESC= Keyring support
-COMICS_DESC= Comic book archives support
-DJVU_DESC= DJVU support
-XPS_DESC= XPS support
-
-.include <bsd.port.options.mk>
-
-.if ${SLAVEPORT} == lite
-CONFIGURE_ARGS+=--disable-dbus
-.else
-CONFIGURE_ARGS+=--enable-dbus
-LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-.endif
-
-.if ${PORT_OPTIONS:MDVI} || ${PORT_OPTIONS:MT1LIB}
-
-USE_TEX= base
-CONFIGURE_ARGS+=--enable-dvi
-PLIST_SUB+= DVI=""
-
-. if ${PORT_OPTIONS:MT1LIB}
-LIB_DEPENDS+= libt1.so:${PORTSDIR}/devel/t1lib
-CONFIGURE_ARGS+=--enable-t1lib
-.else
-CONFIGURE_ARGS+=--disable-t1lib
-. endif
-
-.else
-CONFIGURE_ARGS+=--disable-dvi
-PLIST_SUB+= DVI="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MKEYRING}
-LIB_DEPENDS+= libsecret-1.so:${PORTSDIR}/security/libsecret
-.else
-CONFIGURE_ARGS+=--without-keyring
-.endif
-
-.if ${PORT_OPTIONS:MCAJA}
-USE_MATE+= caja
-CONFIGURE_ARGS+=--enable-caja
-PLIST_SUB+= CAJA=""
-.else
-CONFIGURE_ARGS+=--disable-caja
-PLIST_SUB+= CAJA="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MXPS}
-LIB_DEPENDS+= libgxps.so:${PORTSDIR}/graphics/libgxps
-CONFIGURE_ARGS+= --enable-xps
-PLIST_SUB+= XPS=""
-.else
-CONFIGURE_ARGS+= --disable-xps
-PLIST_SUB+= XPS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDJVU}
-LIB_DEPENDS+= libdjvulibre.so:${PORTSDIR}/graphics/djvulibre
-CONFIGURE_ARGS+=--enable-djvu
-PLIST_SUB+= DJVU=""
-.else
-CONFIGURE_ARGS+=--disable-djvu
-PLIST_SUB+= DJVU="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MCOMICS}
-CONFIGURE_ARGS+=--enable-comics
-PLIST_SUB+= COMICS=""
-.else
-CONFIGURE_ARGS+=--disable-comics
-PLIST_SUB+= COMICS="@comment "
-.endif
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"