aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender/Makefile.options
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/blender/Makefile.options')
-rw-r--r--graphics/blender/Makefile.options12
1 files changed, 11 insertions, 1 deletions
diff --git a/graphics/blender/Makefile.options b/graphics/blender/Makefile.options
index b90c07fdd8c8..8ee2bdd4b1ce 100644
--- a/graphics/blender/Makefile.options
+++ b/graphics/blender/Makefile.options
@@ -38,8 +38,10 @@ OPTIONS_DEFINE= \
OPENIMAGEDN \
OPENJPEG \
OPENMP \
+ OPENPGL \
OPENSUBDIV \
OPENVDB \
+ POTRACE \
PUGIXML \
PULSEAUDIO \
QUADRIFLOW \
@@ -50,6 +52,8 @@ OPTIONS_DEFINE= \
TIFF \
THUMBNAILER \
TRACE \
+ WAYLAND \
+ WEBP \
XINPUT \
XF86VMODE
@@ -87,6 +91,7 @@ OPTIONS_DEFAULT= \
OPENJPEG \
OPENSUBDIV \
OPENVDB \
+ POTRACE \
PUGIXML \
PULSEAUDIO \
QUADRIFLOW \
@@ -96,10 +101,11 @@ OPTIONS_DEFAULT= \
TIFF \
THUMBNAILER \
TRACE \
+ WEBP \
XINPUT \
XF86VMODE
-OPTIONS_DEFAULT_amd64= CAMERATRACK CYCLESEMBR OPENIMAGEDN
+OPTIONS_DEFAULT_amd64= CAMERATRACK CYCLESEMBR OPENIMAGEDN OPENPGL
ALEMBIC_DESC= Enable Alembic file support
ALEMBIC_HDF5_DESC= Enable Alembic hdf5 file support
@@ -135,8 +141,10 @@ OPENCOLORIO_DESC= OpenColorIO-based color management support
OPENIMAGEIO_DESC= OpenImageIO image processing support
OPENIMAGEDN_DESC= OpenImageDenoise support
OPENJPEG_DESC= Enhanced JPEG (jpeg2000) graphics support
+OPENPGL_DESC= Open Path Guiding in Cycles
OPENSUBDIV_DESC= Use the OpenSubDiv library for surface subdivision
OPENVDB_DESC= Use openVDB library for volumetric data
+POTRACE_DESC= Enable features using libpotrace
PUGIXML_DESC= Enable pugixml support
QUADRIFLOW_DESC= Enable quadriflow remesher
RAYOPTIMIZATION_DESC= Enable SSE optimizatons for raytracing
@@ -144,5 +152,7 @@ SDL_DESC= Audio and Joystick support using SDL
TBB_DESC= Enable use of Intel's tbb
THUMBNAILER_DESC= Build blender thumbnailer
TRACE_DESC= Enable tracing image to GP stroke
+WEBP_DESC= Enable webp image support
+WAYLAND_DESC= Wayland support
XINPUT_DESC= X11 Xinput (tablet) support
XF86VMODE_DESC= X11 video mode switching support