aboutsummaryrefslogtreecommitdiff
path: root/graphics/blender/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/blender/Makefile')
-rw-r--r--graphics/blender/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/blender/Makefile b/graphics/blender/Makefile
index d0431575e617..3a24af5f817e 100644
--- a/graphics/blender/Makefile
+++ b/graphics/blender/Makefile
@@ -177,8 +177,8 @@ CMAKE_ARGS+= -DWITH_GHOST_DEBUG:BOOL=ON
.include <bsd.port.options.mk>
-.if ${ARCH} != amd64 && ${ARCH} != i386
-CMAKE_ARGS+= -DWITH_CPU_SSE:BOOL=OFF
+.if ${ARCH:Mpowerpc*} || ${ARCH:Mriscv64*}
+CMAKE_ARGS+= -DWITH_CPU_SIMD:BOOL=OFF
.endif
.if ${LLVM_DEFAULT:M[678]0}