aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/gegl/Makefile')
-rw-r--r--graphics/gegl/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index b7122cc8c081..3375c0063b1b 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -1,12 +1,8 @@
PORTNAME= gegl
-PORTVERSION= 0.4.46
-PORTREVISION= 5
+PORTVERSION= 0.4.48
CATEGORIES= graphics
MASTER_SITES= GIMP
-PATCH_SITES= https://gitlab.gnome.org/GNOME/gegl/-/commit/
-PATCHFILES+= a99a93e5c9013bd4101f5058cdee7d0cf30234fe.patch:-p1
-
MAINTAINER= gnome@FreeBSD.org
COMMENT= Graph based image processing framework
WWW= https://gegl.org/
@@ -33,6 +29,7 @@ USES+= compiler:c++14-lang
USE_GNOME= glib20 introspection:build
USE_LDCONFIG= yes
MESON_ARGS= -Ddocs=false \
+ -Dgi-docgen=disabled \
-Dworkshop=false \
-Dintrospection=true \
-Dlensfun=disabled \
@@ -46,7 +43,7 @@ MESON_ARGS= -Ddocs=false \
MESON_ARGS_armv6= -Dopenmp=disabled
MESON_ARGS_armv7= -Dopenmp=disabled
-GEGL_SHLIB= 0.445.1
+GEGL_SHLIB= 0.447.1
GEGL_VER= 0.4
PLIST_SUB+= GEGL_SHLIB=${GEGL_SHLIB} GEGL_VER=${GEGL_VER}