aboutsummaryrefslogtreecommitdiff
path: root/graphics/h3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/h3/Makefile')
-rw-r--r--graphics/h3/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/graphics/h3/Makefile b/graphics/h3/Makefile
new file mode 100644
index 000000000000..0679d13c0663
--- /dev/null
+++ b/graphics/h3/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= h3
+PORTVERSION= 3.6.4
+DISTVERSIONPREFIX= v
+CATEGORIES= graphics
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Hexagonal hierarchical geospatial indexing system
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake
+
+CMAKE_ON= BUILD_SHARED_LIBS
+USE_CSTD= c99
+
+USE_GITHUB= yes
+GH_ACCOUNT= uber
+
+.include <bsd.port.mk>