aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mesa-devel/Makefile')
-rw-r--r--graphics/mesa-devel/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/mesa-devel/Makefile b/graphics/mesa-devel/Makefile
index 3897719fc374..765adf008783 100644
--- a/graphics/mesa-devel/Makefile
+++ b/graphics/mesa-devel/Makefile
@@ -112,8 +112,9 @@ OPENCL_BUILD_DEPENDS= bindgen:devel/rust-bindgen-cli \
libclc>0:devel/libclc \
spirv-tools>0:graphics/spirv-tools \
rustc:lang/${RUST_DEFAULT}
-OPENCL_LIB_DEPENDS= libLLVMSPIRVLib.so.${LLVM_VERSION}:devel/spirv-llvm-translator@${LLVM_PORT:T}
+OPENCL_LIB_DEPENDS= libLLVMSPIRVLib.so.${OPENCL_SOVERSION}:devel/spirv-llvm-translator@${LLVM_PORT:T}
OPENCL_RUN_DEPENDS= libclc>0:devel/libclc
+OPENCL_SOVERSION= ${LLVM_VERSION}${${LLVM_VERSION}>=18:?.1:}
OPENCL_CONFIGURE_ENV= PKG_CONFIG_PATH="${LLVM_PREFIX}/libdata/pkgconfig"
OPENCL_MESON_FALSE= b_lundef # environ
OPENCL_MESON_TRUE= gallium-rusticl