aboutsummaryrefslogtreecommitdiff
path: root/graphics/okular/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/okular/Makefile')
-rw-r--r--graphics/okular/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/graphics/okular/Makefile b/graphics/okular/Makefile
index bfe059266c77..8fbe5bdf5f97 100644
--- a/graphics/okular/Makefile
+++ b/graphics/okular/Makefile
@@ -2,34 +2,36 @@
PORTNAME= okular
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 universal document viewer
LIB_DEPENDS= djvulibre:${PORTSDIR}/graphics/djvulibre \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- qca.2:${PORTSDIR}/devel/qca \
- tiff.4:${PORTSDIR}/graphics/tiff \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ qca:${PORTSDIR}/devel/qca \
+ tiff:${PORTSDIR}/graphics/tiff \
poppler-qt4:${PORTSDIR}/graphics/poppler-qt4 \
- spectre.1:${PORTSDIR}/print/libspectre \
- chm.0:${PORTSDIR}/misc/chmlib \
- freetype.9:${PORTSDIR}/print/freetype2 \
- epub.0:${PORTSDIR}/textproc/ebook-tools
+ spectre:${PORTSDIR}/print/libspectre \
+ chm:${PORTSDIR}/misc/chmlib \
+ freetype:${PORTSDIR}/print/freetype2 \
+ epub:${PORTSDIR}/textproc/ebook-tools
CONFLICTS= kdegraphics-4.[0-6].*
-USE_KDE4= kdehier kdelibs kdeprefix automoc4 qimageblitz
+USE_KDE4= kdehier kdelibs kdeprefix automoc4 qimageblitz kactivities
USES= cmake:outsource
-USE_QT4= gui xml qmake_build moc_build uic_build rcc_build
-USE_XZ= yes
+USE_QT4= corelib declarative gui opengl xml \
+ qmake_build moc_build uic_build rcc_build
+USE_XZ= yes
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
+MAN1= okular.1
+
OPTIONS_DEFINE= DVI
DVI_DESC= Support DVI files (requires teTeX)