aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv/files/extra-patch-modules_dnn__modern_CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/opencv/files/extra-patch-modules_dnn__modern_CMakeLists.txt')
-rw-r--r--graphics/opencv/files/extra-patch-modules_dnn__modern_CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/graphics/opencv/files/extra-patch-modules_dnn__modern_CMakeLists.txt b/graphics/opencv/files/extra-patch-modules_dnn__modern_CMakeLists.txt
new file mode 100644
index 000000000000..cd478f415543
--- /dev/null
+++ b/graphics/opencv/files/extra-patch-modules_dnn__modern_CMakeLists.txt
@@ -0,0 +1,37 @@
+--- modules/dnn_modern/CMakeLists.txt.orig 2017-12-22 19:15:17.000000000 +0300
++++ modules/dnn_modern/CMakeLists.txt 2018-01-17 02:29:23.382430000 +0300
+@@ -15,20 +15,20 @@
+
+ set(TINY_DNN_CPP_PATH "${OpenCV_BINARY_DIR}/3rdparty/tinydnn")
+ set(TINY_DNN_CPP_ROOT "${TINY_DNN_CPP_PATH}/tiny-dnn-1.0.0a3")
+-ocv_download(FILENAME "v1.0.0a3.tar.gz"
+- HASH "adb1c512e09ca2c7a6faef36f9c53e59"
+- URL
+- "${OPENCV_TINY_DNN_URL}"
+- "$ENV{OPENCV_TINY_DNN_URL}"
+- "https://github.com/tiny-dnn/tiny-dnn/archive/"
+- DESTINATION_DIR "${TINY_DNN_CPP_PATH}"
+- STATUS TINY_DNN_DOWNLOAD_SUCCESS
+- ID "tiny-dnn"
+- UNPACK RELATIVE_URL)
+-
+-if(NOT TINY_DNN_DOWNLOAD_SUCCESS)
+- message(STATUS "Failed to download tiny-dnn sources")
+-endif()
++#ocv_download(FILENAME "v1.0.0a3.tar.gz"
++# HASH "adb1c512e09ca2c7a6faef36f9c53e59"
++# URL
++# "${OPENCV_TINY_DNN_URL}"
++# "$ENV{OPENCV_TINY_DNN_URL}"
++# "https://github.com/tiny-dnn/tiny-dnn/archive/"
++# DESTINATION_DIR "${TINY_DNN_CPP_PATH}"
++# STATUS TINY_DNN_DOWNLOAD_SUCCESS
++# ID "tiny-dnn"
++# UNPACK RELATIVE_URL)
++#
++#if(NOT TINY_DNN_DOWNLOAD_SUCCESS)
++# message(STATUS "Failed to download tiny-dnn sources")
++#endif()
+
+ find_package(TinyDNN QUIET)
+