aboutsummaryrefslogtreecommitdiff
path: root/graphics/openpgl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/openpgl/Makefile')
-rw-r--r--graphics/openpgl/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/openpgl/Makefile b/graphics/openpgl/Makefile
index e62f56d67c1a..f93b6f1390e1 100644
--- a/graphics/openpgl/Makefile
+++ b/graphics/openpgl/Makefile
@@ -1,8 +1,7 @@
PORTNAME= openpgl
DISTVERSIONPREFIX= v
-DISTVERSION= 0.4.1
-PORTREVISION= 2
-DISTVERSIONSUFFIX= -beta
+DISTVERSION= 0.5.0
+#DISTVERSIONSUFFIX= -beta
CATEGORIES= graphics devel
MAINTAINER= FreeBSD@Shaneware.biz
@@ -14,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
# supported processors -
# arm with NEON/NEON2X and x86_64 with SSE4/AVX2/AVX512
-ONLY_FOR_ARCHS= amd64 armv6 armv7
+ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7
ONLY_FOR_ARCHS_REASON= requires supported SIMD ISA
LIB_DEPENDS= libembree3.so:graphics/embree \
@@ -26,4 +25,6 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= OpenPathGuidingLibrary
+PLIST_SUB= VERSION="${PORTVERSION}"
+
.include <bsd.port.mk>