aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-h3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-h3/Makefile')
-rw-r--r--graphics/py-h3/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/graphics/py-h3/Makefile b/graphics/py-h3/Makefile
new file mode 100644
index 000000000000..645f2780af11
--- /dev/null
+++ b/graphics/py-h3/Makefile
@@ -0,0 +1,31 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= h3
+PORTVERSION= 3.6.4
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python binding of H3 library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= cmake:devel/cmake \
+ ${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR}
+LIB_DEPENDS= libh3.so:graphics/h3
+
+USES= localbase:ldflags python
+USE_PYTHON= autoplist concurrent cython distutils
+
+CFLAGS+= -I${LOCALBASE}/include/h3
+
+OPTIONS_DEFINE= NUMPY
+OPTIONS_DEFAULT=NUMPY
+NUMPY_DESC= NumPy support
+
+NUMPY_RUN_DEPENDS= ${PYNUMPY}
+
+.include <bsd.port.mk>