aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pyqtgraph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-pyqtgraph/Makefile')
-rw-r--r--graphics/py-pyqtgraph/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/graphics/py-pyqtgraph/Makefile b/graphics/py-pyqtgraph/Makefile
index 7b3ecf1d3c4f..80dbad756823 100644
--- a/graphics/py-pyqtgraph/Makefile
+++ b/graphics/py-pyqtgraph/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pyqtgraph
-DISTVERSION= 0.12.4
+DISTVERSION= 0.13.1
CATEGORIES= graphics science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,10 +11,15 @@ WWW= https://www.pyqtgraph.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}colorcet>0:graphics/py-colorcet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}PyOpenGL>0:graphics/py-PyOpenGL@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}qt5-pyqt>0:devel/py-qt5-pyqt@${PY_FLAVOR} # PyQtGraph requires one of PyQt5, PyQt6, PySide2 or PySide6
-USES= python:3.6+
-USE_PYTHON= autoplist distutils
+USES= python:3.8+
+USE_PYTHON= distutils autoplist pytest # 1 test fails, see https://github.com/pyqtgraph/pyqtgraph/issues/2444
NO_ARCH= yes