aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-wand/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/py-wand/Makefile')
-rw-r--r--graphics/py-wand/Makefile25
1 files changed, 1 insertions, 24 deletions
diff --git a/graphics/py-wand/Makefile b/graphics/py-wand/Makefile
index 552aabeaff68..8466489ecd36 100644
--- a/graphics/py-wand/Makefile
+++ b/graphics/py-wand/Makefile
@@ -11,32 +11,9 @@ WWW= https://github.com/emcconville/wand
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.6+
+USES= magick python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTIONS_DEFINE= X11
-OPTIONS_SINGLE= IMAGEMAGICK
-OPTIONS_SINGLE_IMAGEMAGICK= IMAGEMAGICK6 IMAGEMAGICK7
-OPTIONS_DEFAULT=IMAGEMAGICK7 X11
-IMAGEMAGICK6_DESC= Use ImageMagick 6.x (graphics/ImageMagick6*)
-IMAGEMAGICK7_DESC= Use ImageMagick 7.x (graphics/ImageMagick7*)
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MX11}
-.if ${PORT_OPTIONS:MIMAGEMAGICK7}
-USES+= magick:7
-.else
-USES+= magick:6
-.endif
-.else
-.if ${PORT_OPTIONS:MIMAGEMAGICK7}
-USES+= magick:7,nox11
-.else
-USES+= magick:6,nox11
-.endif
-.endif
-
.include <bsd.port.mk>