aboutsummaryrefslogtreecommitdiff
path: root/graphics/tiled/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/tiled/Makefile')
-rw-r--r--graphics/tiled/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/graphics/tiled/Makefile b/graphics/tiled/Makefile
index fa18adbf278c..2adbd51034c3 100644
--- a/graphics/tiled/Makefile
+++ b/graphics/tiled/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tiled
-PORTVERSION= 1.1.6
-PORTREVISION= 1
+PORTVERSION= 1.2.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics editors games
@@ -29,12 +28,16 @@ OPTIONS_DEFAULT=PYTHON
OPTIONS_SUB= yes
PYTHON_DESC= Enable python plugin
-PYTHON_USES= pkgconfig python:2.7
+PYTHON_USES= pkgconfig python:3.6+
PYTHON_QMAKE_OFF= DISABLE_PYTHON_PLUGIN=yes
post-patch:
@${FIND} ${WRKSRC} -name "*.pro" -exec ${REINPLACE_CMD} -e 's|share/man|man|' {} \;
+post-patch-PYTHON-on:
+ @${REINPLACE_CMD} -e 's|python3|python-${PYTHON_VER}|' \
+ ${WRKSRC}/src/plugins/python/find_python.pri
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in AUTHORS README.md NEWS.md