aboutsummaryrefslogtreecommitdiff
path: root/graphics/zphoto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/zphoto/Makefile')
-rw-r--r--graphics/zphoto/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index 6d74951e256d..f453101447b0 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zphoto
-PORTVERSION= 0.9
+PORTVERSION= 1.0
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,6 +18,11 @@ LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming \
Imlib2.2:${PORTSDIR}/graphics/imlib2 \
popt.0:${PORTSDIR}/devel/popt \
aviplay.0:${PORTSDIR}/multimedia/avifile
+.if defined (WITH_WXGTK)
+LIB_DEPENDS+= wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk
+.elif defined (WITH_WXGTK2)
+LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
+.endif
RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip
USE_REINPLACE= yes
@@ -25,10 +30,19 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="-I${LOCALBASE}/include \
${PTHREAD_CFLAGS}"
+.if defined (WITH_WXGTK) || (WITH_WXGTK2)
+PLIST+= ${PKGDIR}/pkg-plist.wxzphoto
+.else
+CONFIGURE_ARGS= --disable-wx
+.endif
USE_GMAKE= yes
USE_XLIB= yes
post-patch:
@${REINPLACE_CMD} -e 's|<ming.h>|<ming/ming.h>|g' ${WRKSRC}/*.c ${WRKSRC}/configure
-
+.if defined (WITH_WXGTK)
+ @${REINPLACE_CMD} -e 's|wxgtk2-config||g' -e 's|wxgtk2-2.5-config||g' -e 's|wxgtk2-2.4-config||g' ${WRKSRC}/configure
+.elif defined (WITH_WXGTK2)
+ @${REINPLACE_CMD} -e 's|wx-config||g' -e 's|wxgtk-config||g' ${WRKSRC}/configure
+.endif
.include <bsd.port.mk>