aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Cgraph/Makefile4
-rw-r--r--graphics/GraphicsMagick13/Makefile2
-rw-r--r--graphics/SciPlot/Makefile2
-rw-r--r--graphics/devil/Makefile2
-rw-r--r--graphics/dri/Makefile2
-rw-r--r--graphics/electrix/Makefile2
-rw-r--r--graphics/evas-loader-generic/Makefile11
-rw-r--r--graphics/evas/Makefile8
-rw-r--r--graphics/freeglut/Makefile2
-rw-r--r--graphics/gimp-help/Makefile8
-rw-r--r--graphics/inkscape/Makefile2
-rw-r--r--graphics/ivtools/Makefile2
-rw-r--r--graphics/kipi-plugins-kde4/Makefile8
-rw-r--r--graphics/libGL/bsd.mesalib.mk4
-rw-r--r--graphics/libprojectm/Makefile2
-rw-r--r--graphics/opendx/Makefile4
-rw-r--r--graphics/projectm-libvisual/Makefile2
-rw-r--r--graphics/py-pyggel/Makefile2
-rw-r--r--graphics/ruby-gd/Makefile2
-rw-r--r--graphics/svgfig/Makefile4
-rw-r--r--graphics/uDrawGraph/Makefile2
21 files changed, 34 insertions, 43 deletions
diff --git a/graphics/Cgraph/Makefile b/graphics/Cgraph/Makefile
index 867a65902c36..da1e29e6066d 100644
--- a/graphics/Cgraph/Makefile
+++ b/graphics/Cgraph/Makefile
@@ -12,8 +12,8 @@ MAINTAINER= tobez@FreeBSD.org
COMMENT= A PostScript plotting library in C
WRKSRC= ${WRKDIR}/Cgraph/source
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:L}
-EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME:L}
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:tl}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME:tl}
USE_LDCONFIG= yes
diff --git a/graphics/GraphicsMagick13/Makefile b/graphics/GraphicsMagick13/Makefile
index 776ef87902ab..b329e9eeebee 100644
--- a/graphics/GraphicsMagick13/Makefile
+++ b/graphics/GraphicsMagick13/Makefile
@@ -7,7 +7,7 @@ PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= SF \
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.3/
-MASTER_SITE_SUBDIR= ${PORTNAME:L}/${PORTNAME:L}/${PORTVERSION}
+MASTER_SITE_SUBDIR= ${PORTNAME:tl}/${PORTNAME:tl}/${PORTVERSION}
PKGNAMESUFFIX= 13
MAINTAINER= ports@FreeBSD.org
diff --git a/graphics/SciPlot/Makefile b/graphics/SciPlot/Makefile
index 4d3171e14078..c78cc20899f2 100644
--- a/graphics/SciPlot/Makefile
+++ b/graphics/SciPlot/Makefile
@@ -19,7 +19,7 @@ MAKE_ENV= EXTRA_DEFINES="-fPIC" LIBNAME=${LIBNAME}
USE_LDCONFIG= yes
INCLUDES= SciPlot.h SciPlotP.h SciPlotUtil.h
-LIBNAME= lib${PORTNAME:L} # Remove :L for libSciPlot
+LIBNAME= lib${PORTNAME:tl} # Remove :tl for libSciPlot
PLIST_SUB= LIBNAME=${LIBNAME}
PORTDOCS= README SciPlot.html SciPlotDemo.html SciPlotProg.html
diff --git a/graphics/devil/Makefile b/graphics/devil/Makefile
index 92a102a0895a..b9516a64aed3 100644
--- a/graphics/devil/Makefile
+++ b/graphics/devil/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ARGS= --enable-ILU \
USE_LDCONFIG= yes
USE_GCC= any
-WRKSRC= ${WRKDIR}/${DISTNAME:L}
+WRKSRC= ${WRKDIR}/${DISTNAME:tl}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/graphics/dri/Makefile b/graphics/dri/Makefile
index 026b79a023dd..098adbefacd8 100644
--- a/graphics/dri/Makefile
+++ b/graphics/dri/Makefile
@@ -86,7 +86,7 @@ PLIST_SUB+= ${_d}_DRIVER="@comment "
.if !(${ARCH} == amd64 || ${ARCH} == i386)
CONFIGURE_ARGS+=--disable-gallium-intel
.endif
-CONFIGURE_ARGS+=--with-dri-drivers="${DRI_DRIVERS:L}"
+CONFIGURE_ARGS+=--with-dri-drivers="${DRI_DRIVERS:tl}"
.if defined(WITH_NEW_XORG) && !defined(WITH_GALLIUM) \
&& (${ARCH} == i386 || ${ARCH} == amd64)
diff --git a/graphics/electrix/Makefile b/graphics/electrix/Makefile
index 8ea31e059d67..0c5593e8aca7 100644
--- a/graphics/electrix/Makefile
+++ b/graphics/electrix/Makefile
@@ -4,7 +4,7 @@ PORTNAME= electrix
PORTVERSION= 0.2.0
PORTREVISION= 2
CATEGORIES= graphics print
-MASTER_SITES= SF/${PORTNAME:L}/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME:tl}/${PORTVERSION}
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Application to view PDF files
diff --git a/graphics/evas-loader-generic/Makefile b/graphics/evas-loader-generic/Makefile
index ce1130a901b9..00ede3123bfb 100644
--- a/graphics/evas-loader-generic/Makefile
+++ b/graphics/evas-loader-generic/Makefile
@@ -16,13 +16,10 @@ LICENSE= BSD
EVAS_GENERIC_LOADERS= gst pdf ps raw svg xcf
-#bmake compatibility
-.MAKE.FreeBSD_UL= yes
-
.for NODE in ${EVAS_GENERIC_LOADERS}
-OPTIONS_DEFINE+= ${NODE:U}
-OPTIONS_DEFAULT+= ${NODE:U}
-${NODE:U}_DESC= Install ${NODE} evas generic loader
+OPTIONS_DEFINE+= ${NODE:tu}
+OPTIONS_DEFAULT+= ${NODE:tu}
+${NODE:tu}_DESC= Install ${NODE} evas generic loader
.endfor
DIST_SUBDIR= e17
@@ -40,7 +37,7 @@ CONFIGURE_ARGS+= --enable-image-loader-generic
.include <bsd.port.options.mk>
.for NODE in ${EVAS_GENERIC_LOADERS}
-. if ${PORT_OPTIONS:M${NODE:U}}
+. if ${PORT_OPTIONS:M${NODE:tu}}
RUN_DEPENDS+= ${LOCALBASE}/lib/evas/utils/evas_image_loader.${NODE}:${PORTSDIR}/graphics/evas_generic_loaders-${NODE}
. endif
.endfor
diff --git a/graphics/evas/Makefile b/graphics/evas/Makefile
index 5259ff3beb2c..0ea9691c658c 100644
--- a/graphics/evas/Makefile
+++ b/graphics/evas/Makefile
@@ -24,24 +24,24 @@ OPTIONS_DEFAULT=BUFFER OPENGL X11 \
PNG PMAPS PSD TGA TIFF WBMP XPM
.for NODE in ${OPTIONS_MULTI_ENGINES}
-${NODE}_DESC= Install ${NODE:L} engine
+${NODE}_DESC= Install ${NODE:tl} engine
.endfor
.for NODE in ${OPTIONS_DEFINE}
-${NODE}_DESC= Install ${NODE:L} loader
+${NODE}_DESC= Install ${NODE:tl} loader
.endfor
.include <bsd.port.options.mk>
.for NODE in ${OPTIONS_MULTI_ENGINES}
. if ${PORT_OPTIONS:M${NODE}}
-USE_EFL_EVAS_ENGINES+= ${NODE:L}
+USE_EFL_EVAS_ENGINES+= ${NODE:tl}
. endif
.endfor
.for NODE in ${OPTIONS_DEFINE}
. if ${PORT_OPTIONS:M${NODE}}
-USE_EFL_EVAS_LOADERS+= ${NODE:L}
+USE_EFL_EVAS_LOADERS+= ${NODE:tl}
. endif
.endfor
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index bdf28110fe18..30520ffc6a8f 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -53,7 +53,7 @@ post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/progs/demos/Fractals/fractals.dat ${STAGEDIR}${EXAMPLESDIR}
.for prog in ${BINS}
- @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${prog}/.libs/${prog:L} ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${prog}/.libs/${prog:tl} ${STAGEDIR}${EXAMPLESDIR}
.endfor
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
diff --git a/graphics/gimp-help/Makefile b/graphics/gimp-help/Makefile
index 76390a6ac70d..cdf2423a7636 100644
--- a/graphics/gimp-help/Makefile
+++ b/graphics/gimp-help/Makefile
@@ -12,8 +12,6 @@ COMMENT= The meta port for GIMP User Manual
LICENSE= GFDL
-.MAKE.FreeBSD_UL= yes
-
NO_BUILD= yes
NO_INSTALL= yes
NO_MTREE= yes
@@ -49,7 +47,7 @@ sl_NAME= Slovenian
sv_NAME= Swedish
zh_CN_NAME= Chinese Simplified
-OPTIONS_DEFINE= ALL ${LANG_ALL_HTML:U}
+OPTIONS_DEFINE= ALL ${LANG_ALL_HTML:tu}
OPTIONS_DEFAULT= ALL
ALL_DESC= All translations
@@ -57,8 +55,8 @@ ALL_DESC= All translations
${lang}_DETECT?= ${LOCALBASE}/share/gimp/help/${lang}/index.html
${lang}_PORT?= misc/gimp-help-${lang}
${lang}_NAME?= ${lang}
-${lang:U}_DESC= ${${lang}_NAME}
-${lang:U}_RUN_DEPENDS= ${${lang}_DETECT}:${PORTSDIR}/${${lang}_PORT}
+${lang:tu}_DESC= ${${lang}_NAME}
+${lang:tu}_RUN_DEPENDS= ${${lang}_DETECT}:${PORTSDIR}/${${lang}_PORT}
ALL_RUN_DEPENDS+= ${${lang}_DETECT}:${PORTSDIR}/${${lang}_PORT}
.endfor
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 71a095cb0a85..b857c2bec492 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 0.48.4
PORTREVISION= 4
CATEGORIES= graphics gnome
MASTER_SITES= SF
-MASTER_SITE_SUBDIR=${PORTNAME:L}/${PORTNAME:L}/${PORTVERSION}
+MASTER_SITE_SUBDIR=${PORTNAME:tl}/${PORTNAME:tl}/${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Full featured open source SVG editor
diff --git a/graphics/ivtools/Makefile b/graphics/ivtools/Makefile
index 15d3707ff34b..e76329881734 100644
--- a/graphics/ivtools/Makefile
+++ b/graphics/ivtools/Makefile
@@ -19,7 +19,7 @@ USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --with-tiff=${PREFIX}
CONFIGURE_ENV= IMAKECPP=${CPP}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
-MAKE_ARGS= ARCH="${OPSYS:U}" MAKE="${MAKE_CMD}"
+MAKE_ARGS= ARCH="${OPSYS:tu}" MAKE="${MAKE_CMD}"
USE_XORG= x11 xaw ice xext
MANCOMPRESSED= no
diff --git a/graphics/kipi-plugins-kde4/Makefile b/graphics/kipi-plugins-kde4/Makefile
index 445e629af38f..814aafb2852d 100644
--- a/graphics/kipi-plugins-kde4/Makefile
+++ b/graphics/kipi-plugins-kde4/Makefile
@@ -10,8 +10,6 @@ DISTFILES= #
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 kipi graphics plugins (meta port)
-.MAKE.FreeBSD_UL= yes
-
NO_BUILD= yes
NO_INSTALL= yes
NO_MTREE= yes
@@ -25,9 +23,9 @@ OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
NO_OPTIONS_SORT= yes
.for plugin in ${KIPI_PLUGINS_ALL}
-OPTIONS_DEFINE+= ${plugin:U}
-${plugin:U}_DESC= ${${plugin}_DESC}
-${plugin:U}_RUN_DEPENDS= kipi-plugin-${plugin}>=${DIGIKAM_VER}:${PORTSDIR}/graphics/kipi-plugin-${plugin}
+OPTIONS_DEFINE+= ${plugin:tu}
+${plugin:tu}_DESC= ${${plugin}_DESC}
+${plugin:tu}_RUN_DEPENDS= kipi-plugin-${plugin}>=${DIGIKAM_VER}:${PORTSDIR}/graphics/kipi-plugin-${plugin}
.endfor
NLS_DEP= digikam-l10n>=${DIGIKAM_VER}:${PORTSDIR}/graphics/digikam-kde4-l10n
diff --git a/graphics/libGL/bsd.mesalib.mk b/graphics/libGL/bsd.mesalib.mk
index 1a87e02bcfc2..4d8a7beabc26 100644
--- a/graphics/libGL/bsd.mesalib.mk
+++ b/graphics/libGL/bsd.mesalib.mk
@@ -11,8 +11,6 @@
#
# $FreeBSD$
-.MAKE.FreeBSD_UL= yes
-
MESAVERSION= ${MESABASEVERSION}${MESASUBVERSION:C/^(.)/.\1/}
MESADISTVERSION=${MESABASEVERSION}${MESASUBVERSION:C/^(.)/-\1/}
@@ -86,7 +84,7 @@ DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
WRKSRC= ${WRKDIR}/Mesa-${MESADISTVERSION}
-COMPONENT= ${PORTNAME:L:C/^lib//:C/mesa-//}
+COMPONENT= ${PORTNAME:tl:C/^lib//:C/mesa-//}
.if ${COMPONENT:Mglesv2} == ""
CONFIGURE_ARGS+= --disable-gles2
diff --git a/graphics/libprojectm/Makefile b/graphics/libprojectm/Makefile
index 54d4b61776df..8796a2a10ff7 100644
--- a/graphics/libprojectm/Makefile
+++ b/graphics/libprojectm/Makefile
@@ -4,7 +4,7 @@ PORTNAME= libprojectM
PORTVERSION= 2.0.1
PORTREVISION= 2
CATEGORIES= graphics audio
-MASTER_SITES= SF/${PORTNAME:L:S/lib//}/${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME:tl:S/lib//}/${PORTVERSION}/
DISTNAME= ${PORTNAME:S/lib//}-${DISTVERSION}-Source
MAINTAINER= crees@FreeBSD.org
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index 4306b35e73fd..12d91624e9a3 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -22,11 +22,11 @@ USE_GL= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CFLAGS+= ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= ARCH="${OPSYS:L}"
+CONFIGURE_ENV= ARCH="${OPSYS:tl}"
CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
NO_MTREE= yes
-PLIST_SUB= ARCH=${OPSYS:L}
+PLIST_SUB= ARCH=${OPSYS:tl}
PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(WITH_HDF) && !defined(WITHOUT_NETCDF)
diff --git a/graphics/projectm-libvisual/Makefile b/graphics/projectm-libvisual/Makefile
index edb044087a4b..60887fd30f40 100644
--- a/graphics/projectm-libvisual/Makefile
+++ b/graphics/projectm-libvisual/Makefile
@@ -3,7 +3,7 @@
PORTNAME= projectM-libvisual
PORTVERSION= 2.0.1
CATEGORIES= graphics audio
-MASTER_SITES= SF/${PORTNAME:L:S/-libvisual//}/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME:tl:S/-libvisual//}/${PORTVERSION}
DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}-Source
MAINTAINER= crees@FreeBSD.org
diff --git a/graphics/py-pyggel/Makefile b/graphics/py-pyggel/Makefile
index fe7441f3e743..a6b86ca38741 100644
--- a/graphics/py-pyggel/Makefile
+++ b/graphics/py-pyggel/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 0.08
DISTVERSIONSUFFIX= -alpha4c
CATEGORIES= graphics python
MASTER_SITES= GOOGLE_CODE
-DISTNAME= ${PORTNAME:U}-V${DISTVERSION}${DISTVERSIONSUFFIX}
+DISTNAME= ${PORTNAME:tu}-V${DISTVERSION}${DISTVERSIONSUFFIX}
DIST_SUBDIR= python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index 33c341767c64..a153b015174c 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -22,7 +22,7 @@ NEED_ROOT= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-RUBY_MODNAME= ${PORTNAME:L}
+RUBY_MODNAME= ${PORTNAME:tl}
CONFIGURE_ARGS= --with-gd-lib="${LOCALBASE}/lib" \
--with-jpeg \
diff --git a/graphics/svgfig/Makefile b/graphics/svgfig/Makefile
index a358179f0e71..31fb91079427 100644
--- a/graphics/svgfig/Makefile
+++ b/graphics/svgfig/Makefile
@@ -6,13 +6,13 @@ PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME:L}-${PORTVERSION}
+DISTNAME= ${PORTNAME:tl}-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Draw mathematical figures in SVG using Python
-WRKSRC= ${WRKDIR}/${PORTNAME:L}
+WRKSRC= ${WRKDIR}/${PORTNAME:tl}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/graphics/uDrawGraph/Makefile b/graphics/uDrawGraph/Makefile
index e9464dacb101..de68333e0510 100644
--- a/graphics/uDrawGraph/Makefile
+++ b/graphics/uDrawGraph/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 3.1.1
#PORTREVISION= 0
CATEGORIES= graphics math
MASTER_SITES= http://www.informatik.uni-bremen.de/uDrawGraph/download/
-DISTNAME= ${PORTNAME}-${PORTVERSION}-${PKGNUM}-${OPSYS:L}-${ARCH}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${PKGNUM}-${OPSYS:tl}-${ARCH}
MAINTAINER= nivit@FreeBSD.org
COMMENT= A graph drawing/visualization system