aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/partio/Makefile2
-rw-r--r--graphics/py-python-poppler-qt5/Makefile2
-rw-r--r--graphics/py-qt5-svg/Makefile30
-rw-r--r--graphics/py-qt5-svg/pkg-descr4
-rw-r--r--graphics/py-qt5-svg/pkg-plist8
-rw-r--r--graphics/py-traitsui/Makefile2
-rw-r--r--graphics/py-visvis/Makefile2
-rw-r--r--graphics/qgis-ltr/Makefile4
-rw-r--r--graphics/qgis-ltr/files/patch-cmake_FindSIP.py47
-rw-r--r--graphics/qgis/Makefile3
-rw-r--r--graphics/qtqr/Makefile2
-rw-r--r--graphics/rapid-photo-downloader/Makefile2
-rw-r--r--graphics/seexpr/Makefile3
14 files changed, 58 insertions, 54 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index ead72b211277..471d2af5699e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -904,7 +904,6 @@
SUBDIR += py-pyvips
SUBDIR += py-pyx
SUBDIR += py-qrencode
- SUBDIR += py-qt5-svg
SUBDIR += py-railroad-diagrams
SUBDIR += py-rasterio
SUBDIR += py-rasterstats
diff --git a/graphics/partio/Makefile b/graphics/partio/Makefile
index 5fdacd155f50..88a96fe25cdf 100644
--- a/graphics/partio/Makefile
+++ b/graphics/partio/Makefile
@@ -35,7 +35,7 @@ DOXYGEN_ALL_TARGET= all doc
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
PYQT_USES= pyqt:5
-PYQT_USE= PYQT=core,gui,widgets
+PYQT_USE= PYQT=pyqt5
PYQT_PLIST_FILES= bin/partedit bin/partinspect
TEST_LIB_DEPENDS= libgtest.so:devel/googletest
diff --git a/graphics/py-python-poppler-qt5/Makefile b/graphics/py-python-poppler-qt5/Makefile
index 97b6768d54b0..e4a7e680b26f 100644
--- a/graphics/py-python-poppler-qt5/Makefile
+++ b/graphics/py-python-poppler-qt5/Makefile
@@ -18,7 +18,7 @@ USES= compiler:c++11-lang gl pkgconfig pyqt:5 python:3.7-3.9 qt:5
USE_GITHUB= yes
GH_ACCOUNT= frescobaldi
USE_GL= gl
-USE_PYQT= gui qtbuilder xml sip_build
+USE_PYQT= pyqt5 sip_build
USE_QT= core gui xml
PLIST_SUB= _PY_SONAME=${_PY_SONAME}
diff --git a/graphics/py-qt5-svg/Makefile b/graphics/py-qt5-svg/Makefile
deleted file mode 100644
index 55accfc38cdc..000000000000
--- a/graphics/py-qt5-svg/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-PORTNAME= svg
-PORTREVISION= 3
-CATEGORIES= graphics devel python
-
-MAINTAINER= kde@FreeBSD.org
-COMMENT= Python bindings for the Qt5 toolkit, QtSvg module
-
-CONFIGURE_ARGS= --enable QtSvg
-PYQT_DIST= yes
-
-USES= gl python:3.5+ pyqt:5 qt:5
-USE_GL= gl
-USE_PYQT= sip_build core_run gui_run widgets_run
-USE_PYTHON= concurrent flavors py3kplist
-USE_QT= core gui svg widgets qmake_build
-
-OPTIONS_DEFINE= API DEBUG
-OPTIONS_DEFAULT=API
-OPTIONS_SUB= yes
-
-API_DESC= Install QtSvg API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
-API_CONFIGURE_OFF= --no-qsci-api
-API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
-DEBUG_CONFIGURE_ON= --debug --trace
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt5/QtSvg.so
-
-.include <bsd.port.mk>
diff --git a/graphics/py-qt5-svg/pkg-descr b/graphics/py-qt5-svg/pkg-descr
deleted file mode 100644
index 705c6e16baa6..000000000000
--- a/graphics/py-qt5-svg/pkg-descr
+++ /dev/null
@@ -1,4 +0,0 @@
-PyQt5 is a set of Python bindings for Qt5 application framework.
-This package provides the QtSvg module.
-
-WWW: https://riverbankcomputing.com/software/pyqt
diff --git a/graphics/py-qt5-svg/pkg-plist b/graphics/py-qt5-svg/pkg-plist
deleted file mode 100644
index b56a2cad5c5d..000000000000
--- a/graphics/py-qt5-svg/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-%%PYTHON_SITELIBDIR%%/PyQt5/QtSvg.so
-%%PYTHON_SITELIBDIR%%/PyQt5/QtSvg.pyi
-%%PYQT_SIPDIR%%/QtSvg/QtSvgmod.sip
-%%PYQT_SIPDIR%%/QtSvg/qgraphicssvgitem.sip
-%%PYQT_SIPDIR%%/QtSvg/qsvggenerator.sip
-%%PYQT_SIPDIR%%/QtSvg/qsvgrenderer.sip
-%%PYQT_SIPDIR%%/QtSvg/qsvgwidget.sip
-%%API%%%%PYQT_APIDIR%%/api/python/QtSvg.api
diff --git a/graphics/py-traitsui/Makefile b/graphics/py-traitsui/Makefile
index e78dd1472b2b..3f097b1da91d 100644
--- a/graphics/py-traitsui/Makefile
+++ b/graphics/py-traitsui/Makefile
@@ -41,7 +41,7 @@ OPTIONS_DEFAULT=QT5
QT5_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygments>=0:textproc/py-pygments@${PY_FLAVOR}
QT5_USES= pyqt:5
-QT5_USE= PYQT=core_run,gui_run,printsupport_run,svg_run,widgets_run
+QT5_USE= PYQT=pyqt5_run
# These tests were extracted from etstool.py and adapted to the ports test framework
do-test:
diff --git a/graphics/py-visvis/Makefile b/graphics/py-visvis/Makefile
index 0e9630bf309a..6085a867ef33 100644
--- a/graphics/py-visvis/Makefile
+++ b/graphics/py-visvis/Makefile
@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYNUMPY} \
USES= gl python:3.5+ pyqt:5
USE_GL= gl
-USE_PYQT= core gui
+USE_PYQT= pyqt5
USE_PYTHON= autoplist distutils
USE_WX= 3.0+
diff --git a/graphics/qgis-ltr/Makefile b/graphics/qgis-ltr/Makefile
index 654a6a341f06..62595e526c98 100644
--- a/graphics/qgis-ltr/Makefile
+++ b/graphics/qgis-ltr/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/doc/LICENSE
BUILD_DEPENDS= gpsbabel>=1.5.4:astro/gpsbabel \
opencl>=0:devel/opencl \
+ sip:devel/py-sip4 \
${PYTHON_PKGNAMEPREFIX}cycler>=0.10.0:devel/py-cycler@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=2.8.1:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}future>=0.18.2:devel/py-future@${PY_FLAVOR} \
@@ -104,8 +105,7 @@ USES= bison cmake compiler:features desktop-file-utils \
USE_GL= gl
USE_GNOME= libxml2
USE_LDCONFIG= yes
-USE_PYQT= core gui location network positioning qml quick quickwidgets \
- qscintilla2 pysip sip sql svg webkit_run webkitwidgets_run xml
+USE_PYQT= pyqt5 qscintilla2
USE_QT= 3d buildtools_build core concurrent dbus declarative \
designer doc gamepad gui linguist_build location \
network printsupport qmake_build script serialport \
diff --git a/graphics/qgis-ltr/files/patch-cmake_FindSIP.py b/graphics/qgis-ltr/files/patch-cmake_FindSIP.py
new file mode 100644
index 000000000000..dfe7adce9a97
--- /dev/null
+++ b/graphics/qgis-ltr/files/patch-cmake_FindSIP.py
@@ -0,0 +1,47 @@
+--- cmake/FindSIP.py.orig 2021-12-07 16:53:56 UTC
++++ cmake/FindSIP.py
+@@ -30,31 +30,17 @@
+ # Redistribution and use is allowed according to the terms of the BSD license.
+ # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+
+-try:
+- import sipbuild
+-except ImportError: # Code for SIP v4
+- import sipconfig
++import sipconfig
+
+- sipcfg = sipconfig.Configuration()
+- print("sip_version:%06.0x" % sipcfg.sip_version)
+- print("sip_version_num:%d" % sipcfg.sip_version)
+- print("sip_version_str:%s" % sipcfg.sip_version_str)
+- print("sip_bin:%s" % sipcfg.sip_bin)
+- print("default_sip_dir:%s" % sipcfg.default_sip_dir)
+- print("sip_inc_dir:%s" % sipcfg.sip_inc_dir)
+- # SIP 4.19.10+ has new sipcfg.sip_module_dir
+- if hasattr(sipcfg, "sip_module_dir"):
+- print("sip_module_dir:%s" % sipcfg.sip_module_dir)
+- else:
+- print("sip_module_dir:%s" % sipcfg.sip_mod_dir)
+-else: # Code for SIP v5
+- print("sip_version:%06.0x" % sipbuild.version.SIP_VERSION)
+- print("sip_version_num:%d" % sipbuild.version.SIP_VERSION)
+- print("sip_version_str:%s" % sipbuild.version.SIP_VERSION_STR)
+-
+- import shutil
+- print("sip_bin:%s" % shutil.which("sip5"))
+-
+- from distutils.sysconfig import get_python_lib
+- python_modules_dir = get_python_lib(plat_specific=1)
+- print("default_sip_dir:%s" % python_modules_dir)
++sipcfg = sipconfig.Configuration()
++print("sip_version:%06.0x" % sipcfg.sip_version)
++print("sip_version_num:%d" % sipcfg.sip_version)
++print("sip_version_str:%s" % sipcfg.sip_version_str)
++print("sip_bin:%s" % sipcfg.sip_bin)
++print("default_sip_dir:%s" % sipcfg.default_sip_dir)
++print("sip_inc_dir:%s" % sipcfg.sip_inc_dir)
++# SIP 4.19.10+ has new sipcfg.sip_module_dir
++if hasattr(sipcfg, "sip_module_dir"):
++ print("sip_module_dir:%s" % sipcfg.sip_module_dir)
++else:
++ print("sip_module_dir:%s" % sipcfg.sip_mod_dir)
diff --git a/graphics/qgis/Makefile b/graphics/qgis/Makefile
index 5318b9cf32f1..489cea7681be 100644
--- a/graphics/qgis/Makefile
+++ b/graphics/qgis/Makefile
@@ -106,8 +106,7 @@ USES= bison cmake compiler:features desktop-file-utils \
USE_GL= gl
USE_GNOME= libxml2
USE_LDCONFIG= yes
-USE_PYQT= core gui location network positioning qml quick quickwidgets \
- qscintilla2 pysip sip sql svg webkit_run webkitwidgets_run xml
+USE_PYQT= pyqt5 qscintilla2 pysip sip
USE_QT= 3d buildtools_build core concurrent dbus declarative \
designer doc gamepad gui linguist_build location \
network printsupport qmake_build script serialport \
diff --git a/graphics/qtqr/Makefile b/graphics/qtqr/Makefile
index 1ce9efdde089..e3c33c425d94 100644
--- a/graphics/qtqr/Makefile
+++ b/graphics/qtqr/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}zbar-py>=1.0.4:graphics/py-zbar-py@${PY_FLAVOR}
USES= desktop-file-utils pyqt:5 python:3.6+ shebangfix
-USE_PYQT= core_run gui_run network_run widgets_run
+USE_PYQT= pyqt5_run
USE_PYTHON= autoplist distutils
SHEBANG_FILES= qtqr.py
diff --git a/graphics/rapid-photo-downloader/Makefile b/graphics/rapid-photo-downloader/Makefile
index 0bc9cca24b9f..28005091b170 100644
--- a/graphics/rapid-photo-downloader/Makefile
+++ b/graphics/rapid-photo-downloader/Makefile
@@ -36,7 +36,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arrow>0:devel/py-arrow@${PY_FLAVOR} \
USES= desktop-file-utils gettext pyqt:5 python:3.6+ qt:5
USE_PYTHON= autoplist distutils noflavors
USE_QT= imageformats_run
-USE_PYQT= core gui network sip widgets
+USE_PYQT= pyqt5 sip
BINARY_ALIAS= python3=${PYTHON_VERSION}
NO_ARCH= yes
diff --git a/graphics/seexpr/Makefile b/graphics/seexpr/Makefile
index 9d4041068af5..bba03ab09b34 100644
--- a/graphics/seexpr/Makefile
+++ b/graphics/seexpr/Makefile
@@ -40,9 +40,10 @@ NLS_USES= kde:5
NLS_USE= KDE=ecm_build
NLS_CMAKE_OFF= -DBUILD_TRANSLATIONS:BOOL=FALSE
+PYTHON_BUILD_DEPENDS= sip:devel/py-sip4
PYTHON_LIB_DEPENDS= ${PY_BOOST}
PYTHON_USES= pyqt:5 python
-PYTHON_USE= PYQT=core_build,sip_build,widgets_build
+PYTHON_USE= PYQT=pyqt5
PYTHON_CMAKE_ON= -DPYQT_SIP_DIR:STRING=${PYQT_SIPDIR}
PYTHON_CMAKE_OFF= -DUSE_PYTHON:BOOL=FALSE