aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gnash/Makefile2
-rw-r--r--graphics/gnash/files/patch-libbase_GnashSleep.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/gnash/Makefile b/graphics/gnash/Makefile
index 336aa08fcfb8..883959b4b37f 100644
--- a/graphics/gnash/Makefile
+++ b/graphics/gnash/Makefile
@@ -34,7 +34,7 @@ USES= cpe tar:bzip2 compiler:c++11-lang autoreconf gmake libtool \
pkgconfig jpeg gnome gl sdl desktop-file-utils xorg
CPE_VENDOR= gnu
GNU_CONFIGURE= yes
-USE_GNOME= atk gtk20 libxml2 pango
+USE_GNOME= atk gdkpixbuf2 gtk20 libxml2 pango
USE_XORG= x11 xau xdmcp xext xi xinerama ice sm xv
USE_GL= egl
USE_SDL= sdl
diff --git a/graphics/gnash/files/patch-libbase_GnashSleep.h b/graphics/gnash/files/patch-libbase_GnashSleep.h
new file mode 100644
index 000000000000..c44b0e8a29c2
--- /dev/null
+++ b/graphics/gnash/files/patch-libbase_GnashSleep.h
@@ -0,0 +1,11 @@
+--- libbase/GnashSleep.h.orig 2022-12-05 11:34:39 UTC
++++ libbase/GnashSleep.h
+@@ -38,7 +38,7 @@ inline void gnashSleep(time_t useconds)
+ Sleep(useconds / 1000);
+ #else
+ const time_t m = 1000000;
+- const struct timespec t = { useconds / m, (useconds % m) * 1000 };
++ const struct timespec t = { useconds / m, (long)((useconds % m) * 1000) };
+ ::nanosleep(&t, nullptr);
+ #endif
+ }