aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/swfmill/Makefile7
-rw-r--r--graphics/swfmill/distinfo5
-rw-r--r--graphics/swfmill/files/patch-src_codegen_parsexml.xsl11
-rw-r--r--graphics/swfmill/files/patch-src_codegen_writexml.xsl11
4 files changed, 7 insertions, 27 deletions
diff --git a/graphics/swfmill/Makefile b/graphics/swfmill/Makefile
index 5865a41d4a98..8c04b3cbe0d1 100644
--- a/graphics/swfmill/Makefile
+++ b/graphics/swfmill/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= swfmill
-PORTVERSION= 0.3.3
-PORTREVISION= 5
+PORTVERSION= 0.3.4
CATEGORIES= graphics
MASTER_SITES= http://swfmill.org/releases/
@@ -13,7 +12,9 @@ COMMENT= Tool to generate or decompile Adobe Flash SWF files
LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libgcrypt.so:security/libgcrypt \
+ libgpg-error.so:security/libgpg-error
USES= dos2unix iconv gmake pkgconfig libtool
USE_GNOME= libxml2 libxslt
diff --git a/graphics/swfmill/distinfo b/graphics/swfmill/distinfo
index 58381fe136cb..69f10df40262 100644
--- a/graphics/swfmill/distinfo
+++ b/graphics/swfmill/distinfo
@@ -1,2 +1,3 @@
-SHA256 (swfmill-0.3.3.tar.gz) = f9e8529eed84962abf88c6457b59cbc6d230db068d1fdd977e7b234228beac96
-SIZE (swfmill-0.3.3.tar.gz) = 1386829
+TIMESTAMP = 1507454534
+SHA256 (swfmill-0.3.4.tar.gz) = 514843cdacd1c95a1a8b60a3f4f4fc6559932fb270c6a0585ad5c3275da03589
+SIZE (swfmill-0.3.4.tar.gz) = 1387014
diff --git a/graphics/swfmill/files/patch-src_codegen_parsexml.xsl b/graphics/swfmill/files/patch-src_codegen_parsexml.xsl
deleted file mode 100644
index 2e5d6f234a16..000000000000
--- a/graphics/swfmill/files/patch-src_codegen_parsexml.xsl
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/codegen/parsexml.xsl.orig 2013-10-30 17:33:35 UTC
-+++ src/codegen/parsexml.xsl
-@@ -19,7 +19,7 @@ char *fromXmlChar(const Context *ctx, co
- if (ctx->convertEncoding) {
- size_t len = strlen((const char *)from_str);
- iconv_t cd = iconv_open(ctx->swf_encoding, "UTF-8");
-- if (cd < 0) {
-+ if (cd == (iconv_t)-1) {
- fprintf(stderr, "iconv_open failed.\n");
- char *buf = new char[1];
- buf[0] = '\0';
diff --git a/graphics/swfmill/files/patch-src_codegen_writexml.xsl b/graphics/swfmill/files/patch-src_codegen_writexml.xsl
deleted file mode 100644
index fb95220452af..000000000000
--- a/graphics/swfmill/files/patch-src_codegen_writexml.xsl
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/codegen/writexml.xsl.orig 2013-10-30 17:33:35 UTC
-+++ src/codegen/writexml.xsl
-@@ -15,7 +15,7 @@ xmlChar *toXmlChar(const Context *ctx, c
- if (ctx->convertEncoding) {
- size_t len = strlen(from_str);
- iconv_t cd = iconv_open("UTF-8", ctx->swf_encoding);
-- if (cd < 0) {
-+ if (cd == (iconv_t)-1) {
- fprintf(stderr, "iconv_open failed.\n");
- return xmlCharStrdup("");
- }