aboutsummaryrefslogtreecommitdiff
path: root/irc/komanda-cli/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/komanda-cli/Makefile')
-rw-r--r--irc/komanda-cli/Makefile27
1 files changed, 7 insertions, 20 deletions
diff --git a/irc/komanda-cli/Makefile b/irc/komanda-cli/Makefile
index 452aac3d71a3..3647a598f491 100644
--- a/irc/komanda-cli/Makefile
+++ b/irc/komanda-cli/Makefile
@@ -1,6 +1,6 @@
PORTNAME= komanda-cli
DISTVERSION= g20190920
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= irc
MAINTAINER= lcook@FreeBSD.org
@@ -14,31 +14,14 @@ USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= mephux
GH_TAGNAME= b5ba03b
-GH_TUPLE= 0xAX:notificator:d81462e38c21:0xax_notificator/vendor/github.com/0xAX/notificator \
- BurntSushi:toml:v0.3.1:burntsushi_toml/vendor/github.com/BurntSushi/toml \
- alecthomas:kingpin:v2.2.6:alecthomas_kingpin/vendor/gopkg.in/alecthomas/kingpin.v2 \
- alecthomas:template:fb15b899a751:alecthomas_template/vendor/github.com/alecthomas/template \
- alecthomas:units:c3de453c63f4:alecthomas_units/vendor/github.com/alecthomas/units \
- davecgh:go-spew:v1.1.1:davecgh_go_spew/vendor/github.com/davecgh/go-spew \
- fluffle:goirc:v1.0.1:fluffle_goirc/vendor/github.com/fluffle/goirc \
- golang:mock:v1.1.1:golang_mock/vendor/github.com/golang/mock \
- golang:net:3b0461eec859:golang_net/vendor/golang.org/x/net \
- golang:sys:953cdadca894:golang_sys/vendor/golang.org/x/sys \
- hectane:go-nonblockingchan:v0.1.0:hectane_go_nonblockingchan/vendor/github.com/hectane/go-nonblockingchan \
- jroimartin:gocui:v0.4.0:jroimartin_gocui/vendor/github.com/jroimartin/gocui \
- konsorten:go-windows-terminal-sequences:v1.0.1:konsorten_go_windows_terminal_sequences/vendor/github.com/konsorten/go-windows-terminal-sequences \
- mattn:go-runewidth:v0.0.4:mattn_go_runewidth/vendor/github.com/mattn/go-runewidth \
- mephux:common:c3a670c8b76e:mephux_common/vendor/github.com/mephux/common \
- nsf:termbox-go:93860e161317:nsf_termbox_go/vendor/github.com/nsf/termbox-go \
- sirupsen:logrus:v1.4.2:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
- worg:merger:94181de72ed1:worg_merger/vendor/github.com/worg/merger
+GH_TUPLE= golang:sys:v0.6.0:sys
_BUILD_SHA= ${GH_TAGNAME}
_BUILD_COUNT= 138
_BUILD_TAG= ${_BUILD_COUNT}.${_BUILD_SHA}
GO_BUILDFLAGS= -ldflags "\
- -s -w \
+ ${STRIP} -w \
-X main.Build=${_BUILD_TAG}"
PLIST_FILES= bin/${PORTNAME}
@@ -46,6 +29,10 @@ PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
+pre-patch:
+ ${RM} -r ${WRKSRC}/vendor/golang.org/x/sys
+ ${LN} -s ${WRKDIR}/sys-* ${WRKSRC}/vendor/golang.org/x/sys
+
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}