aboutsummaryrefslogtreecommitdiff
path: root/irc/pounce/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/pounce/Makefile')
-rw-r--r--irc/pounce/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/irc/pounce/Makefile b/irc/pounce/Makefile
new file mode 100644
index 000000000000..e2f105502db3
--- /dev/null
+++ b/irc/pounce/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= pounce
+DISTVERSION= 2.4
+CATEGORIES= irc
+MASTER_SITES= https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER= june@causal.agency
+COMMENT= Multi-client IRC bouncer
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= localbase:ldflags ssl
+USE_RC_SUBR= calico pounce
+
+MAKE_ENV+= MANDIR=${MANPREFIX}/man
+CFLAGS+= -D'OPENSSL_BIN=\"${OPENSSL_BIN}\"'
+CFLAGS+= -D'CERTBOT_PATH=\"${LOCALBASE}/etc/letsencrypt\"'
+
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} == base || ${SSL_DEFAULT} == openssl
+LIB_DEPENDS+= libtls.so:security/libretls
+.endif
+
+.if ${SSL_DEFAULT} == base
+OPENSSL_BIN=/usr/bin/openssl
+.else
+OPENSSL_BIN=${LOCALBASE}/bin/openssl
+.endif
+
+post-install:
+ @${MKDIR} ${STAGEDIR}/var/run/calico
+.for b in calico pounce
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.post.mk>