aboutsummaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
Diffstat (limited to 'irc')
-rw-r--r--irc/party/Makefile1
-rw-r--r--irc/party/files/patch-ac11
2 files changed, 12 insertions, 0 deletions
diff --git a/irc/party/Makefile b/irc/party/Makefile
index 6efc00a17268..ac49216bc4db 100644
--- a/irc/party/Makefile
+++ b/irc/party/Makefile
@@ -7,6 +7,7 @@
PORTNAME= party
PORTVERSION= 2.12
+PORTREVISION= 1
CATEGORIES= irc
MASTER_SITES= http://www.vocito.com/downloads/software/party/ \
ftp://ftp.vocito.com/pub/vocito.com/software/party/
diff --git a/irc/party/files/patch-ac b/irc/party/files/patch-ac
new file mode 100644
index 000000000000..ee8a7c887d04
--- /dev/null
+++ b/irc/party/files/patch-ac
@@ -0,0 +1,11 @@
+--- proc.c.orig Thu Aug 22 23:22:19 2002
++++ proc.c Thu Aug 22 23:22:31 2002
+@@ -50,7 +50,7 @@
+ /* If a filter is running, and it is different, kill it */
+ if (out_fd != 1)
+ {
+- if (!strncmp(ofilter,opt[OPT_FILTER].str))
++ if (!strncmp(ofilter,opt[OPT_FILTER].str, BFSZ))
+ return(0);
+ else
+ stop_filter();