aboutsummaryrefslogtreecommitdiff
path: root/japanese/mozc-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'japanese/mozc-server/Makefile')
-rw-r--r--japanese/mozc-server/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/japanese/mozc-server/Makefile b/japanese/mozc-server/Makefile
index 20296b559677..719364ca69c1 100644
--- a/japanese/mozc-server/Makefile
+++ b/japanese/mozc-server/Makefile
@@ -23,11 +23,14 @@ USE_GITHUB= yes
GH_ACCOUNT= hrs-allbsd
GH_TUPLE= hiroyuki-komatsu:japanese-usage-dictionary:e5b3425:udic
-USES= compiler:c++11-lang gmake ninja:build pkgconfig \
+USES= compiler:c++17-lang gmake ninja:build pkgconfig \
python:build shebangfix tar:bzip2
SHEBANG_FILES= src/build_mozc.py
BUILD_WRKSRC= ${WRKSRC}/src
+LDFLAGS+= -labsl_spinlock_wait
+USE_CXXSTD= c++17
+
BUILD_MOZC_LIST?= mozc_server
.if ${BUILD_MOZC_LIST:Mmozc_server} == "mozc_server"