aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
Diffstat (limited to 'japanese')
-rw-r--r--japanese/another-htmllint/Makefile12
-rw-r--r--japanese/wikicker/Makefile8
2 files changed, 17 insertions, 3 deletions
diff --git a/japanese/another-htmllint/Makefile b/japanese/another-htmllint/Makefile
index 5c73272a915c..0f75570113a5 100644
--- a/japanese/another-htmllint/Makefile
+++ b/japanese/another-htmllint/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Another HTML-lint (all messages are written in Japanese)
RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode
USE_ZIP= YES
WRKSRC= ${WRKDIR}
@@ -50,4 +50,12 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/wikicker/Makefile b/japanese/wikicker/Makefile
index 6780753a0e2b..1ff7c9e4b8ee 100644
--- a/japanese/wikicker/Makefile
+++ b/japanese/wikicker/Makefile
@@ -29,7 +29,7 @@ RUN_DEPENDS+= \
${SITE_PERL}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+ ${JCODE}:${PORTSDIR}/japanese/p5-Jcode \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
@@ -54,6 +54,12 @@ IGNORE= requires Perl 5.6 or newer to run. Either install new Perl or define WIT
RUN_DEPENDS+= ${SITE_PERL}/Cache/Memcached.pm:${PORTSDIR}/databases/p5-Cache-Memcached
.endif
+.if ${PERL_LEVEL} < 500801
+JCODE= ${SITE_PERL}/${PERL_ARCH}/Jcode.pm
+.else
+JCODE= ${SITE_PERL}/Jcode.pm
+.endif
+
PERL_CONFIGURE= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
WIKIAUTO= ${SITE_PERL}/auto/${PORTNAME}