aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-uml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'java/eclipse-uml/Makefile')
-rw-r--r--java/eclipse-uml/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/java/eclipse-uml/Makefile b/java/eclipse-uml/Makefile
index f18781839adf..cea7e6fabcad 100644
--- a/java/eclipse-uml/Makefile
+++ b/java/eclipse-uml/Makefile
@@ -28,8 +28,8 @@ do-install:
@${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
@${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
@(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d -empty) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+ | ${SED} -ne 's,^,@dir lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>