aboutsummaryrefslogtreecommitdiff
path: root/lang/erlang14/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/erlang14/files')
-rw-r--r--lang/erlang14/files/epmd.sh.in26
-rw-r--r--lang/erlang14/files/patch-aj11
-rw-r--r--lang/erlang14/files/patch-erts-emulator-Makefile.in15
-rw-r--r--lang/erlang14/files/patch-erts-emulator-drivers-common-inet_drv.c29
-rw-r--r--lang/erlang14/files/patch-erts_config.h.in17
-rw-r--r--lang/erlang14/files/patch-erts_configure149
-rw-r--r--lang/erlang14/files/patch-erts_emulator_beam_erl__process__dump.c27
-rw-r--r--lang/erlang14/files/patch-erts_emulator_hipe_hipe__x86.c14
-rw-r--r--lang/erlang14/files/patch-lib_asn1_c__src_Makefile.in14
-rw-r--r--lang/erlang14/files/patch-lib_crypto_c__src_Makefile.in14
-rw-r--r--lang/erlang14/files/patch-lib_dialyzer_src_Makefile42
-rw-r--r--lang/erlang14/files/patch-lib_dialyzer_src_dialyzer__cl.erl14
-rw-r--r--lang/erlang14/files/patch-lib_dialyzer_src_dialyzer__cl__parse.erl14
-rw-r--r--lang/erlang14/files/patch-lib_erl__interface_src_connect_ei__resolve.c15
-rw-r--r--lang/erlang14/files/patch-lib_et_src_et__contents__viewer.erl13
-rw-r--r--lang/erlang14/files/patch-lib_et_src_et__viewer.erl15
-rw-r--r--lang/erlang14/files/patch-lib_gs_src_tool__utils.erl87
-rw-r--r--lang/erlang14/files/patch-lib_odbc_c_src_odbcserver.c10
-rw-r--r--lang/erlang14/files/patch-lib_sasl_src_rb.erl14
-rw-r--r--lang/erlang14/files/patch-lib_snmp_src_misc_snmp__config.erl14
-rw-r--r--lang/erlang14/files/patch-lib_stdlib_src_io__lib__pretty.erl16
-rw-r--r--lang/erlang14/files/patch-lib_typer_src_typer__info.erl13
-rw-r--r--lang/erlang14/files/pkg-message.in15
23 files changed, 0 insertions, 598 deletions
diff --git a/lang/erlang14/files/epmd.sh.in b/lang/erlang14/files/epmd.sh.in
deleted file mode 100644
index ea57aa23cdc0..000000000000
--- a/lang/erlang14/files/epmd.sh.in
+++ /dev/null
@@ -1,26 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# PROVIDE: epmd
-# REQUIRE: LOGIN
-#
-# Add the following line to /etc/rc.conf to enable epmd:
-#
-# epmd_enable="YES"
-#
-
-epmd_enable=${epmd_enable:-"NO"}
-
-. %%RC_SUBR%%
-
-name=epmd
-rcvar=`set_rcvar`
-
-prefix=%%PREFIX%%
-procname=${prefix}/bin/epmd
-start_cmd="${prefix}/bin/epmd -daemon"
-stop_cmd="${prefix}/bin/epmd -kill >/dev/null"
-
-load_rc_config ${name}
-run_rc_command "$1"
diff --git a/lang/erlang14/files/patch-aj b/lang/erlang14/files/patch-aj
deleted file mode 100644
index c3b2f87f73c6..000000000000
--- a/lang/erlang14/files/patch-aj
+++ /dev/null
@@ -1,11 +0,0 @@
-
-$FreeBSD$
-
---- erts/etc/unix/Install.src.orig Thu Oct 7 15:45:43 2004
-+++ erts/etc/unix/Install.src Thu Oct 7 15:45:59 2004
-@@ -157,4 +157,4 @@
- ./misc/format_man_pages $ERL_ROOT
- fi
-
--
-+exit 0
diff --git a/lang/erlang14/files/patch-erts-emulator-Makefile.in b/lang/erlang14/files/patch-erts-emulator-Makefile.in
deleted file mode 100644
index 20d61548c764..000000000000
--- a/lang/erlang14/files/patch-erts-emulator-Makefile.in
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- erts/emulator/Makefile.in.orig
-+++ erts/emulator/Makefile.in
-@@ -265,7 +265,9 @@
- endif
- WITH_SCTP=@WITH_SCTP@
- ifdef WITH_SCTP
-+ifneq ($(findstring freebsd,$(TARGET)),freebsd)
- LIBS += -lsctp
-+endif
- endif
-
- ORG_THR_LIBS=@EMU_THR_LIBS@
diff --git a/lang/erlang14/files/patch-erts-emulator-drivers-common-inet_drv.c b/lang/erlang14/files/patch-erts-emulator-drivers-common-inet_drv.c
deleted file mode 100644
index f7d48c82139c..000000000000
--- a/lang/erlang14/files/patch-erts-emulator-drivers-common-inet_drv.c
+++ /dev/null
@@ -1,29 +0,0 @@
-
-$FreeBSD$
-
---- erts/emulator/drivers/common/inet_drv.c.orig
-+++ erts/emulator/drivers/common/inet_drv.c
-@@ -5684,7 +5684,11 @@
- arg.es.sctp_peer_error_event = get_int8(curr); curr++;
- arg.es.sctp_shutdown_event = get_int8(curr); curr++;
- arg.es.sctp_partial_delivery_event = get_int8(curr); curr++;
-+# ifdef HAVE_STRUCT_SCTP_EVENT_SUBSCRIBE_SCTP_ADAPTATION_LAYER_EVENT
-+ arg.es.sctp_adaptation_layer_event = get_int8(curr); curr++;
-+# else
- arg.es.sctp_adaption_layer_event = get_int8(curr); curr++;
-+# endif
-
- proto = IPPROTO_SCTP;
- type = SCTP_EVENTS;
-@@ -6580,7 +6584,11 @@
- i = LOAD_BOOL (spec, i, evs.sctp_peer_error_event);
- i = LOAD_BOOL (spec, i, evs.sctp_shutdown_event);
- i = LOAD_BOOL (spec, i, evs.sctp_partial_delivery_event);
-+# ifdef HAVE_STRUCT_SCTP_EVENT_SUBSCRIBE_SCTP_ADAPTATION_LAYER_EVENT
-+ i = LOAD_BOOL (spec, i, evs.sctp_adaptation_layer_event);
-+# else
- i = LOAD_BOOL (spec, i, evs.sctp_adaption_layer_event);
-+# endif
- /* NB: sctp_authentication_event is not yet supported in Linux */
- i = LOAD_TUPLE (spec, i, 9);
- i = LOAD_TUPLE (spec, i, 2);
diff --git a/lang/erlang14/files/patch-erts_config.h.in b/lang/erlang14/files/patch-erts_config.h.in
deleted file mode 100644
index 0cb9747c20e1..000000000000
--- a/lang/erlang14/files/patch-erts_config.h.in
+++ /dev/null
@@ -1,17 +0,0 @@
-
-$FreeBSD$
-
---- erts/config.h.in.orig
-+++ erts/config.h.in
-@@ -366,6 +366,10 @@
- /* Define to 1 if `ssh_data' is member of `struct sctp_send_failed'. */
- #undef HAVE_STRUCT_SCTP_SEND_FAILED_SSH_DATA
-
-+/* Define to 1 if `sctp_adaptation_layer_event' is member of
-+ `struct sctp_event_subscribe'. */
-+#undef HAVE_STRUCT_SCTP_EVENT_SUBSCRIBE_SCTP_ADAPTATION_LAYER_EVENT
-+
- /* Define to 1 if you have the <syslog.h> header file. */
- #undef HAVE_SYSLOG_H
-
-
diff --git a/lang/erlang14/files/patch-erts_configure b/lang/erlang14/files/patch-erts_configure
deleted file mode 100644
index a2756de41f1b..000000000000
--- a/lang/erlang14/files/patch-erts_configure
+++ /dev/null
@@ -1,149 +0,0 @@
-
-$FreeBSD$
-
---- erts/configure.orig
-+++ erts/configure
-@@ -11040,6 +11040,125 @@
-
-
- fi
-+echo "$as_me:$LINENO: checking for struct sctp_event_subscribe.sctp_adaptation_layer_event" >&5
-+echo $ECHO_N "checking for struct sctp_event_subscribe.sctp_adaptation_layer_event... $ECHO_C" >&6
-+if test "${ac_cv_member_struct_sctp_event_subscribe_sctp_adaptation_layer_event+set}" = set; then
-+ echo $ECHO_N "(cached) $ECHO_C" >&6
-+else
-+ cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+#if HAVE_SYS_SOCKET_H
-+ #include <sys/socket.h>
-+ #endif
-+ #include <netinet/sctp.h>
-+
-+
-+int
-+main ()
-+{
-+static struct sctp_event_subscribe ac_aggr;
-+if (ac_aggr.sctp_adaptation_layer_event)
-+return 0;
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext
-+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-+ (eval $ac_compile) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest.$ac_objext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ ac_cv_member_struct_sctp_event_subscribe_sctp_adaptation_layer_event=yes
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+cat >conftest.$ac_ext <<_ACEOF
-+/* confdefs.h. */
-+_ACEOF
-+cat confdefs.h >>conftest.$ac_ext
-+cat >>conftest.$ac_ext <<_ACEOF
-+/* end confdefs.h. */
-+#if HAVE_SYS_SOCKET_H
-+ #include <sys/socket.h>
-+ #endif
-+ #include <netinet/sctp.h>
-+
-+
-+int
-+main ()
-+{
-+static struct sctp_event_subscribe ac_aggr;
-+if (sizeof ac_aggr.sctp_adaptation_layer_event)
-+return 0;
-+ ;
-+ return 0;
-+}
-+_ACEOF
-+rm -f conftest.$ac_objext
-+if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
-+ (eval $ac_compile) 2>conftest.er1
-+ ac_status=$?
-+ grep -v '^ *+' conftest.er1 >conftest.err
-+ rm -f conftest.er1
-+ cat conftest.err >&5
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); } &&
-+ { ac_try='test -z "$ac_c_werror_flag"
-+ || test ! -s conftest.err'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; } &&
-+ { ac_try='test -s conftest.$ac_objext'
-+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
-+ (eval $ac_try) 2>&5
-+ ac_status=$?
-+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
-+ (exit $ac_status); }; }; then
-+ ac_cv_member_struct_sctp_event_subscribe_sctp_adaptation_layer_event=yes
-+else
-+ echo "$as_me: failed program was:" >&5
-+sed 's/^/| /' conftest.$ac_ext >&5
-+
-+ac_cv_member_struct_sctp_event_subscribe_sctp_adaptation_layer_event=no
-+fi
-+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
-+fi
-+rm -f conftest.err conftest.$ac_objext conftest.$ac_ext
-+fi
-+echo "$as_me:$LINENO: result: $ac_cv_member_struct_sctp_event_subscribe_sctp_adaptation_layer_event" >&5
-+echo "${ECHO_T}$ac_cv_member_struct_sctp_event_subscribe_sctp_adaptation_layer_event" >&6
-+if test $ac_cv_member_struct_sctp_event_subscribe_sctp_adaptation_layer_event = yes; then
-+
-+cat >>confdefs.h <<_ACEOF
-+#define HAVE_STRUCT_SCTP_EVENT_SUBSCRIBE_SCTP_ADAPTATION_LAYER_EVENT 1
-+_ACEOF
-+
-+
-+fi
-
- fi
-
-@@ -19219,7 +19338,7 @@
- DED_LD_FLAG_RUNTIME_LIBRARY_PATH=
- STATIC_CFLAGS="-mdynamic-no-pic"
- ;;
-- linux*)
-+ linux*|freebsd*)
- DED_LD="$CC"
- DED_LDFLAGS="-shared"
- ;;
-@@ -19530,7 +19649,7 @@
- /bin/rm -f $ERL_TOP/lib/$a/SKIP
- done
-
--SSL_DYNAMIC_ONLY=no
-+SSL_DYNAMIC_ONLY=yes
-
- if test "x$with_ssl" = "xno"; then
- SSL_APP=
diff --git a/lang/erlang14/files/patch-erts_emulator_beam_erl__process__dump.c b/lang/erlang14/files/patch-erts_emulator_beam_erl__process__dump.c
deleted file mode 100644
index cdccf8671ff6..000000000000
--- a/lang/erlang14/files/patch-erts_emulator_beam_erl__process__dump.c
+++ /dev/null
@@ -1,27 +0,0 @@
-
-$FreeBSD$
-
---- erts/emulator/beam/erl_process_dump.c.orig
-+++ erts/emulator/beam/erl_process_dump.c
-@@ -399,9 +399,11 @@
- static void
- dump_externally(int to, void *to_arg, Eterm term)
- {
-- byte sbuf[1024]; /* encode and hope for the best ... */
-- byte* s;
-- byte* p;
-+ byte *sbuf, *s, *p;
-+ unsigned size;
-+
-+ size = encode_size_struct(term, TERM_TO_BINARY_DFLAGS);
-+ sbuf = (byte *) erts_alloc(ERTS_ALC_T_TMP, size);
-
- s = p = sbuf;
- erts_to_external_format(NULL, term, &p, NULL, NULL);
-@@ -409,4 +411,6 @@
- while (s < p) {
- erts_print(to, to_arg, "%02X", *s++);
- }
-+
-+ erts_free(ERTS_ALC_T_TMP, (void *) sbuf);
- }
diff --git a/lang/erlang14/files/patch-erts_emulator_hipe_hipe__x86.c b/lang/erlang14/files/patch-erts_emulator_hipe_hipe__x86.c
deleted file mode 100644
index b7086a076357..000000000000
--- a/lang/erlang14/files/patch-erts_emulator_hipe_hipe__x86.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- erts/emulator/hipe/hipe_x86.c.orig
-+++ erts/emulator/hipe/hipe_x86.c
-@@ -106,7 +106,7 @@
- abort();
- map_start = mmap(map_hint, map_bytes,
- PROT_EXEC|PROT_READ|PROT_WRITE,
-- MAP_PRIVATE|MAP_ANONYMOUS
-+ MAP_PRIVATE|MAP_ANON
- #ifdef __x86_64__
- |MAP_32BIT
- #endif
diff --git a/lang/erlang14/files/patch-lib_asn1_c__src_Makefile.in b/lang/erlang14/files/patch-lib_asn1_c__src_Makefile.in
deleted file mode 100644
index 7ae33c2bc61d..000000000000
--- a/lang/erlang14/files/patch-lib_asn1_c__src_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- lib/asn1/c_src/Makefile.in.orig Sun Aug 31 14:45:35 2003
-+++ lib/asn1/c_src/Makefile.in Sun Aug 31 14:45:42 2003
-@@ -131,7 +131,7 @@
- $(CC) -c $(CFLAGS) -o $(OBJ_FILES) $(C_FILES)
-
- $(SHARED_OBJ_FILES): $(OBJ_FILES) $(LIBDIR)
-- $(LD) $(LDFLAGS) $(LD_INCL_EI) -o $(SHARED_OBJ_FILES) $(OBJ_FILES) $(LD_EI) $(CLIB_FLAGS) $(LIBS)
-+ $(LD) $(LDFLAGS) $(LD_INCL_EI) -o $(SHARED_OBJ_FILES) $(OBJ_FILES) $(LD_EI)
-
- $(LIBDIR):
- -mkdir -p $(LIBDIR)
diff --git a/lang/erlang14/files/patch-lib_crypto_c__src_Makefile.in b/lang/erlang14/files/patch-lib_crypto_c__src_Makefile.in
deleted file mode 100644
index 81e0ce9e83b3..000000000000
--- a/lang/erlang14/files/patch-lib_crypto_c__src_Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- lib/crypto/c_src/Makefile.in.orig Thu Oct 7 12:11:06 2004
-+++ lib/crypto/c_src/Makefile.in Thu Oct 7 12:11:07 2004
-@@ -121,7 +121,7 @@
- release_spec: opt
- $(INSTALL_DIR) $(RELSYSDIR)/priv/obj
- $(INSTALL_DIR) $(RELSYSDIR)/priv/lib
-- $(INSTALL_PROGRAM) $(DRV_MAKEFILE) $(RELSYSDIR)/priv/obj
-+ $(INSTALL_DATA) $(DRV_MAKEFILE) $(RELSYSDIR)/priv/obj
- $(INSTALL_PROGRAM) $(OBJS) $(RELSYSDIR)/priv/obj
- $(INSTALL_PROGRAM) $(DYN_DRIVER) $(RELSYSDIR)/priv/lib
-
diff --git a/lang/erlang14/files/patch-lib_dialyzer_src_Makefile b/lang/erlang14/files/patch-lib_dialyzer_src_Makefile
deleted file mode 100644
index de6ac4c165d6..000000000000
--- a/lang/erlang14/files/patch-lib_dialyzer_src_Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-
-$FreeBSD$
-
---- lib/dialyzer/src/Makefile.orig
-+++ lib/dialyzer/src/Makefile
-@@ -66,8 +66,6 @@
- dialyzer_succ_typings \
- dialyzer_typesig
-
--EXTRA_FILES= ../plt/dialyzer_init_plt ## automatically generated
--
- HRL_FILES= dialyzer.hrl
- ERL_FILES= $(MODULES:%=%.erl)
- INSTALL_FILES= $(MODULES:%=$(EBIN)/%.$(EMULATOR)) $(APP_TARGET) $(APPUP_TARGET)
-@@ -91,13 +89,12 @@
- # Targets
- # ----------------------------------------------------
-
--debug opt: $(TARGET_FILES) $(DIALYZER_DIR)/plt/dialyzer_init_plt
-+debug opt: $(TARGET_FILES)
-
- docs:
-
- clean:
- rm -f $(TARGET_FILES)
-- rm -f $(EXTRA_FILES)
- rm -f core
-
- # ----------------------------------------------------
-@@ -149,11 +146,10 @@
-
- release_spec: opt
- $(INSTALL_DIR) $(RELSYSDIR)/src
-- $(INSTALL_DATA) $(ERL_FILES) $(HRL_FILES) $(EXTRA_FILES) \
-+ $(INSTALL_DATA) $(ERL_FILES) $(HRL_FILES) \
- $(RELSYSDIR)/src
- $(INSTALL_DIR) $(RELSYSDIR)/ebin
- $(INSTALL_DATA) $(INSTALL_FILES) $(RELSYSDIR)/ebin
- $(INSTALL_DIR) $(RELSYSDIR)/plt
-- $(INSTALL_DATA) ../plt/dialyzer_init_plt $(RELSYSDIR)/plt
-
- release_docs_spec:
diff --git a/lang/erlang14/files/patch-lib_dialyzer_src_dialyzer__cl.erl b/lang/erlang14/files/patch-lib_dialyzer_src_dialyzer__cl.erl
deleted file mode 100644
index 4c2e014af58e..000000000000
--- a/lang/erlang14/files/patch-lib_dialyzer_src_dialyzer__cl.erl
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- lib/dialyzer/src/dialyzer_cl.erl.orig
-+++ lib/dialyzer/src/dialyzer_cl.erl
-@@ -93,7 +93,7 @@
- check_if_installed() ->
- case filename:basename(code:lib_dir(dialyzer)) of
- "dialyzer" -> false;
-- "dialyzer-" ++ _Version -> true
-+ "dialyzer-" ++ _Version -> false
- end.
-
- create_init_plt(MD5, Libs, InitPlt, IncludeDirs) ->
diff --git a/lang/erlang14/files/patch-lib_dialyzer_src_dialyzer__cl__parse.erl b/lang/erlang14/files/patch-lib_dialyzer_src_dialyzer__cl__parse.erl
deleted file mode 100644
index a02691d2d845..000000000000
--- a/lang/erlang14/files/patch-lib_dialyzer_src_dialyzer__cl__parse.erl
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- lib/dialyzer/src/dialyzer_cl_parse.erl.orig
-+++ lib/dialyzer/src/dialyzer_cl_parse.erl
-@@ -159,7 +159,7 @@
- throw({dialyzer_cl_parse_error, Msg}).
-
- init() ->
-- InitPlt = filename:join([code:lib_dir(dialyzer), "plt","dialyzer_init_plt"]),
-+ InitPlt = filename:join([os:getenv ("HOME"), ".dialyzer_init_plt"]),
- put(dialyzer_init_plt, InitPlt),
- put(dialyzer_only_check_init_plt, false),
- put(dialyzer_options_gui, true),
diff --git a/lang/erlang14/files/patch-lib_erl__interface_src_connect_ei__resolve.c b/lang/erlang14/files/patch-lib_erl__interface_src_connect_ei__resolve.c
deleted file mode 100644
index d8454c710f69..000000000000
--- a/lang/erlang14/files/patch-lib_erl__interface_src_connect_ei__resolve.c
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- lib/erl_interface/src/connect/ei_resolve.c.orig
-+++ lib/erl_interface/src/connect/ei_resolve.c
-@@ -621,7 +621,8 @@
-
- return result;
- #else
-- return gethostbyname_r(name,hostp,buffer,buflen,h_errnop);
-+ struct hostent *dummy;
-+ return gethostbyname_r(name,hostp,buffer,buflen,&dummy,h_errnop);
- #endif
- #endif
- #endif
diff --git a/lang/erlang14/files/patch-lib_et_src_et__contents__viewer.erl b/lang/erlang14/files/patch-lib_et_src_et__contents__viewer.erl
deleted file mode 100644
index 683358dbf6da..000000000000
--- a/lang/erlang14/files/patch-lib_et_src_et__contents__viewer.erl
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- lib/et/src/et_contents_viewer.erl.orig Sat Jul 24 15:04:01 2004
-+++ lib/et/src/et_contents_viewer.erl Sat Jul 24 15:04:31 2004
-@@ -346,7 +346,6 @@
- 'Caps_Lock' ->
- {noreply, S};
- _ ->
-- io:format("~p: ignored: ~p~n", [?MODULE, KeySym]),
- {noreply, S}
- end;
- handle_info({gs, _Obj, configure, [], [W, H | _]}, S) ->
diff --git a/lang/erlang14/files/patch-lib_et_src_et__viewer.erl b/lang/erlang14/files/patch-lib_et_src_et__viewer.erl
deleted file mode 100644
index 8cc3212e49e2..000000000000
--- a/lang/erlang14/files/patch-lib_et_src_et__viewer.erl
+++ /dev/null
@@ -1,15 +0,0 @@
-
-$FreeBSD$
-
---- lib/et/src/et_viewer.erl.orig Sat Jul 24 15:02:18 2004
-+++ lib/et/src/et_viewer.erl Sat Jul 24 15:04:38 2004
-@@ -982,8 +982,7 @@
- noreply(S).
-
- click_error(Click, S) ->
-- gs:config(S#state.canvas, beep),
-- io:format("~p: ignored: ~p~n", [?MODULE, Click]).
-+ gs:config(S#state.canvas, beep).
-
- %%%----------------------------------------------------------------------
- %%% Clone viewer
diff --git a/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl b/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl
deleted file mode 100644
index ddc1ecb98b12..000000000000
--- a/lang/erlang14/files/patch-lib_gs_src_tool__utils.erl
+++ /dev/null
@@ -1,87 +0,0 @@
-
-$FreeBSD$
-
---- lib/gs/src/tool_utils.erl.orig
-+++ lib/gs/src/tool_utils.erl
-@@ -27,6 +27,9 @@
- -export([file_dialog/1]).
- -export([notify/2, confirm/2, confirm_yesno/2, request/2]).
-
-+%% Browser executable list (openURL command line protocol required)
-+-define(BROWSERS, ["netscape", "mozilla", "MozillaFirebird", "opera"]).
-+
- %%----------------------------------------------------------------------
- %% open_help(GS, File)
- %% GS = gsobj() (GS root object returned by gs:start/0,1)
-@@ -67,7 +70,7 @@
- {unix,Type} ->
- case Type of
- darwin -> "open " ++ File;
-- _Else -> "netscape -remote \"openURL(file:" ++ File ++ ")\""
-+ _Else -> unix_url_command("file:" ++ File)
- end;
- {win32,_AnyType} ->
- "start " ++ filename:nativename(File);
-@@ -82,7 +85,7 @@
- {unix,Type} ->
- case Type of
- darwin -> "open " ++ File;
-- _Else -> "netscape -remote \"openURL(file:" ++ File ++ ")\""
-+ _Else -> unix_url_command("file:" ++ File)
- end;
- {win32,_AnyType} ->
- "netscape.exe -h " ++ regexp:gsub(File,"\\\\","/");
-@@ -342,3 +345,53 @@
- [Last];
- insert_newlines(Other) ->
- Other.
-+
-+%% find_browser(BrowserList) => string() | false
-+%% BrowserList - [string()]
-+%% Given a list of basenames, find the first available executable.
-+
-+find_browser([]) ->
-+ false;
-+
-+find_browser([H | T]) ->
-+ case os:find_executable(H) of
-+ false ->
-+ find_browser(T);
-+ Browser ->
-+ Browser
-+ end.
-+
-+%% unix_url_command(URL) => string()
-+%% URL - string()
-+%% Open an URL, using a browser which supports the openURL command
-+%% line protocol. If no browser is found, the empty string will be
-+%% returned.
-+
-+unix_url_command(URL) ->
-+ Template = "BROWSER -remote \"openURL(" ++ URL ++ ")\" || BROWSER " ++ URL ++ "&",
-+
-+ case os:getenv("BROWSER") of
-+ false ->
-+ %% look for a compatible browser
-+ case find_browser(?BROWSERS) of
-+ false ->
-+ "";
-+ Browser ->
-+ case regexp:gsub(Template, "BROWSER", Browser) of
-+ {ok, Command, 0} ->
-+ %% Template does not contain "BROWSER" placeholder
-+ "";
-+ {ok, Command, _} ->
-+ Command
-+ end
-+ end;
-+
-+ Value ->
-+ case regexp:gsub(Template, "BROWSER", Value) of
-+ {ok, Command2, 0} ->
-+ %% no placeholder
-+ "";
-+ {ok, Command2, _} ->
-+ Command2
-+ end
-+ end.
diff --git a/lang/erlang14/files/patch-lib_odbc_c_src_odbcserver.c b/lang/erlang14/files/patch-lib_odbc_c_src_odbcserver.c
deleted file mode 100644
index 985785bd8e26..000000000000
--- a/lang/erlang14/files/patch-lib_odbc_c_src_odbcserver.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/odbc/c_src/odbcserver.c.orig Sat Jun 25 17:34:20 2005
-+++ lib/odbc/c_src/odbcserver.c Sat Jun 25 17:34:33 2005
-@@ -107,6 +107,7 @@
- #include <sys/socket.h>
- #include <sys/uio.h>
- #include <netdb.h>
-+#include <netinet/in.h>
- #endif
-
- #include "ei.h"
diff --git a/lang/erlang14/files/patch-lib_sasl_src_rb.erl b/lang/erlang14/files/patch-lib_sasl_src_rb.erl
deleted file mode 100644
index 79b3961b0f00..000000000000
--- a/lang/erlang14/files/patch-lib_sasl_src_rb.erl
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- lib/sasl/src/rb.erl.orig
-+++ lib/sasl/src/rb.erl
-@@ -414,7 +414,7 @@
- Ref = make_ref(),
- case (catch {Ref,binary_to_term(Bin)}) of
- {'EXIT',_} ->
-- {error, "Inclomplete erlang term in log"};
-+ {error, "Incomplete erlang term in log"};
- {Ref,Term} ->
- {ok, Term}
- end
diff --git a/lang/erlang14/files/patch-lib_snmp_src_misc_snmp__config.erl b/lang/erlang14/files/patch-lib_snmp_src_misc_snmp__config.erl
deleted file mode 100644
index 732aef70634f..000000000000
--- a/lang/erlang14/files/patch-lib_snmp_src_misc_snmp__config.erl
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- lib/snmp/src/misc/snmp_config.erl.orig
-+++ lib/snmp/src/misc/snmp_config.erl
-@@ -1722,7 +1722,7 @@
- "%% {\"standard inform\", \"std_inform\", inform}.\n"
- "%%\n\n",
- Hdr = header() ++ Comment,
-- Conf = [{"stadard_trap", "std_trap", NotifyType}],
-+ Conf = [{"standard trap", "std_trap", NotifyType}],
- write_agent_notify_config(Dir, Hdr, Conf).
-
- write_agent_notify_config(Dir, Hdr, Conf)
diff --git a/lang/erlang14/files/patch-lib_stdlib_src_io__lib__pretty.erl b/lang/erlang14/files/patch-lib_stdlib_src_io__lib__pretty.erl
deleted file mode 100644
index 0f3305e2fd57..000000000000
--- a/lang/erlang14/files/patch-lib_stdlib_src_io__lib__pretty.erl
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- lib/stdlib/src/io_lib_pretty.erl.orig
-+++ lib/stdlib/src/io_lib_pretty.erl
-@@ -159,7 +159,9 @@
- %% Reuse the list created by io_lib:write_binary()...
- pp_binary([LT,LT,S,GT,GT], Col, Ll, Ind, LD) ->
- N = max(8, Ll - Col - LD),
-- [LT,LT,pp_binary(S, N, N, Ind),GT,GT].
-+ [LT,LT,pp_binary(S, N, N, Ind),GT,GT];
-+pp_binary(S, _Col, _Ll, _Ind, _LD) ->
-+ S.
-
- pp_binary([BS, $, | S], N, N0, Ind) ->
- Len = length(BS) + 1,
diff --git a/lang/erlang14/files/patch-lib_typer_src_typer__info.erl b/lang/erlang14/files/patch-lib_typer_src_typer__info.erl
deleted file mode 100644
index 953e440d5980..000000000000
--- a/lang/erlang14/files/patch-lib_typer_src_typer__info.erl
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- lib/typer/src/typer_info.erl.orig
-+++ lib/typer/src/typer_info.erl
-@@ -123,6 +123,5 @@
- dialyzerObj=NewDialyzerObj}.
-
- get_dialyzer_plt() ->
-- DialyzerDir = code:lib_dir(dialyzer),
-- Dialyzer_Init_Plt = filename:join([DialyzerDir,"plt","dialyzer_init_plt"]),
-+ Dialyzer_Init_Plt = filename:join([os:getenv ("HOME"), ".dialyzer_init_plt"]),
- dialyzer_plt:from_file(typer_plt, Dialyzer_Init_Plt).
diff --git a/lang/erlang14/files/pkg-message.in b/lang/erlang14/files/pkg-message.in
deleted file mode 100644
index 1b8961341722..000000000000
--- a/lang/erlang14/files/pkg-message.in
+++ /dev/null
@@ -1,15 +0,0 @@
-===========================================================================
-This package requires a properly configured nsswitch.conf on FreeBSD
-5.x, else nameserver queries (and the distribution protocol) will
-not work.
-
-Installation tips:
-
-You can find an emacs mode for Erlang here:
-
- %%LOCALBASE%%/lib/erlang/lib/tools-%%TOOLS_VSN%%/emacs
-
-You may wish to add the following line to /etc/manpath.config:
-
-OPTIONAL_MANPATH %%LOCALBASE%%/lib/erlang/man
-===========================================================================