aboutsummaryrefslogtreecommitdiff
path: root/lang/ghc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ghc/Makefile')
-rw-r--r--lang/ghc/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index d230579297d5..7a42d5888840 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -13,7 +13,7 @@ WWW= https://www.haskell.org/ghc/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-ONLY_FOR_ARCHS= aarch64 amd64 armv6 armv7 i386
+ONLY_FOR_ARCHS= aarch64 amd64 i386
USES= autoreconf compiler:c11 gmake \
ncurses perl5 python:build shebangfix \
@@ -203,15 +203,6 @@ post-patch:
${PATCHDIR}/UserSettings.hs > ${WRKSRC}/hadrian/src/UserSettings.hs
.endif
-.if ${BOOT_GHC_VERSION:C/\..*//g} < 9
-# TODO: remove this after rerolling all bootstraps
-post-patch-BOOT-off:
- @${REINPLACE_CMD} -e '/^mandir/d' ${BOOT_DIR}/mk/build.mk
- @${REINPLACE_CMD} -e '/^infodir/d' ${BOOT_DIR}/mk/build.mk
- @${REINPLACE_CMD} -e '/^docdir/d' ${BOOT_DIR}/mk/build.mk
- @${REINPLACE_CMD} -e '/^htmldir/d' ${BOOT_DIR}/mk/build.mk
-.endif
-
pre-configure:
# Call the bootstrap script
cd ${WRKSRC}/ && ${BOOT_SCRIPT}