aboutsummaryrefslogtreecommitdiff
path: root/lang/julia/files
diff options
context:
space:
mode:
Diffstat (limited to 'lang/julia/files')
-rw-r--r--lang/julia/files/check_openblas.c10
-rw-r--r--lang/julia/files/patch-Make.inc31
-rw-r--r--lang/julia/files/patch-Makefile63
-rw-r--r--lang/julia/files/patch-stdlib_LibGit2__jll_src_LibGit2__jll.jl11
-rw-r--r--lang/julia/files/patch-stdlib_LibGit2_src_types.jl12
-rw-r--r--lang/julia/files/patch-stdlib_MbedTLS__jll_src_MbedTLS__jll.jl15
-rw-r--r--lang/julia/files/patch-stdlib_OpenLibm__jll_src_OpenLibm__jll.jl11
7 files changed, 153 insertions, 0 deletions
diff --git a/lang/julia/files/check_openblas.c b/lang/julia/files/check_openblas.c
new file mode 100644
index 000000000000..6218d3507c65
--- /dev/null
+++ b/lang/julia/files/check_openblas.c
@@ -0,0 +1,10 @@
+#include <string.h>
+
+char* openblas_get_config(void);
+
+int main()
+{
+ if (strstr(openblas_get_config(), "USE64BITINT") == NULL)
+ return 1;
+ return 0;
+}
diff --git a/lang/julia/files/patch-Make.inc b/lang/julia/files/patch-Make.inc
new file mode 100644
index 000000000000..9eee322adcb4
--- /dev/null
+++ b/lang/julia/files/patch-Make.inc
@@ -0,0 +1,31 @@
+--- Make.inc.orig 2021-12-23 01:12:50 UTC
++++ Make.inc
+@@ -243,7 +243,7 @@ libdir := $(prefix)/$(framework_currver)
+ libexecdir := $(prefix)/$(framework_helpers)
+ datarootdir := $(prefix)/$(framework_resources)
+ docdir := $(prefix)/$(framework_documentation)
+-mandir := $(datarootdir)/man
++mandir := $(prefix)/man
+ man1dir := $(mandir)/man1
+ includedir := $(prefix)/$(framework_headers)
+ sysconfdir := $(prefix)/$(framework_resources)
+@@ -271,7 +271,7 @@ build_depsbindir := $(build_prefix)/tools
+ build_libdir := $(build_prefix)/lib
+ build_libexecdir := $(build_prefix)/libexec
+ build_datarootdir := $(build_prefix)/share
+-build_mandir := $(build_datarootdir)/man
++build_mandir := $(build_prefix)/man
+ build_man1dir := $(build_mandir)/man1
+ build_includedir := $(build_prefix)/include
+ build_sysconfdir := $(build_prefix)/etc
+@@ -510,8 +510,8 @@ SHIPFLAGS := -O3 -ggdb2 -falign-functions
+ endif
+
+ ifeq ($(USECLANG),1)
+-CC := $(CROSS_COMPILE)clang
+-CXX := $(CROSS_COMPILE)clang++
++CC ?= $(CROSS_COMPILE)clang
++CXX ?= $(CROSS_COMPILE)clang++
+ JCFLAGS := -std=gnu99 -pipe $(fPIC) -fno-strict-aliasing -D_FILE_OFFSET_BITS=64
+ # AArch64 needs this flag to generate the .eh_frame used by libunwind
+ JCPPFLAGS := -fasynchronous-unwind-tables
diff --git a/lang/julia/files/patch-Makefile b/lang/julia/files/patch-Makefile
new file mode 100644
index 000000000000..1248a6e671cf
--- /dev/null
+++ b/lang/julia/files/patch-Makefile
@@ -0,0 +1,63 @@
+--- Makefile.orig 2021-11-30 12:13:06 UTC
++++ Makefile
+@@ -226,7 +226,7 @@ define stringreplace
+ endef
+
+
+-install: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html
++install: $(build_depsbindir)/stringreplace
+ ifeq ($(BUNDLE_DEBUG_LIBS),1)
+ @$(MAKE) $(QUIET_MAKE) all
+ else
+@@ -314,8 +314,6 @@ endif
+ cp -R -L $(JULIAHOME)/base/* $(DESTDIR)$(datarootdir)/julia/base
+ cp -R -L $(JULIAHOME)/test/* $(DESTDIR)$(datarootdir)/julia/test
+ cp -R -L $(build_datarootdir)/julia/* $(DESTDIR)$(datarootdir)/julia
+- # Copy documentation
+- cp -R -L $(BUILDROOT)/doc/_build/html $(DESTDIR)$(docdir)/
+ # Remove various files which should not be installed
+ -rm -f $(DESTDIR)$(datarootdir)/julia/base/version_git.sh
+ -rm -f $(DESTDIR)$(datarootdir)/julia/test/Makefile
+@@ -325,12 +323,6 @@ endif
+ -rm -f $(DESTDIR)$(datarootdir)/julia/stdlib/$(VERSDIR)/*/build-checked
+ # Copy in beautiful new man page
+ $(INSTALL_F) $(build_man1dir)/julia.1 $(DESTDIR)$(man1dir)/
+- # Copy .desktop file
+- mkdir -p $(DESTDIR)$(datarootdir)/applications/
+- $(INSTALL_F) $(JULIAHOME)/contrib/julia.desktop $(DESTDIR)$(datarootdir)/applications/
+- # Install appdata file
+- mkdir -p $(DESTDIR)$(datarootdir)/appdata/
+- $(INSTALL_F) $(JULIAHOME)/contrib/julia.appdata.xml $(DESTDIR)$(datarootdir)/appdata/
+
+ # Update RPATH entries and JL_SYSTEM_IMAGE_PATH if $(private_libdir_rel) != $(build_private_libdir_rel)
+ ifneq ($(private_libdir_rel),$(build_private_libdir_rel))
+@@ -384,26 +376,15 @@ ifeq ($(BUNDLE_DEBUG_LIBS),1)
+ endif
+ endif
+
+- # On FreeBSD, remove the build's libdir from each library's RPATH
+-ifeq ($(OS),FreeBSD)
+- $(JULIAHOME)/contrib/fixup-rpath.sh "$(PATCHELF)" $(DESTDIR)$(libdir) $(build_libdir)
+- $(JULIAHOME)/contrib/fixup-rpath.sh "$(PATCHELF)" $(DESTDIR)$(private_libdir) $(build_libdir)
+- $(JULIAHOME)/contrib/fixup-rpath.sh "$(PATCHELF)" $(DESTDIR)$(bindir) $(build_libdir)
+- # Set libgfortran's RPATH to ORIGIN instead of GCCPATH. It's only libgfortran that
+- # needs to be fixed here, as libgcc_s and libquadmath don't have RPATHs set. If we
+- # don't set libgfortran's RPATH, it won't be able to find its friends on systems
+- # that don't have the exact GCC port installed used for the build.
+- for lib in $(DESTDIR)$(private_libdir)/libgfortran*$(SHLIB_EXT)*; do \
+- $(PATCHELF) --set-rpath '$$ORIGIN' $$lib; \
+- done
+-endif
+-
+ mkdir -p $(DESTDIR)$(sysconfdir)
+ cp -R $(build_sysconfdir)/julia $(DESTDIR)$(sysconfdir)/
+
+ ifeq ($(DARWIN_FRAMEWORK),1)
+ $(MAKE) -C $(JULIAHOME)/contrib/mac/framework frameworknoinstall
+ endif
++install-docs:
++ #Copy documentation
++ cp -R -L $(BUILDROOT)/doc/_build/html $(DESTDIR)$(docdir)/
+
+ distclean:
+ -rm -fr $(BUILDROOT)/julia-*.tar.gz $(BUILDROOT)/julia*.exe $(BUILDROOT)/julia-$(JULIA_COMMIT)
diff --git a/lang/julia/files/patch-stdlib_LibGit2__jll_src_LibGit2__jll.jl b/lang/julia/files/patch-stdlib_LibGit2__jll_src_LibGit2__jll.jl
new file mode 100644
index 000000000000..cb9e92662688
--- /dev/null
+++ b/lang/julia/files/patch-stdlib_LibGit2__jll_src_LibGit2__jll.jl
@@ -0,0 +1,11 @@
+--- stdlib/LibGit2_jll/src/LibGit2_jll.jl.orig 2021-12-15 04:07:07 UTC
++++ stdlib/LibGit2_jll/src/LibGit2_jll.jl
+@@ -23,7 +23,7 @@ if Sys.iswindows()
+ elseif Sys.isapple()
+ const libgit2 = "@rpath/libgit2.1.1.dylib"
+ else
+- const libgit2 = "libgit2.so.1.1"
++ const libgit2 = "libgit2.so.1"
+ end
+
+ function __init__()
diff --git a/lang/julia/files/patch-stdlib_LibGit2_src_types.jl b/lang/julia/files/patch-stdlib_LibGit2_src_types.jl
new file mode 100644
index 000000000000..46ff7104388e
--- /dev/null
+++ b/lang/julia/files/patch-stdlib_LibGit2_src_types.jl
@@ -0,0 +1,12 @@
+--- stdlib/LibGit2/src/types.jl.orig 2021-12-15 04:07:40 UTC
++++ stdlib/LibGit2/src/types.jl
+@@ -230,6 +230,9 @@ Matches the [`git_remote_callbacks`](https://libgit2.o
+ push_update_reference::Ptr{Cvoid} = C_NULL
+ push_negotiation::Ptr{Cvoid} = C_NULL
+ transport::Ptr{Cvoid} = C_NULL
++ @static if LibGit2.VERSION >= v"1.2.0"
++ remote_ready::Ptr{Cvoid} = C_NULL
++ end
+ payload::Any = nothing
+ @static if LibGit2.VERSION >= v"0.99.0"
+ resolve_url::Ptr{Cvoid} = C_NULL
diff --git a/lang/julia/files/patch-stdlib_MbedTLS__jll_src_MbedTLS__jll.jl b/lang/julia/files/patch-stdlib_MbedTLS__jll_src_MbedTLS__jll.jl
new file mode 100644
index 000000000000..70b82c6dd39a
--- /dev/null
+++ b/lang/julia/files/patch-stdlib_MbedTLS__jll_src_MbedTLS__jll.jl
@@ -0,0 +1,15 @@
+--- stdlib/MbedTLS_jll/src/MbedTLS_jll.jl.orig 2021-11-25 11:01:50 UTC
++++ stdlib/MbedTLS_jll/src/MbedTLS_jll.jl
+@@ -31,9 +31,9 @@ elseif Sys.isapple()
+ const libmbedtls = "@rpath/libmbedtls.13.dylib"
+ const libmbedx509 = "@rpath/libmbedx509.1.dylib"
+ else
+- const libmbedcrypto = "libmbedcrypto.so.5"
+- const libmbedtls = "libmbedtls.so.13"
+- const libmbedx509 = "libmbedx509.so.1"
++ const libmbedcrypto = "libmbedcrypto.so"
++ const libmbedtls = "libmbedtls.so"
++ const libmbedx509 = "libmbedx509.so"
+ end
+
+ function __init__()
diff --git a/lang/julia/files/patch-stdlib_OpenLibm__jll_src_OpenLibm__jll.jl b/lang/julia/files/patch-stdlib_OpenLibm__jll_src_OpenLibm__jll.jl
new file mode 100644
index 000000000000..ff13a5ea86d2
--- /dev/null
+++ b/lang/julia/files/patch-stdlib_OpenLibm__jll_src_OpenLibm__jll.jl
@@ -0,0 +1,11 @@
+--- stdlib/OpenLibm_jll/src/OpenLibm_jll.jl.orig 2021-11-25 11:01:50 UTC
++++ stdlib/OpenLibm_jll/src/OpenLibm_jll.jl
+@@ -22,7 +22,7 @@ if Sys.iswindows()
+ elseif Sys.isapple()
+ const libopenlibm = "@rpath/libopenlibm.3.dylib"
+ else
+- const libopenlibm = "libopenlibm.so.3"
++ const libopenlibm = "libopenlibm.so"
+ end
+
+ function __init__()