aboutsummaryrefslogtreecommitdiff
path: root/lang/p5-Try-Tiny-Retry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/p5-Try-Tiny-Retry/Makefile')
-rw-r--r--lang/p5-Try-Tiny-Retry/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/lang/p5-Try-Tiny-Retry/Makefile b/lang/p5-Try-Tiny-Retry/Makefile
new file mode 100644
index 000000000000..91083080eb43
--- /dev/null
+++ b/lang/p5-Try-Tiny-Retry/Makefile
@@ -0,0 +1,20 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Try-Tiny-Retry
+PORTVERSION= 0.004
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DAGOLDEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Extends Try::Tiny to allow retries
+
+BUILD_DEPENDS= p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>