aboutsummaryrefslogtreecommitdiff
path: root/lang/php53/Makefile.ext
diff options
context:
space:
mode:
Diffstat (limited to 'lang/php53/Makefile.ext')
-rw-r--r--lang/php53/Makefile.ext12
1 files changed, 8 insertions, 4 deletions
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index c59f4d3c035f..b5d56d805179 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -61,9 +61,6 @@ CONFIGURE_ARGS+=--enable-dom \
--with-libxml-dir=${LOCALBASE}
USE_GNOME= libxml2
-
-USE_PHP= simplexml
-USE_PHP_BUILD= yes
.endif
.if ${PHP_MODNAME} == "exif"
@@ -353,7 +350,7 @@ CONFIGURE_ARGS+=--with-xmlreader \
USE_GNOME= libxml2
-USE_PHP= xml
+USE_PHP= dom
USE_PHP_BUILD= yes
.endif
@@ -371,6 +368,13 @@ USE_PHP= xml
USE_PHP_BUILD= yes
.endif
+.if ${PHP_MODNAME} == "xmlwriter"
+CONFIGURE_ARGS+=--with-xmlwriter \
+ --with-libxml-dir=${LOCALBASE}
+
+USE_GNOME= libxml2
+.endif
+
.if ${PHP_MODNAME} == "xsl"
CONFIGURE_ARGS+=--with-xsl=${LOCALBASE}