aboutsummaryrefslogtreecommitdiff
path: root/lang/rexx-regutil
diff options
context:
space:
mode:
Diffstat (limited to 'lang/rexx-regutil')
-rw-r--r--lang/rexx-regutil/Makefile45
-rw-r--r--lang/rexx-regutil/distinfo2
-rw-r--r--lang/rexx-regutil/files/patch-Makefile.inc11
-rw-r--r--lang/rexx-regutil/files/pkg-message.in5
-rw-r--r--lang/rexx-regutil/files/regutil.1.in24
-rw-r--r--lang/rexx-regutil/pkg-descr9
-rw-r--r--lang/rexx-regutil/pkg-plist3
7 files changed, 99 insertions, 0 deletions
diff --git a/lang/rexx-regutil/Makefile b/lang/rexx-regutil/Makefile
new file mode 100644
index 000000000000..23f6a25b7c8b
--- /dev/null
+++ b/lang/rexx-regutil/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: rexx-regutil
+# Date created: 09 September 2010
+# Whom: Bob Eager <bob@eager.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= regutil
+PORTVERSION= 1.26
+CATEGORIES= lang
+MASTER_SITES= http://www.tavi.co.uk/distfiles/ http://pages.interlog.com/~pjtm/
+PKGNAMEPREFIX= rexx-
+DISTNAME= regutil126
+
+MAINTAINER= bob@eager.cx
+COMMENT= An implementation of IBM's RexxUtil function library for Regina
+
+BUILD_DEPENDS= ${LOCALBASE}/include/rexxsaa.h:${PORTSDIR}/lang/rexx-regina
+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_LDCONFIG= yes
+MAN1= regutil.1
+MLINKS= regutil.1 rexxutil.1
+MAKEFILE= Makefile.bsd
+
+SUB_FILES= regutil.1 pkg-message
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/librexxutil.so ${PREFIX}/lib
+ ${INSTALL_MAN} ${WRKDIR}/regutil.1 ${PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/regutil.pdf ${DOCSDIR}
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/rexx-regutil/distinfo b/lang/rexx-regutil/distinfo
new file mode 100644
index 000000000000..a081f099ce59
--- /dev/null
+++ b/lang/rexx-regutil/distinfo
@@ -0,0 +1,2 @@
+SHA256 (regutil126.zip) = 9f80ddfd681779f6b3d112df0343f1508bedde3ad5ce3a80f33343777a218109
+SIZE (regutil126.zip) = 250916
diff --git a/lang/rexx-regutil/files/patch-Makefile.inc b/lang/rexx-regutil/files/patch-Makefile.inc
new file mode 100644
index 000000000000..147ad6cf0d9d
--- /dev/null
+++ b/lang/rexx-regutil/files/patch-Makefile.inc
@@ -0,0 +1,11 @@
+--- Makefile.inc.orig 2010-08-30 23:27:33.000000000 +0100
++++ Makefile.inc 2010-08-30 23:27:53.000000000 +0100
+@@ -26,7 +26,7 @@
+ DEBUG=-g $(PDEBUG)
+ OPT=
+
+-REXX_INCLUDE=$(HOME)/regina
++REXX_INCLUDE=$(PREFIX)/include
+ CFLAGS=$(DEBUG) $(OPT) $(PCFLAGS) $(PCDEFS) -I $(REXX_INCLUDE)
+ LDFLAGS=$(PLDFLAGS)
+ LIBS=$(PLIBS)
diff --git a/lang/rexx-regutil/files/pkg-message.in b/lang/rexx-regutil/files/pkg-message.in
new file mode 100644
index 000000000000..7f368ec5195c
--- /dev/null
+++ b/lang/rexx-regutil/files/pkg-message.in
@@ -0,0 +1,5 @@
+================================================================================
+
+Documentation can be found in %%DOCSDIR%%/regutil.pdf
+
+================================================================================
diff --git a/lang/rexx-regutil/files/regutil.1.in b/lang/rexx-regutil/files/regutil.1.in
new file mode 100644
index 000000000000..40ae3dd95410
--- /dev/null
+++ b/lang/rexx-regutil/files/regutil.1.in
@@ -0,0 +1,24 @@
+.Dd September 3, 2010
+.Dt REGUTIL 1 CON
+.Os
+.Sh NAME
+.Nm regutil
+.Nd "RexxUtil library for Regina REXX interpreter"
+.Sh DESCRIPTION
+.Nm
+is a collection of utility functions for use with the Regina REXX interpreter.
+These closely mirror the functions contained in the
+.Em RexxUtil
+library provided
+on IBM systems (e.g. OS/2).
+.Pp
+Details of usage are in the full manual, which is normally found at:
+.br
+.Pa %%DOCSDIR%%/regutil.pdf
+.Sh SEE ALSO
+The original author's web site at
+.Em http://pages.interlog.com/~pjtm/
+.Sh AUTHORS
+.An "Patrick T J McPhee" (original author)
+.An "Bob Eager" Aq bob@eager.cx
+(port)
diff --git a/lang/rexx-regutil/pkg-descr b/lang/rexx-regutil/pkg-descr
new file mode 100644
index 000000000000..c2f9c9ca2e6d
--- /dev/null
+++ b/lang/rexx-regutil/pkg-descr
@@ -0,0 +1,9 @@
+RegUtil is an implementation of IBM's RexxUtil for Regina. According to
+the author, it is not complete; however, it implements a large number of
+the RexxUtil functions, and is very useful.
+
+Note that any scripts which load RegUtil must be run with the 'regina'
+command, rather than 'rexx'; the latter does not support the use of
+external function packages.
+
+WWW: http://pages.interlog.com/~pjtm/
diff --git a/lang/rexx-regutil/pkg-plist b/lang/rexx-regutil/pkg-plist
new file mode 100644
index 000000000000..3fb0154bcedd
--- /dev/null
+++ b/lang/rexx-regutil/pkg-plist
@@ -0,0 +1,3 @@
+lib/librexxutil.so
+%%PORTDOCS%%%%DOCSDIR%%/regutil.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%