aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby16/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/ruby16/Makefile')
-rw-r--r--lang/ruby16/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index d69dc5b26316..9efd00c39ddd 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -18,7 +18,8 @@ MAINTAINER= yasuf@bsdclub.org
USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-shared
-MAN1= ${RUBY_NAME}.1
+MAN1= ruby${_RUBY_SUFFIX}.1
+MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
@@ -32,7 +33,6 @@ XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
.if !empty(RUBY_SUFFIX)
CONFIGURE_ARGS+= --program-suffix="${RUBY_SUFFIX}"
-MLINKS= ${RUBY_NAME}.1 ruby.1
.endif
.if ${OSVERSION} >= 400014
@@ -46,7 +46,13 @@ post-patch:
post-install:
strip ${RUBY}
- ${LN} -fs ${RUBY} ${PREFIX}/ruby
+.if empty(RUBY_SUFFIX)
+ ${MV} ${RUBY} ${RUBY}${_RUBY_SUFFIX}
+ ${LN} -fs ${RUBY}${_RUBY_SUFFIX} ${RUBY}
+ ${MV} ${PREFIX}/man/man1/ruby.1 ${PREFIX}/man/man1/ruby${_RUBY_SUFFIX}.1
+.else
+ ${LN} -fs ${RUBY} ${PREFIX}/bin/ruby
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}