aboutsummaryrefslogtreecommitdiff
path: root/lang/rust/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/rust/Makefile')
-rw-r--r--lang/rust/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 0205fb9b8b00..0d49ff305759 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -177,6 +177,12 @@ do-configure:
.endif
@${REINPLACE_CMD} 's,%CC%,${CC},g' \
${WRKSRC}/src/bootstrap/native.rs
+# src/librustc_llvm has moved to compiler/rustc_llvm in nightly
+# this reinplace_cmd is used for ppc64-elfv1
+.if !defined(NIGHTLY_DATE)
+ @${REINPLACE_CMD} 's,%CC%,${CC},g' \
+ ${WRKSRC}/src/librustc_llvm/build.rs
+.endif
do-build:
@cd ${WRKSRC} && \