aboutsummaryrefslogtreecommitdiff
path: root/lang/seed7/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/seed7/Makefile')
-rw-r--r--lang/seed7/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
new file mode 100644
index 000000000000..0918ace01638
--- /dev/null
+++ b/lang/seed7/Makefile
@@ -0,0 +1,47 @@
+# New ports collection Makefile for: seed7
+# Date created: 16 July 2008
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= seed7
+DISTVERSION= 05_20080707
+CATEGORIES= lang
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A high-level, extensible programming language
+
+USE_GMAKE= yes
+USE_XORG= x11
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+MAKEFILE= makefile
+ALL_TARGET= hi
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/makefile
+
+do-configure:
+ (cd ${WRKSRC} && ${GMAKE} depend)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hi ${PREFIX}/bin
+ ${INSTALL} -d ${PREFIX}/lib/${PORTNAME}
+ (cd ${WRKSRC}/../lib && ${COPYTREE_SHARE} \* ${PREFIX}/lib/${PORTNAME})
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d ${DOCSDIR}
+ (cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${INSTALL} -d ${EXAMPLESDIR}
+ (cd ${WRKSRC}/../prg && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.mk>