aboutsummaryrefslogtreecommitdiff
path: root/mail/mailman/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/mailman/Makefile')
-rw-r--r--mail/mailman/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index d2f00201b5c1..575e9ffabcb7 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.29
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= GNU \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION} \
@@ -71,8 +71,8 @@ PORTDOCS= ACKNOWLEDGMENTS BUGS FAQ INSTALL NEWS README README-I18N.en \
OPTIONS_SINGLE= MTA
OPTIONS_SINGLE_MTA= COURIER EXIM4 OPENSMTPD POSTFIX SENDMAIL
-OPTIONS_DEFINE= HTDIG NAMAZU2 NLS DOCS
-OPTIONS_DEFAULT= SENDMAIL
+OPTIONS_DEFINE= HTDIG NAMAZU2 NOMAILPWD NLS DOCS
+OPTIONS_DEFAULT= SENDMAIL NOMAILPWD
COURIER_DESC= for use with courier
EXIM4_DESC= for use with exim4
OPENSMTPD_DESC= for use with opensmtpd - EXPERIMENTAL -
@@ -80,6 +80,7 @@ POSTFIX_DESC= for use with postfix
SENDMAIL_DESC= for use with sendmail
HTDIG_DESC= - EXPERIMENTAL - htdig integration patches
NAMAZU2_DESC= Make private archives searchable with namazu2
+NOMAILPWD_DESC= Elide plaintext passwords from monthly reminders
MTA_DESC= Integrate with which MTA?
.include <bsd.port.options.mk>
@@ -142,6 +143,10 @@ RUN_DEPENDS+= mknmz:databases/namazu2
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Mailman-Cgi-private.py
.endif
+.if ${PORT_OPTIONS:MNOMAILPWD}
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-mailpasswds
+.endif
+
BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython@${PY_FLAVOR}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython@${PY_FLAVOR}