aboutsummaryrefslogtreecommitdiff
path: root/mail/majordomo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/majordomo/Makefile')
-rw-r--r--mail/majordomo/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/mail/majordomo/Makefile b/mail/majordomo/Makefile
index b16906c5ec20..4dc9b0393b1e 100644
--- a/mail/majordomo/Makefile
+++ b/mail/majordomo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= majordomo
PORTVERSION= 1.94.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= ftp://ftp.nuug.no/pub/anders/distfiles/ \
ftp://ftp.sgi.com/other/majordomo/1.94.5/ \
@@ -19,8 +19,6 @@ COMMENT= A mailing list manager
.if defined(WITH_SHA1_COOKIES)
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
-.else
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
.endif
USE_PERL5= yes
@@ -33,6 +31,14 @@ PKGMESSAGE= ${FILESDIR}/post-install-notes
DOCSDIR= ${PREFIX}/${PORTNAME}/doc
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_SHA1_COOKIES)
+. if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+. endif
+.endif
+
pre-fetch:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
${DIALOG} --yesno "WARNING: Majordomo is a really old mail list manager. The last version was released in january 2000, and there does not seem to be any updates coming. You might want to consider using mailman instead. Are you sure you want to install majordomo?" 8 70 no || ${FALSE}
@@ -103,4 +109,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>