aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/Makefile1
-rw-r--r--mail/cyrus-imapd34/Makefile22
-rw-r--r--mail/cyrus-imapd34/distinfo6
-rw-r--r--mail/cyrus-imapd34/files/patch-imap__tls.c22
-rw-r--r--mail/cyrus-imapd34/files/patch-imtest__imtest.c12
-rw-r--r--mail/cyrus-imapd34/files/patch-lib__byteorder.h16
-rw-r--r--mail/cyrus-imapd34/pkg-plist1
7 files changed, 35 insertions, 45 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 3ae3696d80a1..8388b9df8147 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -80,6 +80,7 @@
SUBDIR += cyrus-imapd25
SUBDIR += cyrus-imapd30
SUBDIR += cyrus-imapd32
+ SUBDIR += cyrus-imapd34
SUBDIR += cyrus2courier
SUBDIR += cyrus2dovecot
SUBDIR += davmail
diff --git a/mail/cyrus-imapd34/Makefile b/mail/cyrus-imapd34/Makefile
index af58d84c8c80..c136c5dd15d1 100644
--- a/mail/cyrus-imapd34/Makefile
+++ b/mail/cyrus-imapd34/Makefile
@@ -1,9 +1,9 @@
PORTNAME= cyrus-imapd
-PORTVERSION= 3.2.6
-PORTREVISION= 2
+PORTVERSION= 3.4.0
+#PORTREVISION= 0
CATEGORIES= mail
MASTER_SITES= https://github.com/cyrusimap/cyrus-imapd/releases/download/${PORTNAME}-${PORTVERSION}/
-PKGNAMESUFFIX= 32
+PKGNAMESUFFIX= 34
MAINTAINER= ume@FreeBSD.org
COMMENT= Cyrus mail server, supporting POP3 and IMAP4 protocols
@@ -38,7 +38,7 @@ CPPFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
USES+= shebangfix
-SHEBANG_FILES= imap/promdatagen snmp/snmpgen tools/config2header \
+SHEBANG_FILES= imap/promdatagen tools/config2header \
tools/masssievec tools/mkimap tools/translatesieve \
perl/sieve/scripts/*.pl
@@ -46,7 +46,7 @@ CPE_VENDOR= cmu
CPE_PRODUCT= cyrus_imap_server
OPTIONS_DEFINE= AUTOCREATE BACKUP CLAMAV HTTP IDLED LDAP MURDER \
- MYSQL NNTP PGSQL REPLICATION SNMP SQLITE SQUAT SRS \
+ MYSQL NNTP PGSQL REPLICATION SQLITE SQUAT SRS \
XAPIAN DOCS
OPTIONS_DEFAULT= AUTOCREATE IDLED SQLITE SQUAT SRS
OPTIONS_SUB= yes
@@ -57,6 +57,15 @@ BACKUP_CONFIGURE_ENABLE=backup
CLAMAV_DESC= Use ClamAV
CLAMAV_CONFIGURE_WITH= clamav
CLAMAV_LIB_DEPENDS= libclamav.so:security/clamav
+
+# OPTIONS_DEFINE+= CLD2
+# OPTIONS_DEFAULT+= CLD2
+# CLD2_DESC= Use CLD2
+# CLD2_CONFIGURE_WITH= cld2
+# CLD2_CONFIGURE_ENV= CLD2_CFLAGS="-I${LOCALBASE}/include" \
+# CLD2_LIBS="-L${LOCALBASE}/lib -lcld2"
+# CLD2_LIB_DEPENDS= libcld2.so:devel/cld2
+
HTTP_DESC= Enable HTTP support
HTTP_CONFIGURE_ENABLE= http
HTTP_LIB_DEPENDS= libical.so:devel/libical \
@@ -87,9 +96,6 @@ REPLICATION_CONFIGURE_ENABLE=replication
SRS_DESC= Enable Sender Rewriting Scheme support
SRS_CONFIGURE_ENABLE= srs
SRS_LIB_DEPENDS= libsrs2.so:mail/libsrs2
-SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
-SNMP_CONFIGURE_ON= --with-snmp=${LOCALBASE}
-SNMP_CONFIGURE_OFF= --with-snmp=no
SQLITE_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
SQLITE_BROKEN_OFF= SQLITE is required
SQUAT_DESC= Enable Squat support
diff --git a/mail/cyrus-imapd34/distinfo b/mail/cyrus-imapd34/distinfo
index fb2317ae24e0..b22ae2e5e1a6 100644
--- a/mail/cyrus-imapd34/distinfo
+++ b/mail/cyrus-imapd34/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1615286134
-SHA256 (cyrus-imapd-3.2.6.tar.gz) = 453958dd8b639aaada9a83c8941af2b403f76b47e4f035a8f0078170e0bacedf
-SIZE (cyrus-imapd-3.2.6.tar.gz) = 12282669
+TIMESTAMP = 1618834194
+SHA256 (cyrus-imapd-3.4.0.tar.gz) = 6a441a180d8224f496e279da7fdb24baa702800414206e5f26fc7d006b2eb2fa
+SIZE (cyrus-imapd-3.4.0.tar.gz) = 12514849
diff --git a/mail/cyrus-imapd34/files/patch-imap__tls.c b/mail/cyrus-imapd34/files/patch-imap__tls.c
deleted file mode 100644
index cc43b5c26384..000000000000
--- a/mail/cyrus-imapd34/files/patch-imap__tls.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- imap/tls.c.orig 2018-04-30 02:05:44 UTC
-+++ imap/tls.c
-@@ -734,7 +734,9 @@ EXPORTED int tls_init_serverengine(c
- off |= SSL_OP_ALL; /* Work around all known bugs */
- off |= SSL_OP_NO_SSLv2; /* Disable insecure SSLv2 */
- off |= SSL_OP_NO_SSLv3; /* Disable insecure SSLv3 */
-+#if defined(SSL_OP_NO_COMPRESSION)
- off |= SSL_OP_NO_COMPRESSION; /* Disable TLS compression */
-+#endif
-
- const char *tls_versions = config_getstring(IMAPOPT_TLS_VERSIONS);
-
-@@ -1465,7 +1467,9 @@ HIDDEN int tls_init_clientengine(int ver
- off |= SSL_OP_ALL; /* Work around all known bugs */
- off |= SSL_OP_NO_SSLv2; /* Disable insecure SSLv2 */
- off |= SSL_OP_NO_SSLv3; /* Disable insecure SSLv3 */
-+#if defined(SSL_OP_NO_COMPRESSION)
- off |= SSL_OP_NO_COMPRESSION; /* Disable TLS compression */
-+#endif
-
- SSL_CTX_set_options(c_ctx, off);
- SSL_CTX_set_info_callback(c_ctx, apps_ssl_info_callback);
diff --git a/mail/cyrus-imapd34/files/patch-imtest__imtest.c b/mail/cyrus-imapd34/files/patch-imtest__imtest.c
deleted file mode 100644
index 0ae1041e4d5b..000000000000
--- a/mail/cyrus-imapd34/files/patch-imtest__imtest.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- imtest/imtest.c.orig 2015-11-30 06:30:33 UTC
-+++ imtest/imtest.c
-@@ -503,7 +503,9 @@ static int tls_init_clientengine(int ver
- off |= SSL_OP_ALL; /* Work around all known bugs */
- off |= SSL_OP_NO_SSLv2; /* Disable insecure SSLv2 */
- off |= SSL_OP_NO_SSLv3; /* Disable insecure SSLv3 */
-+#if defined(SSL_OP_NO_COMPRESSION)
- off |= SSL_OP_NO_COMPRESSION; /* Disable TLS compression */
-+#endif
- SSL_CTX_set_options(tls_ctx, off);
- SSL_CTX_set_info_callback(tls_ctx, apps_ssl_info_callback);
-
diff --git a/mail/cyrus-imapd34/files/patch-lib__byteorder.h b/mail/cyrus-imapd34/files/patch-lib__byteorder.h
new file mode 100644
index 000000000000..a0b2f7e2fabd
--- /dev/null
+++ b/mail/cyrus-imapd34/files/patch-lib__byteorder.h
@@ -0,0 +1,16 @@
+--- lib/byteorder.h.orig 2021-01-07 01:26:49 UTC
++++ lib/byteorder.h
+@@ -61,7 +61,12 @@
+ # define ntohll(x) (x)
+
+ #else /* small-endian machines */
+-# if defined(__GNUC__) && __GNUC_PREREQ(4, 3)
++# if defined(__GNUC__) && !defined(__clang__)
++# if __GNUC_PREREQ(4, 3)
++# define GNUC_PREREQ_4_3 1
++# endif
++# endif
++# if defined(GNUC_PREREQ_4_3)
+ /* Remove existing macros if present */
+ # undef ntohl
+ # undef htonl
diff --git a/mail/cyrus-imapd34/pkg-plist b/mail/cyrus-imapd34/pkg-plist
index 5eb57e3c94d8..1c3a21ab087f 100644
--- a/mail/cyrus-imapd34/pkg-plist
+++ b/mail/cyrus-imapd34/pkg-plist
@@ -110,6 +110,7 @@ include/cyrus/mpool.h
include/cyrus/murmurhash2.h
include/cyrus/nonblock.h
include/cyrus/parseaddr.h
+include/cyrus/procinfo.h
include/cyrus/retry.h
include/cyrus/rfc822tok.h
include/cyrus/sieve/sieve_err.h