aboutsummaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
Diffstat (limited to 'mail')
-rw-r--r--mail/pear-Contact_Vcard_Parse/Makefile8
-rw-r--r--mail/pear-Mail_mimeDecode/Makefile13
-rw-r--r--mail/pear-Net_Cyrus/Makefile12
-rw-r--r--mail/pear-Net_IMAP/Makefile12
-rw-r--r--mail/pear-Net_LMTP/Makefile8
5 files changed, 17 insertions, 36 deletions
diff --git a/mail/pear-Contact_Vcard_Parse/Makefile b/mail/pear-Contact_Vcard_Parse/Makefile
index 72e1300d6037..05c0aea65798 100644
--- a/mail/pear-Contact_Vcard_Parse/Makefile
+++ b/mail/pear-Contact_Vcard_Parse/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Contact_Vcard_Parse
-# Date created: 30 May 2005
-# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
-#
+# Created by: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
# $FreeBSD$
-#
PORTNAME= Contact_Vcard_Parse
PORTVERSION= 1.32.0
@@ -15,6 +11,8 @@ COMMENT= PEAR class to parse vCard 2.1 and 3.0 files
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+PEAR_AUTOINSTALL= yes
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/mail/pear-Mail_mimeDecode/Makefile b/mail/pear-Mail_mimeDecode/Makefile
index 032d49408ab8..d85a4c4986de 100644
--- a/mail/pear-Mail_mimeDecode/Makefile
+++ b/mail/pear-Mail_mimeDecode/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Mail_mimeDecode
-# Date created: 21 June 2007
-# Whom: Zhen REN <bg1tpt@gmail.com>
-#
+# Created by: Zhen REN <bg1tpt@gmail.com>
# $FreeBSD$
-#
PORTNAME= Mail_mimeDecode
PORTVERSION= 1.5.5
@@ -15,13 +11,12 @@ COMMENT= Provides a class to decode mime messages
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime
LICENSE= BSD
-CATEGORY= Mail
-FILES= mimeDecode.php
-TESTS= parse_header_value.phpt semicolon_content_type_bug1724.phpt
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/mail/pear-Net_Cyrus/Makefile b/mail/pear-Net_Cyrus/Makefile
index 409f74b05c47..1b12db96afc8 100644
--- a/mail/pear-Net_Cyrus/Makefile
+++ b/mail/pear-Net_Cyrus/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Net_Cyrus
-# Date created: 12 March 2004
-# Whom: Attila Nagy <bra@fsn.hu>
-#
+# Created by: Attila Nagy <bra@fsn.hu>
# $FreeBSD$
-#
PORTNAME= Net_Cyrus
PORTVERSION= 0.3.1
@@ -14,10 +10,10 @@ COMMENT= PEAR class to administer Cyrus IMAP servers
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
${PEARDIR}/Net/IMAP.php:${PORTSDIR}/mail/pear-Net_IMAP
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
+ ${PEARDIR}/Net/IMAP.php:${PORTSDIR}/mail/pear-Net_IMAP
-CATEGORY= Net
-FILES= Cyrus.php
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/mail/pear-Net_IMAP/Makefile b/mail/pear-Net_IMAP/Makefile
index b75f0a0b9569..0d40bf3f52b8 100644
--- a/mail/pear-Net_IMAP/Makefile
+++ b/mail/pear-Net_IMAP/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-Net_IMAP
-# Date created: 12 march 2004
-# Whom: Attila Nagy <bra@fsn.hu>
-#
+# Created by: Attila Nagy <bra@fsn.hu>
# $FreeBSD$
-#
PORTNAME= Net_IMAP
PORTVERSION= 1.1.0
@@ -14,10 +10,10 @@ COMMENT= PEAR class that provides an implementation of the IMAP protocol
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket \
+ ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
-CATEGORY= Net
-FILES= IMAP.php IMAPProtocol.php
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
diff --git a/mail/pear-Net_LMTP/Makefile b/mail/pear-Net_LMTP/Makefile
index d4a6456088ea..675ad1254f55 100644
--- a/mail/pear-Net_LMTP/Makefile
+++ b/mail/pear-Net_LMTP/Makefile
@@ -13,13 +13,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR implementation of the RFC2033 LMTP protocol
BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-CATEGORY= Net
-PEAR_CATSRC= yes
-FILES= LMTP.php
-TESTS= test_lmtp.php
-_TESTSDIR= .
+PEAR_AUTOINSTALL= yes
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"