aboutsummaryrefslogtreecommitdiff
path: root/math/asymptote
diff options
context:
space:
mode:
Diffstat (limited to 'math/asymptote')
-rw-r--r--math/asymptote/Makefile14
-rw-r--r--math/asymptote/distinfo6
-rw-r--r--math/asymptote/files/patch-settings.cc20
-rw-r--r--math/asymptote/pkg-plist6
4 files changed, 26 insertions, 20 deletions
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index 291bd2398f23..fab6c9989fc7 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -1,13 +1,10 @@
PORTNAME= asymptote
-PORTVERSION= 2.81
-PORTREVISION= 5
+PORTVERSION= 2.92
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
-PATCH_SITES= https://github.com/vectorgraphics/asymptote/commit/
-PATCHFILES+= fa28442195bd99b9bac87e3ff752953ac57ee172.patch:-p1 # backport fix for https://github.com/vectorgraphics/asymptote/issues/328
-
MAINTAINER= nivit@FreeBSD.org
COMMENT= Powerful script-based vector graphics language
WWW= https://asymptote.sourceforge.io/
@@ -21,9 +18,10 @@ LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libcurl.so:ftp/curl \
libsigsegv.so:devel/libsigsegv
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cson>=0.8:devel/py-cson@${PY_FLAVOR} \
- ${PY_PILLOW}
+ ${PY_PILLOW} \
+ xdg-open:devel/xdg-utils
-USES= compiler:c++14-lang gettext-runtime ghostscript gl gmake gnome ncurses perl5 python \
+USES= bison compiler:c++14-lang gettext-runtime ghostscript gl gmake gnome ncurses perl5 python \
pyqt:5 shebangfix tar:tgz tex
SHEBANG_FILES= GUI/*.py
USE_GL= gl glu glut
@@ -84,7 +82,7 @@ PORTEXAMPLES= *
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
+.if ${OPSYS} == FreeBSD
USES+= llvm:max=15
.endif
diff --git a/math/asymptote/distinfo b/math/asymptote/distinfo
index 8ecccc39b64b..3c2a12cba1e6 100644
--- a/math/asymptote/distinfo
+++ b/math/asymptote/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1658909077
-SHA256 (asymptote-2.81.src.tgz) = 768eba48c877373a810d991d482f88480643291aae68fa2abc3aa3d5a7ed0073
-SIZE (asymptote-2.81.src.tgz) = 15062426
+TIMESTAMP = 1728465593
+SHA256 (asymptote-2.92.src.tgz) = 9d9b5c6fa7e0fbce3c1e54feb25e2d51d28c4fe7798f24c76cdcae8291a8ea66
+SIZE (asymptote-2.92.src.tgz) = 17075592
SHA256 (fa28442195bd99b9bac87e3ff752953ac57ee172.patch) = 88d733ec69d5c0b03a866ef20d4e6f3cf308ebd048143d2ce34dcaaaf1fa357b
SIZE (fa28442195bd99b9bac87e3ff752953ac57ee172.patch) = 667
diff --git a/math/asymptote/files/patch-settings.cc b/math/asymptote/files/patch-settings.cc
index b14cf2fbc960..aa044a38e8d1 100644
--- a/math/asymptote/files/patch-settings.cc
+++ b/math/asymptote/files/patch-settings.cc
@@ -1,11 +1,15 @@
---- settings.cc.orig 2019-10-03 16:43:08 UTC
+--- settings.cc.orig 2024-10-07 18:22:37 UTC
+++ settings.cc
-@@ -99,7 +99,7 @@ string defaultPDFViewer="open";
+@@ -101,9 +101,9 @@ string defaultHTMLViewer="open";
+ string defaultPDFViewer="open";
string defaultHTMLViewer="open";
- #else
- string defaultPSViewer="gv";
--string defaultPDFViewer="acroread";
-+string defaultPDFViewer="gv";
- string defaultHTMLViewer="google-chrome";
- #endif
+ #else
+-string defaultPSViewer="evince";
+-string defaultPDFViewer="evince";
+-string defaultHTMLViewer="google-chrome";
++string defaultPSViewer="gv";
++string defaultPDFViewer="xdg-open";
++string defaultHTMLViewer="xdg-open";
+ #endif
string defaultGhostscript="gs";
+ string defaultGhostscriptLibrary="";
diff --git a/math/asymptote/pkg-plist b/math/asymptote/pkg-plist
index 7b893a6475b3..6942c6f9ce16 100644
--- a/math/asymptote/pkg-plist
+++ b/math/asymptote/pkg-plist
@@ -1,6 +1,7 @@
bin/asy
bin/xasy
%%DATADIR%%/CAD.asy
+%%DATADIR%%/GUI/ContextWindow.py
%%DATADIR%%/GUI/CustMatTransform.py
%%DATADIR%%/GUI/DebugFlags.py
%%DATADIR%%/GUI/GuidesManager.py
@@ -25,7 +26,6 @@ bin/xasy
%%DATADIR%%/GUI/pyUIClass/widg_editBezier.py
%%DATADIR%%/GUI/pyUIClass/widgetPointEditor.py
%%DATADIR%%/GUI/pyUIClass/window1.py
-%%DATADIR%%/GUI/res/icons.qrc
%%DATADIR%%/GUI/res/icons/anchor.svg
%%DATADIR%%/GUI/res/icons/android-arrow-back.svg
%%DATADIR%%/GUI/res/icons/android-arrow-forward.svg
@@ -117,6 +117,7 @@ bin/xasy
%%DATADIR%%/labelpath3.asy
%%DATADIR%%/lmfit.asy
%%DATADIR%%/map.asy
+%%DATADIR%%/mapArray.asy
%%DATADIR%%/markers.asy
%%DATADIR%%/math.asy
%%DATADIR%%/metapost.asy
@@ -155,10 +156,12 @@ bin/xasy
%%DATADIR%%/shaders/screen.glsl
%%DATADIR%%/shaders/sum1.glsl
%%DATADIR%%/shaders/sum2.glsl
+%%DATADIR%%/shaders/sum2fast.glsl
%%DATADIR%%/shaders/sum3.glsl
%%DATADIR%%/shaders/vertex.glsl
%%DATADIR%%/shaders/zero.glsl
%%DATADIR%%/simplex.asy
+%%DATADIR%%/simplex2.asy
%%DATADIR%%/size10.asy
%%DATADIR%%/size11.asy
%%DATADIR%%/slide.asy
@@ -197,6 +200,7 @@ share/info/asymptote/Hobbycontrol.png
share/info/asymptote/Hobbydir.png
share/info/asymptote/asymptote.info
share/info/asymptote/axis3.png
+share/info/asymptote/basealign.png
share/info/asymptote/bezier.png
share/info/asymptote/bezier2.png
share/info/asymptote/beziercurve.png