aboutsummaryrefslogtreecommitdiff
path: root/math/cloog/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/cloog/Makefile')
-rw-r--r--math/cloog/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/math/cloog/Makefile b/math/cloog/Makefile
new file mode 100644
index 000000000000..ee8f5e65211a
--- /dev/null
+++ b/math/cloog/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= cloog
+PORTVERSION= 0.18.0
+CATEGORIES= math
+MASTER_SITES= http://www.bastoul.net/cloog/pages/download/
+
+MAINTAINER= danilogondolfo@gmail.com
+COMMENT= Code generator in the polyhedral model
+
+LIB_DEPENDS= gmp:${PORTSDIR}/math/gmp
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-gmp-prefix=${PREFIX}
+CONFIGURE_ENV= pkgconfig_libdir=${PREFIX}/libdata/pkgconfig/
+
+MAKE_JOBS_SAFE= yes
+
+post-install:
+ ${LN} -s ${PREFIX}/lib/libcloog-isl.so.4 \
+ ${PREFIX}/lib/libcloog-isl.so.0
+ ${LN} -s ${PREFIX}/lib/libisl.so.11 \
+ ${PREFIX}/lib/libisl.so.0
+
+.include <bsd.port.mk>