aboutsummaryrefslogtreecommitdiff
path: root/math/freefem++/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/freefem++/Makefile')
-rw-r--r--math/freefem++/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 879d2051df2e..342803365596 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -1,7 +1,6 @@
PORTNAME= freefem++
DISTVERSIONPREFIX= v
-DISTVERSION= 4.13
-PORTREVISION= 5
+DISTVERSION= 4.14
CATEGORIES= math science
MAINTAINER= yuri@FreeBSD.org
@@ -27,12 +26,11 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libscotch.so:cad/scotch \
libcmumps.so:math/mumps \
libnlopt.so:math/nlopt \
- libsuperlu.so:math/superlu \
- libsz.so:science/libaec
+ libsuperlu.so:math/superlu
RUN_DEPENDS= bash:shells/bash \
pipe:misc/pipe
-USES= autoreconf bison blaslapack:openblas compiler:c++14-lang fortran \
+USES= autoreconf bison blaslapack:openblas compiler:c++14-lang fortran \
gl gmake localbase perl5 pkgconfig shebangfix xorg
USE_GITHUB= yes
@@ -47,6 +45,8 @@ CPPFLAGS+= -I${LOCALBASE}/include/superlu
LDFLAGS+= -s
.endif
+LDFLAGS+= -pthread # workaround for https://github.com/FreeFem/FreeFem-sources/issues/296#issuecomment-1839198380
+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CNOFLAGS="${CFLAGS}" LIBS=-lz
CONFIGURE_ARGS= --disable-download \