aboutsummaryrefslogtreecommitdiff
path: root/math/hs-syfco/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/hs-syfco/Makefile')
-rw-r--r--math/hs-syfco/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/math/hs-syfco/Makefile b/math/hs-syfco/Makefile
new file mode 100644
index 000000000000..00f3a2e14f19
--- /dev/null
+++ b/math/hs-syfco/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= syfco
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1-34
+DISTVERSIONSUFFIX= -g0f0f6a6
+CATEGORIES= math lang haskell
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Synthesis Format Conversion Tool
+WWW= https://github.com/reactive-systems/syfco
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cabal
+
+USE_GITHUB= yes
+GH_ACCOUNT= reactive-systems
+
+USE_CABAL= convertible-1.1.1.1 \
+ old-locale-1.0.0.7_2 \
+ old-time-1.1.0.3_2
+CABAL_FLAGS= -relocatable
+
+CABAL_EXECUTABLES= syfco
+CABAL_WRAPPER_SCRIPTS= ${CABAL_EXECUTABLES}
+
+PLIST_FILES= bin/syfco \
+ libexec/cabal/syfco
+
+.include <bsd.port.mk>