aboutsummaryrefslogtreecommitdiff
path: root/math/kamis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/kamis/Makefile')
-rw-r--r--math/kamis/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/math/kamis/Makefile b/math/kamis/Makefile
index 2794cab7f0bc..2185a844f918 100644
--- a/math/kamis/Makefile
+++ b/math/kamis/Makefile
@@ -10,6 +10,9 @@ COMMENT= Maximum independent sets and vertex covers of large sparse graphs
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_armv6= fatal error: 'omp.h' file not found
+BROKEN_armv7= fatal error: 'omp.h' file not found
+
USES= cmake
USE_LDCONFIG= yes
@@ -22,4 +25,10 @@ PLIST_FILES= bin/graphchecker \
bin/redumis \
bin/sort_adjacencies
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1301000
+BROKEN_riscv64= fatal error: 'omp.h' file not found
+.endif
+
+.include <bsd.port.post.mk>