aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-es/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-es/Makefile')
-rw-r--r--math/octave-forge-es/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/octave-forge-es/Makefile b/math/octave-forge-es/Makefile
index 3da256693b40..793141762c76 100644
--- a/math/octave-forge-es/Makefile
+++ b/math/octave-forge-es/Makefile
@@ -13,12 +13,16 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
-WRKSRC= ${WRKDIR}/${OCTAVE_PKGNAME}/src
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+WRKSRC= ${WRKDIR}/${OCTSRC}/src
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>