aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-fpl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-fpl/Makefile')
-rw-r--r--math/octave-forge-fpl/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/octave-forge-fpl/Makefile b/math/octave-forge-fpl/Makefile
index 10c07077a9f9..6e17542daea7 100644
--- a/math/octave-forge-fpl/Makefile
+++ b/math/octave-forge-fpl/Makefile
@@ -13,6 +13,10 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
RUN_DEPENDS+= dx:${PORTSDIR}/graphics/opendx
.include <bsd.port.pre.mk>
@@ -22,6 +26,6 @@ do-build:
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>